Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 181162

Summary: media-gfx/gimp-2.3.16 crash w/ x11-libs/libX11-1.1.2 - X BadWindow error when attempting to edit image
Product: Gentoo Linux Reporter: Ryan Tandy <ryan>
Component: New packagesAssignee: Hanno Böck <hanno>
Status: RESOLVED FIXED    
Severity: normal CC: cr0nDaem0n, jakub, keaneyw, mkyral, nelchael, neysx, sybillel, tolich.arz, x11
Priority: High    
Version: 2007.0   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 181707    
Bug Blocks:    

Description Ryan Tandy 2007-06-07 05:02:59 UTC
Steps to reproduce:
1) Open The GIMP.
2) Create a new image.
3) Attempt to draw on the canvas with f.ex the pencil tool.

Expected results: Artwork!
Actual results:

The program 'gimp' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 34369 error_code 3 request_code 39 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(script-fu:15790): LibGimpBase-WARNING **: script-fu: wire_read(): error

I am using gimp-2.3.16 and openbox-3.4.0.  Last time I used gimp was back around the middle of April, when I was using Beryl.  Aside from regular updates, the window manager is the only significant change to my system since then.  I rebuilt gimp, but it didn't help.

I Googled the error message, but the only results I got placed the blame on clipboard managers such as Klipper, which I'm not using.

tarpman@peregrine ~ $ emerge --info
Portage 2.1.2.9 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r3, 2.6.21-gentoo-r2 i686)
=================================================================
System uname: 2.6.21-gentoo-r2 i686 Genuine Intel(R) CPU T2400 @ 1.83GHz
Gentoo Base System release 2.0.0_alpha3
Timestamp of tree: Wed, 06 Jun 2007 23:50:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=nocona -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-Os -march=nocona -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="ftp://gentoo.osuosl.org/pub/gentoo"
LANG="en_CA.utf8"
LC_ALL="en_CA.utf8"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/tarpman"
SYNC="rsync://rsync1.ca.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acpi alsa amr ao async berkdb bittorrent branding bzip2 cairo caps cscope custom-cflags dbus divx dri dts dv dvd dvdnav dvdread expat fam ftp gdbm gif glitz gmedia hal hpn iconv idn insecure-savers ithreads javascript jpeg logrotate mad mailwrapper math midi mmap mmx mmxext mp3 mpeg msn multicall ncurses nethack no-old-linux nptl nptlonly nsplugin offensive opengl pam pango pcre pdf pic png quicktime readline samba slang smp srt sse sse2 ssl startup-notification svg symlink theora threads truetype unicode urandom vim vim-pager vim-syntax vim-with-x vorbis wifi win32codecs wmp x264 x86 xcb xml xorg xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="none nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Marian Kyral 2007-06-07 06:27:20 UTC
I have the same problem.

This is a development version of GIMP.  Debug messages may appear here.

(null): image-type contains unrecognizable parts:'Image with 2 layers'
jpeg-load: found EXIF block (13315 bytes)
The program 'gimp' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 96884 error_code 3 request_code 39 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(script-fu:624): LibGimpBase-WARNING **: script-fu: wire_read(): error
---------------------------------------------------------------------------------

Portage 2.1.2.9 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r3, 2.6.21-gentoo-r2 i686)
=================================================================
System uname: 2.6.21-gentoo-r2 i686 AMD Athlon(tm) 2600+
Gentoo Base System release 1.12.10
Timestamp of tree: Thu, 07 Jun 2007 05:20:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.supp.name/ ftp://ftp.sh.cvut.cz/MIRRORS/gentoo/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="cs_CZ.utf8"
LDFLAGS="-Wl,-O1,--enable-new-dtags,--sort-common,-s"
LINGUAS="en cs"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X a52 aac aalib acl acpi alsa apache2 berkdb bzip2 cairo cdparanoia cdr cli cracklib crypt cups curl dbus directfb dri dts dv dvb dvd dvdr dvdread emboss encode evo exif fam ffmpeg firefox flac font-server foomaticdb ftp gd gdbm gif gimp gimpprint gpm gstreamer hal iconv icq icu imagemagick ipv6 isdnlog java javascript joystick jpeg kde kdeenablefinal kerberos kipi ldap libg++ live lm_sensors lzo mad matroska midi mikmod mmx mmxext mng mozsvg mp3 mpeg msn mudflap musepack mysql mysqli ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl php pic png posix pppd python qt3 qt3support qt4 quicktime readline real reflection sdl session slang spell spl sqlite sse sse2 ssl subversion svg symlink tcpd theora tiff truetype truetype-fonts type1-fonts unicode usb vcd vorbis win32codecs wmf x264 x86 xcomposite xml xorg xv xvid zip zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en cs" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 William Keaney 2007-06-07 13:13:17 UTC
I ran into the same error, and found this bug: http://bugs.archlinux.org/task/7370
I'm downgrading my libX11 back to 1.1.1-r1 to see if this fixes the issue.  Will report any results.
Comment 3 William Keaney 2007-06-07 13:26:55 UTC
Downgrading to x11-libs/libX11-1.1.1-r1 fixed this problem for me.  I can now draw on and edit images in GIMP without crashing.
Comment 4 Łukasz Damentko (RETIRED) gentoo-dev 2007-06-10 02:36:27 UTC
*** Bug 181481 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-06-14 17:08:00 UTC
*** Bug 182041 has been marked as a duplicate of this bug. ***
Comment 7 Doug Goldstein (RETIRED) gentoo-dev 2007-06-15 21:51:37 UTC
Please re-test with libX11-1.1.2-r1
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-06-16 11:16:25 UTC
(In reply to comment #7)
> Please re-test with libX11-1.1.2-r1

Fixed, thanks! 

Comment 9 Anatoly Arzhnikov 2007-06-16 18:58:21 UTC
Confirm, fixed