Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 181159

Summary: media-plugins/audacious-plugins-1.3.4 does not compile flac plugin with flac use flag
Product: Gentoo Linux Reporter: Steve Warren <warrensg2001>
Component: New packagesAssignee: Tony Vroon <chainsaw>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: sound
Priority: High    
Version: 2006.0   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: audacious-plugins build log
audacious log

Description Steve Warren 2007-06-07 00:59:25 UTC
media-plugins/audacious-plugins-1.3.4 does not compile flac plugin with flac use flag. Tried to rebuild flac and assign flac use flag from command, still no flac plugin.

Reproducible: Always

Steps to Reproduce:
1.USE="flac" emerge audacious-plugins
2.
3.

Actual Results:  
builds all plugins specified by my use flags except for flac

Expected Results:  
build all plugins spcefied by my use flags

 # emerge --info
Portage 2.1.2.7 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.5-r2, 2.6.20-gentoo-r8-01 i686)
=================================================================
System uname: 2.6.20-gentoo-r8-01 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Thu, 07 Jun 2007 00:30:08 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-java/java-config: 1.3.7, 2.0.32
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS="en_US ja ko zh_CN zh_TW"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi aim alsa arts audiofile avi bash-completion berkdb bitmap-fonts bonobo bzlib cdb cdr cjk cli cracklib crypt cups curl curlwrappers dga dio divix4linux dri dvd dvdr encode esd fam fbcon flac font-server foomaticdb fortran ftp gb gd gdbm gif glitz gnutils gphoto2 gpm gstreamer gtk gtk2 iconv ipv6 isdnlog jack java jikes jpeg kde libg++ mad mbox midi mime mmx mozilla mpeg msn mudflap ncurses nls nptl nptlonly nsplugin nvidia oggvorbis openall opengl openmp oss pam pcre pdf pdflib perl png posix pppd python quicktime readline reflection samba session slang sockets softmmu spell spl sse sse2 ssl svg svga tcl tcpd tetex theora tiff tk truetype truetype-fonts type1-fonts unicode videos win32codecs x86 xine xml xml2 xorg yahoo zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US ja ko zh_CN zh_TW" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Tony Vroon gentoo-dev 2007-06-07 08:34:09 UTC
Please include the output of:
emerge -pv flac
Comment 2 Tony Vroon gentoo-dev 2007-06-07 16:14:56 UTC
Please test on 1.3.5; if the problem is still there I will need the emerge -pv flac output that I asked for.
Comment 3 Steve Warren 2007-06-07 18:21:32 UTC
No change with audacious-plugins-1.3.5.

emerge -pv flac

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/flac-1.1.2-r8  USE="sse -3dnow -debug -doc -ogg" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Comment 4 Tony Vroon gentoo-dev 2007-06-07 19:22:13 UTC
Alright, I will need the full build output and the diagnostic message output. Please compile audacious-plugins like so:

emerge audacious-plugins &> audacious-plugins.buildlog

Attach the resulting file here, be sure to select text/plain.

Then start audacious as follows:
audacious &> audacious.log

And also attach the resulting file here.
Comment 5 Steve Warren 2007-06-07 20:00:38 UTC
Created attachment 121445 [details]
audacious-plugins build log

Attached audacious-plugins.buildlog
Comment 6 Steve Warren 2007-06-07 20:01:55 UTC
Created attachment 121446 [details]
audacious log

attached audacious.log