Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 181082

Summary: media-video/mplayer new useflag a52 not enabled by default
Product: Gentoo Linux Reporter: Andrew Hurst <a.hurst>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: VERIFIED UPSTREAM    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Andrew Hurst 2007-06-06 14:23:32 UTC
Updating mplayer to latest mplayer stable release broke the sound on DVD video.

The lastest stable release of mplayer (mplayer-1.0.20070321) has a new use flag 'a52' which is needed to play the audio from a good proportion of today's DVDs (PAL ones certainly - I'm in the UK)

This useflag is not enabled by default in e.g. /usr/portage/profiles/default-linux/x86/desktop/make.defaults

- whereas the 'win32codecs' useflag, which provides video codecs for Microsoft proprietary video formats, is enabled here.


Reproducible: Always

Steps to Reproduce:
1.update to mplayer-1.0.20070321, using default linux desktop profile
2.play a dvd
3.
Comment 1 Austin McKinley 2007-06-06 15:04:22 UTC
yes, this is a huge bummer. same issue here.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-06-06 16:50:53 UTC
Take such stuff to gentoo-dev ML; the default profiles are already bloated enough with junk.
Comment 3 Andrew Hurst 2007-06-06 18:19:56 UTC
I see where you're coming from.
Why was the new use flag added?

My reasoning was that since the win32codecs useflag lives there, then a52, which does a very similar thing, to an almost identical set of packages ought to be with it.

Would it be better to remove the useflag from mplayer (I can't think why one would want to be able to compile it without dvd audio support),
or advise to put the a52 useflag in /etc/portage/package.use ?
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-06-06 18:50:57 UTC
(In reply to comment #3)

The fact that there's already load of cruft in default profile's USE (why on earth does everyone need kerberos e.g.) is no valid reason to add even more to global USE. As said, discuss such things at gentoo-dev mailing list. Or come back to us when people are allowed to use per-ebuild defaults in IUSE.
Comment 5 Steve Dibb (RETIRED) gentoo-dev 2007-06-24 23:17:04 UTC
Changed ebuild so a52 wont be disabled unless -dvd is used.