Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 180096

Summary: www-client/mozilla-firefox- crashes on specific website
Product: Gentoo Linux Reporter: Thomas Frenzel <syslock>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: gdb output with backtrace

Description Thomas Frenzel 2007-05-28 10:18:53 UTC
Firefox is crashing, when klicking on "forums"-button on website:

Reproducible: Always

Steps to Reproduce:
1. open firefox
2. enter in the address bar
3. klick on "forums"-button on that website

Actual Results:  
firefox-bin seems to be terminated by some exception in JS_Assert in jsutil.c

this was tried with:

Mozilla/5.0 (X11; U; Linux i686; de; rv: Gecko/20070523 Firefox/

- fresh ~/.mozilla
- all extensions disabled
- all plugins removed
- default-theme
- language-packs disabled

ebuild & setup:

[ebuild   R   ] www-client/mozilla-firefox-  USE="debug gnome ipv6 java mozdevelop xforms xprint -bindist -filepicker -moznopango -restrict-javascript -xinerama" LINGUAS="de zh_CN -af -ar -be -bg -ca -cs -da -el -en_GB -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ru -sk -sl -sv -sv_SE -tr -zh -zh_TW" 0 kB 

see attachments for gdb output and backtrace
Comment 1 Thomas Frenzel 2007-05-28 10:21:51 UTC
Created attachment 120505 [details]
gdb output with backtrace
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-05-28 10:38:21 UTC
No crash here; try with a fresh *clean* profile.
Comment 3 Thomas Frenzel 2007-05-28 10:45:09 UTC
(In reply to comment #2)
> No crash here; try with a fresh *clean* profile.

As already stated i was able to reproduce this with a fresh ~/.mozilla, autogenerated by firefox on startup. Is that what you mean?
Comment 4 Marijn Schouten (RETIRED) gentoo-dev 2007-05-28 10:47:05 UTC
only firefox-bin or firefox too?
Comment 5 Thomas Frenzel 2007-05-28 10:55:48 UTC
(In reply to comment #4)
> only firefox-bin or firefox too?

This bug is about www-client/mozilla-firefox, that is the source package. I didn't test www-client/mozilla-firefox-bin.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-05-28 10:57:32 UTC
(In reply to comment #5)
> I didn't test www-client/mozilla-firefox-bin.

So do it, please.
Comment 7 Thomas Frenzel 2007-05-28 12:13:40 UTC
Hum, I tried to test this with mozilla-firefox-bin right now, but /opt/firefox/firefox-bin keeps crashing during startup already. I do not know where to get debugging information for the binary package. Strace shows a SIGSEGV after some call to gettimeofday(), whilst ltrace shows a SIGTRAP after a call to PR_AtomicIncrement somewhere within the first call to nsCOMPtr_base::assign_from_gs_contractid... whatever that means.

I assume that the binary package should work on most systems, so there really might be broken something with my one... in a strange manner... :|