Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 178752

Summary: get rid of gcc 3.3.6 (libstdc++.so.5) dependency
Product: Gentoo Linux Reporter: Lars Langhans <lars.langhans>
Component: Current packagesAssignee: Portage team <dev-portage>
Status: RESOLVED DUPLICATE    
Severity: normal CC: togge.gentoo
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Lars Langhans 2007-05-16 12:15:58 UTC
I removed gcc 3.3.6 from my environment, now Skype doesn't work any longer. Isn't it not a good idea to supply the libstdc++.so.5 with this package (skype) also. AFAIK in StarOffice 7 is also a extra libstdc++.so.5. Why not deliver such library in skype also, and all other "bin" packages which need such library.
I won't get back gcc 3.3.6 only for such library.
Or isn't it better to create a libcompat-libstdcpp5 which will only include if a USE flag e.g. "libstdcpp5" exist?

I copied a libstdc++.so.5 to /opt/skype and add the follows into the /usr/bin/skype script

export LD_LIBRARY_PATH=${progpath}:${LD_LIBRARY_PATH}

If you find it a hack, me too, but it works for me. So why we need to compile gcc 3.3.6 only for get access to the libstdc++.so.5 for such binary closed source stuff?

Don't understand me wrong, this should be done only for binary packages.


Reproducible: Always

Steps to Reproduce:
1. install skype
2. remove gcc-3.3.6
3. try to start skype
4. try my patch above (get a libstdc++.so.5) from your gcc-3.3.6 or any other place in the world.
Comment 1 Gilles Dartiguelongue gentoo-dev 2007-05-16 12:29:51 UTC
you should have run revdep-rebuild

namely, try revdep-rebuild --library libstdc++.so.5

It should rebuild everything that was still using gcc 3.3

if that doesn't work, what you are suggesting is probably using sys-libs/libstdc++-v3
Comment 2 Togge 2007-05-16 13:03:01 UTC
The only "bug" here might be to prefer sys-libs/libstdc++-v3 over gcc-3.3, at least when I did a clean install the other day gcc-3.3 was preferred over sys-libs/libstdc++-v3.
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2007-05-16 14:18:50 UTC
And sys-libs/libstdc++-v3 is preferred, when you look virtual/libstdc++-3.3. I suppose the problem is here that Portage checks preference per package - and since GCC 4 is installed...


Portage team, is this issue already tracked in any bug wrt slot dependencies or so?
Comment 4 Petteri R├Ąty (RETIRED) gentoo-dev 2007-05-16 15:06:09 UTC
(In reply to comment #3)
> 
> 
> Portage team, is this issue already tracked in any bug wrt slot dependencies or
> so?
> 

yes bug 161953


*** This bug has been marked as a duplicate of bug 161953 ***