Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 17873

Summary: media-gfx/imagemagick- relocation errors
Product: Gentoo Linux Reporter: Nicolas Kaiser <nikai>
Component: New packagesAssignee: PPC Porters <ppc>
Severity: normal    
Priority: High    
Version: 1.0   
Hardware: PPC   
OS: Linux   
Package list:
Runtime testing required: ---

Description Nicolas Kaiser 2003-03-20 09:02:29 UTC
I'm getting relocation errors trying to access libMagick. I tried stripping all
useflags, but to no avail.

Reproducible: Always
Steps to Reproduce:
1. $ identify
Actual Results:  
identify: error while loading shared libraries:
/usr/lib/ R_PPC_REL24 relocation at 0x0ff04cfc for
symbol `Image' out of range

Expected Results:  
Version: ImageMagick 5.5.5 03/01/03 Q16
Copyright: Copyright (C) 2003 ImageMagick Studio LLC

Usage: identify [options ...] file [ [options ...] file ... ]


Portage 2.0.47-r10 (default-ppc-1.4, gcc-3.2.2, glibc-2.3.1-r2)
System uname: 2.4.20-ben8 ppc 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/3/share/config
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="mitshm ppc gnome-libs gtkhtml gdbm berkdb ggi tcltk tcpd pam libwww perl
python imlib motif ldap cdr aalib alsa apache2 apm -arts avi bonobo crypt cups
dga directfb dvd encode esd fbcon -flash gif gnome gphoto2 -gpm gtk gtk2 guile
-java jpeg -kde lcms mikmod mozilla mozsvg moznoirc moznomail moznocompose mysql
mpeg nls oggvorbis opengl oss pic plotutils png pnp quicktime -qt readline
-samba sdl slang spell ssl tetex tiff truetype X xface xv"
CFLAGS="-Os -pipe -mcpu=750 -fsigned-char"
CXXFLAGS="-Os -pipe -mcpu=750 -fsigned-char"
Comment 1 Graham Forest 2003-03-21 02:57:15 UTC
I've modified an ebuild and posted it at , if you would, I'd appreciate if you tested it.

Comment 2 Nicolas Kaiser 2003-03-21 07:43:24 UTC
No, sorry. I tried your ebuild, but "--enable-static" didn't do the trick for me.
I'm still getting

$ convert
convert: error while loading shared libraries: /usr/lib/ R_PPC_REL24 relocation at 0x0ff07d18 for symbol `Image' out of range
Comment 3 Nicolas Kaiser 2003-04-02 19:44:40 UTC
I still don't know what caused this problem, which haunted me for a long time.
However, I'm currently building a clean new system, and for the first time imagemagick is working!

In case somebody somewhere fixed something, thank you. If not, I don't know, maybe I installed some system library on the wrong day.

Thanks for listening. Have a nice day.
Comment 4 Graham Forest 2003-04-02 19:50:09 UTC
Wow, interesting timing, I just got an error trying to submit due to our disturbingly close commits. I was going to pass this on to a dev that might know what's up, but if that system ceased to exist, it may become rather hard to diagnose. I guess I'll mark it cantfix, and if it comes up again we can reopen it.
Comment 5 Martin Holzer (RETIRED) gentoo-dev 2003-10-01 09:20:00 UTC
db issue