Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 174121

Summary: sys-fs/diskdev_cmds - fsck.hfsplus crashes on amd64
Product: Gentoo Linux Reporter: Arne Babenhauserheide <arne_bab>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED UPSTREAM    
Severity: critical CC: hirakendu
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Arne Babenhauserheide 2007-04-11 08:08:28 UTC
On amd64 fsck.hfsplus from the diskdev_cmds packages crashes with a segmentation fault. 

There was another mentioning of this in the following bug, but the reporter was told to enter a new bug, and since that doesn't seem to have happened, I am now filing this bug: 
http://bugs.gentoo.org/show_bug.cgi?id=46342

Output of the util: 

fsck.hfsplus /dev/disk/by-label/Klangfeuer
** /dev/disk/by-label/Klangfeuer
** Checking HFS Plus volume.
Speicherzugriffsfehler

emerge --info: 
Portage 2.1.2.2 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.18-gentoo-r6 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 11 Apr 2007 07:20:01 +0000
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=k8"
DISTDIR="/var/distfiles"
EMERGE_DEFAULT_OPTS="--nospinner"
FEATURES="buildpkg ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict userfetch userpriv"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ "
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LINGUAS="eo es de en"
MAKEOPTS="-j2"
PKGDIR="/var/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/sunrise /usr/portage/local/layman/gentoo-de /usr/portage/local/layman/kde"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3ds X a52 aac addbookmarks alias alsa amd64 arts autoreplace avahi bash-completion berkdb bitmap-fonts bittorrent cairo cal3d cdr cli connectionstatus contactnotes cracklib crypt css cups curl dbus dri dv dvd dvdr dvdread dvdrip eds emacs emboss encode esd fam firefox flac fortran gadu gdbm gif gpm groupwise gstreamer hal highlight history iconv imagemagick ipod ipv6 irc isdnlog jingle jpeg kde kdehiddenvisibility latex ldap libcaca libg++ mad metalink midi mikmod mng mp3 mpeg mplayer ncurses nls nptl nptlonly offensive ogg oggvorbis opengl oss pam pcre perl png ppds pppd python qt3 qt4 quicktime readline reflection sametime sdl session slp speex spell spl ssl statistics svg symlink tcpd theora tiff timidity truetype truetype-fonts type1-fonts unicode vorbis webpresence xml xorg xscreensaver xv yahoo zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="eo es de en" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CTARGET, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always

Steps to Reproduce:
1.emerge diskdev_cmds (beforehand: unmask it in package.keywords via "sys-fs/diskdev_cmds **")
2.run fsck.hfsplus on a not cleanly unmounted ipod


Actual Results:  
Segmentation Fault

Expected Results:  
Clean the disk

Filed it as critical, because fsck.hfsplus crashes. I hope that was correct.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-04-11 08:13:56 UTC
I doesn't have any amd64 keyword. Feel free to reopen if you have a patch.
Comment 2 hirakendu 2009-10-01 21:20:43 UTC
Please also see my comment on http://bugs.gentoo.org/show_bug.cgi?id=46342#c37 .