Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 173630

Summary: [Future EAPI] Remove mention of DESTTREE and INSDESTTREE variables
Product: Gentoo Hosted Projects Reporter: SpanKY <vapier>
Component: PMS/EAPIAssignee: PMS/EAPI <pms>
Status: RESOLVED FIXED    
Severity: normal CC: esigra, mgorny
Priority: High    
Version: unspecified   
Hardware: All   
OS: All   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=595924
Whiteboard: in-eapi-7
Package list:
Runtime testing required: ---
Bug Depends on: 582966    
Bug Blocks: 174380    

Description SpanKY gentoo-dev 2007-04-07 08:36:17 UTC
nothing in the tree refers to EXEDESTTREE or DOCSDESTTREE anymore and ive changed portage so it doesnt respect these variables, so those can go now

i'm working on pruning INSDESTTREE and DESTTREE
Comment 1 Ciaran McCreesh 2007-04-11 20:11:29 UTC
r142 removes EXE and DOCS. The rest have to stay unless the tree is fixed before PMS is finalised.
Comment 2 Ulrich Müller gentoo-dev 2015-11-19 07:27:49 UTC
*** Bug 566178 has been marked as a duplicate of this bug. ***
Comment 3 Ulrich Müller gentoo-dev 2015-11-19 07:41:15 UTC
List of variables:
DESTTREE, INSDESTTREE
INSOPTIONS, DIROPTIONS, EXEOPTIONS, LIBOPTIONS

Eclasses still using these variables (some of them added by a certain mgorny :)
   distutils-r1.eclass
   java-utils-2.eclass
   python-utils-r1.eclass

These should probably be cleaned up first.
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-11-19 08:37:29 UTC
Some of them cleaned up on a certain EAPI 6 branch.
Comment 5 Ulrich Müller gentoo-dev 2015-11-19 10:03:07 UTC
Thinking about it, issues are different enough to deserve two bugs.

Using this bug for DESTTREE and INSDESTTREE.
Using bug 566178 for INSOPTIONS, DIROPTIONS, EXEOPTIONS, and LIBOPTIONS.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2016-05-13 21:54:58 UTC
Are we waiting with this for next EAPI, or doing it retroactively?
Comment 7 Ulrich Müller gentoo-dev 2016-05-13 22:07:53 UTC
(In reply to Michał Górny from comment #6)
> Are we waiting with this for next EAPI, or doing it retroactively?

Since these variables are (as of today) used in eclasses, I would say next EAPI.
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2016-05-14 06:15:26 UTC
Well, I was asking since you added the feasible tag. Since new EAPI is not anywhere in sight, I'll look into cleaning up the repository.
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-05-11 12:22:26 UTC
$ git grep DESTTREE | wc -l
0

Can we kill it now, please? ;-)
Comment 10 Ulrich Müller gentoo-dev 2017-05-11 14:11:55 UTC
(In reply to Michał Górny from comment #9)
> $ git grep DESTTREE | wc -l
> 0

Nice.

> Can we kill it now, please? ;-)

For PMS, I'd still use regular procedure (i.e., EAPI 7) because these two are in the big list of PM defined variables. Also removals aren't urgent, usually.

Maybe we could make it tree policy, i.e. add a repoman check?
Comment 11 Larry the Git Cow gentoo-dev 2018-03-04 21:04:59 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/portage.git/commit/?id=a5d0111d0bdaa7ee9e5c68e22b4a97ce415e119b

commit a5d0111d0bdaa7ee9e5c68e22b4a97ce415e119b
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2018-03-04 09:49:35 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2018-03-04 21:03:56 +0000

    Ban DESTTREE/INSDESTTREE in EAPI 7
    
    Ban the direct use of DESTTREE/INSDESTTREE in EAPI 7. Use new _E_*
    helper variables for into/insinto.
    
    Bug: https://bugs.gentoo.org/173630
    Closes: https://github.com/gentoo/portage/pull/261
    Series-Reviewed-by: Zac Medico <zmedico@gentoo.org>

 bin/eapi.sh                 |  4 ++++
 bin/ebuild-helpers/dobin    | 16 ++++++++++++----
 bin/ebuild-helpers/doconfd  |  4 ++--
 bin/ebuild-helpers/doenvd   |  4 ++--
 bin/ebuild-helpers/doheader |  4 ++--
 bin/ebuild-helpers/doins    | 18 +++++++++++++-----
 bin/ebuild-helpers/dolib    | 10 +++++++++-
 bin/ebuild-helpers/domo     | 16 ++++++++++++----
 bin/ebuild-helpers/dosbin   | 16 ++++++++++++----
 bin/phase-functions.sh      | 11 ++++++++---
 bin/phase-helpers.sh        | 33 +++++++++++++++++++++++----------
 bin/save-ebuild-env.sh      |  4 ++--
 12 files changed, 101 insertions(+), 39 deletions(-)}
Comment 12 Larry the Git Cow gentoo-dev 2018-04-30 22:14:23 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/pms.git/commit/?id=1d6bf595e8f17414b3d02956d87ce1a3636bf460

commit 1d6bf595e8f17414b3d02956d87ce1a3636bf460
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2017-09-29 03:13:57 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2018-03-30 16:35:43 +0000

    EAPI 7 removes DESTTREE and INSDESTTREE.
    
    Bug: https://bugs.gentoo.org/173630

 eapi-differences.tex |  8 ++++++++
 ebuild-env-vars.tex  | 19 ++++++++++++-------
 2 files changed, 20 insertions(+), 7 deletions(-)}