Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 169969

Summary: Bring back Gentoo x86 Universal CD
Product: Gentoo Release Media Reporter: Andrew Hurst <a.hurst>
Component: EverythingAssignee: Gentoo Release Team <releng>
Status: VERIFIED WONTFIX    
Severity: enhancement CC: hkbst
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Andrew Hurst 2007-03-08 17:30:36 UTC
I preferred the Universal x86 CD to any alternative now offered.

A longer description of my thoughts on this can be found at:
http://forums.gentoo.org/viewtopic-t-534576-highlight-.html

But basically the LiveCD is a poor replacement, and should be offered as an alternative, not a replacement.
I can only think to describe this bug as a regresasion!

Reproducible: Always
Comment 1 Andrew Gaffney (RETIRED) gentoo-dev 2007-03-08 17:31:54 UTC
You're free to build your own universal using catalyst.
Comment 2 Chris Gianelloni (RETIRED) gentoo-dev 2007-03-08 17:32:53 UTC
No.  Never going to happen.

Release Engineering is moving away from the Universal CD on every architecture.  We have no plans on *ever* going back to it, since it caused *many* more bug reports.  We publish our spec files.  If you want a Universal CD, you're more than welcome to make one.  We don't have the desire to do them, nor the mirror space to do them along with the LiveCD.
Comment 3 Marijn Schouten (RETIRED) gentoo-dev 2007-03-08 18:28:03 UTC
Andrew, what exactly are you asking for? An i386 cd? Or something with snapshot and stage3 included?

Chris, why did it cause *many* more bug reports?
Comment 4 Andrew Hurst 2007-03-08 18:36:34 UTC
I'm asking for the Universal x86 CD, as it was back in e.g. 2004.2:
kernel, portage snapshot, and stage 3 tarball, built for x86, so that it boots and installs universally, not just on i686

And most importantly inclusion of the Full x86 Handbook on board.

Should I try and explain my reasons here?
I think the handbook is one of the best things about Gentoo that struck me immediately when I first started using it - a fantastic educational tool that newcomers to Gentoo would all be better off having read, and also the best reference for when something doesn't quite go to plan with the installer.
Comment 5 Chris Gianelloni (RETIRED) gentoo-dev 2007-03-09 02:41:41 UTC
I know what you're asking for, and we're not going to do it.  The Handbook on the LiveCD *is* the complete Handbook.  We have only been shipping the networkless Handbook for more than 2 years now.  Lots of things have changed since the 2004.2 days, and we have no intentions on going backwards.

As for bug reports, it's pretty simple.  The more perceived choice users have, the more possibilities of them messing something up.  It also was a serious problem, QA-wise.  We invariably ended up with something missing from distfiles or some other bug.

Also, we haven't been supporting lower than i686 for some time.  We have stages on the mirrors, but we really don't support anything lower simply because they don't support the features we want to support.  Again, you can do an install on older machines, we just don't support it.

One other thing, starting with 2007.0, there will be a LiveDVD that is quite a bit better than the one from 2006.1, as it will include *all* of the stages for the given architecture, as well as the snapshot.  It will be i686 and above only, though, as we want to use the features of the newer hardware.  Were it not that i686 hardware has been around for more than a decade, we might be a bit more lenient on it.  Again, you're more than welcome to build your own CD.  It's actually quite easy.  You don't even need to use/learn catalyst to remaster a CD with a set of stages/snapshots on it.
Comment 6 Andrew Hurst 2007-03-09 10:12:53 UTC
Hello,
> I know what you're asking for, and we're not going to do it.

Sorry, Marijn asked.

> The Handbook on the LiveCD *is* the complete Handbook

Am I being completely blind?  I have the 2006.1 LiveCD in my drive now...
/docs/handbook contains the 2006.1 Release Handbook, and not the Full x86 Handbook as at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml

Are the differences from 1386 -> i686 important in an installer?  Your first step with your new ssytem should be to rebuild the toolchain with your new CFLAGS anyway, shouldn't it?
Comment 7 Chris Gianelloni (RETIRED) gentoo-dev 2007-03-09 14:27:40 UTC
OK.  I am going to answer these last questions, and then this topic is done.  Bugzilla is *not* a chat forum.  If you want to discuss this further, take it to the gentoo-releng mailing list, where I can assure you, you will get the exact same response from me.  ;]

> > The Handbook on the LiveCD *is* the complete Handbook
> 
> Am I being completely blind?  I have the 2006.1 LiveCD in my drive now...
> /docs/handbook contains the 2006.1 Release Handbook, and not the Full x86
> Handbook as at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml

Yes, you are being completely blind.  We have two Handbooks.  Each Handbook is different.  The Handbook we ship on the LiveCD is the same Handbook that we shipped on the Universal CD, which is the "networkless" Handbook.  It seems that what you're wanting is the "old" Handbook, that covered both installation types.  We have not had this Handbook for well over 2 years, so we can not accommodate your request, nor do we want to do so.

> Are the differences from 1386 -> i686 important in an installer?  Your first
> step with your new ssytem should be to rebuild the toolchain with your new
> CFLAGS anyway, shouldn't it?

The differences are critical, yes.  Remember that the Installer does networkless installations, also, which is built from the CD itself.  These people do *not* rebuild *anything* during the installation.

Again, we simply don't care to support machines that old.  You're more than welcome to install on them using the Minimal CD and a stage3 tarball, but we don't spend our limited time supporting it.
Comment 8 Andrew Hurst 2007-03-09 15:32:54 UTC
Ok, I'm not chatting.  I'm stating my reason for wanting the Universal CD back.

But, thankyou for explaining that you have two handbooks.  And that they're each different.

I'm sorry this could degenerate into a sarcastic counterattack:  I'll refrain.

My experience with the Universal x86 CD dates back to 2004.1

Since the 2006.1 Release Handbook
(http://www.gentoo.org/doc/en/handbook/2006.1/index.xml)
 is a subset of the information in the Full x86 Handbook
(http://www.gentoo.org/doc/en/handbook/handbook-x86.xml)
I believe everyone would be better served by the more detailed document, particularly as a reference for when things go wrong with the graphical installer, and also for its enormous educational value to new users.

That you haven't put the Full x86 Handbook on installation media for two years  doesn't address the 2006.1 Release Handbook's relative shortcomings.

I can see why people wanting to do a networkless installation of the toolchain would be best off with a LiveCD and tarballs built for i686.  However, this must describe a relatively tiny subset of users;  all others will be rebuilding their toolchain at some stage, with the CFLAGS their system has been customised with.

In the general case, not supporting general x86 simply denies access to anyone with old hardware, in return for a ~30% performance gain until your toolchain is rebuilt.

Are we going to be losing the x86 arch flag in portage, in place of 'i686, ~i686' I wonder.
Comment 9 Chris Gianelloni (RETIRED) gentoo-dev 2007-03-09 20:50:25 UTC
(In reply to comment #8)
> Since the 2006.1 Release Handbook
> (http://www.gentoo.org/doc/en/handbook/2006.1/index.xml)
>  is a subset of the information in the Full x86 Handbook
> (http://www.gentoo.org/doc/en/handbook/handbook-x86.xml)

This is where you are mistaken.  It is *not* a subset.  Look at them again.  They cover two completely different installation methods.  One covers performing a network-based installation, while the other covers networkless.

> I believe everyone would be better served by the more detailed document,

That is beyond the scope of Release Engineering.  If you feel the documents should be merged, take it up with the Gentoo Documentation Project, which maintains the Handbook.  You won't find any objections to this from me.

I'm pretty much ignoring the rest, because as I stated before, I'm not discussing this anymore, since the point is moot.  Nothing that you say and no amount of contemplation is going to change that we no longer wish to provide support for older hardware.
Comment 10 Andrew Hurst 2007-03-09 22:23:45 UTC
If the two documents are mutually exclusive, then all the more reason to include them BOTH on the CD.  That's something in releng's scope.
Is the LiveCD designed only for networkless install?
Comment 11 Andrew Gaffney (RETIRED) gentoo-dev 2007-03-09 22:29:41 UTC
> Is the LiveCD designed only for networkless install?

Yes, hence only putting the networkless handbook on there. The other handbook (the networked) is constantly changing as the state of the tree changes, so the best place to get it is direct from www.gentoo.org.
Comment 12 Andrew Hurst 2007-09-20 17:01:02 UTC
I would like to re-open this request, after discussion on the gentoo IRC channel, which leads me to believe that the GUI installer is not being advocated as the preferred means of installing for new users.
Rather, people are being advised to use the Full Handbook (not Release Handbook) and do a stage 3 install;  which is a dead-on description of the purpose of the Universal CD:  bootable, with portage snapshot, stage 3 tarball, and Full Handbook.
The reasons for preferring this method I have described before, but it seems that recently more people agree with my assessment, compounded by the GUI installer project having stalled.

I would also like to see all the old releases back on the Gentoo mirrors.  It is plain bad form for a project to delete its old releases, and for the sake of a few CD iso's worth of space... versus the 50GB distfiles dir??
Comment 13 Chris Gianelloni (RETIRED) gentoo-dev 2007-09-20 17:07:48 UTC
No.  I am not *ever* bringing back the Universal.  Period.

If *you* want to build your own Universal, feel free to do so.  Release Engineering has no desire to support the Universal, as it was the cause of most of our bugs due to users using the media incorrectly.

As for the old releases on the mirrors, we see no point in having an ever-increasing archive of what is simply installation media, as they're outdated quite easily.
Comment 14 Chris Gianelloni (RETIRED) gentoo-dev 2007-09-20 17:08:17 UTC
Marking this as CLOSED in the dash hopes that people will take that as a hint to never open this bug again.