Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 168310

Summary: www-apps/wordpress doesn't protect .htaccess
Product: Gentoo Linux Reporter: Francisco Blas Izquierdo Riera <klondike>
Component: New packagesAssignee: Steve Dibb (RETIRED) <beandog>
Status: RESOLVED CANTFIX    
Severity: normal CC: jesus.de.santos, web-apps
Priority: High    
Version: unspecified   
Hardware: All   
OS: All   
Whiteboard:
Package list:
Runtime testing required: ---

Description Francisco Blas Izquierdo Riera gentoo-dev 2007-02-25 11:54:23 UTC
Since, at least, the last two versions of Wordpress, when upgrading, the package doesn't config protect .htaccess replacing it when you upgrade reinstall.

Reproducible: Always

Steps to Reproduce:
1.Install an older version of www-apps/wordpress
2.If you used the vhosts flag,install that wordpress version into any of your hosts.
3.Create the .htaccess file with whatever you need
4. Install a newer version of www-apps/wordpres
5.If you used the vhosts flag, update that wordpress version into any of your hosts.
6. See the .htaccess, the modificiation you made have disapeared.
Actual Results:  
the .htaccess file wasn't config protected so it was restored to defaults.

Expected Results:  
Config protect the .htaccess and leave it unchanged.

Haven't tried without the vhosts flag, so maybe with it the bug couldn't happen. But with the vhosts flag and doing "webapp-config -U -h klondike -o klondike -d klog wordpress 2.0.9" the .htaccess is changed.
Comment 1 Jesus de Santos Garcia 2007-04-03 13:38:51 UTC
Never had this problem without the vhosts flag. Anyway, with or without that flags you should configprotect in makeconf the directory where wordpress is installed.
Comment 2 Steve Dibb (RETIRED) gentoo-dev 2007-05-12 14:30:28 UTC
I'm not sure its possible in the ebuild, since .htaccess is generated from wordpress install, and not part of the ebuild.

@net-www, any ideas?
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-06-08 14:01:55 UTC
(In reply to comment #2)
> I'm not sure its possible in the ebuild, since .htaccess is generated from
> wordpress install, and not part of the ebuild.
> 
> @net-www, any ideas?

In that case, no... Plus this thing is package.masked.

Comment 4 Francisco Blas Izquierdo Riera gentoo-dev 2007-06-08 16:47:48 UTC
And won't a line looking like this:"webapp_configfile "${MY_HTDOCSDIR}"/.htaccess" solve the problem?

http://sources.gentoo.org/viewcvs.py/gentoo-x86/www-apps/drupal/drupal-5.1.ebuild?r1=1.1&r2=1.2