Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 167006

Summary: dev-libs/glib-2.12.7 failed test
Product: Gentoo Linux Reporter: strites <strites>
Component: [OLD] UnspecifiedAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description strites 2007-02-15 11:50:44 UTC
make  check-TESTS
make[4]: Entering directory `/var/tmp/portage/dev-libs/glib-2.12.7/work/glib-2.12.7/tests'
PASS: atomic-test
PASS: array-test
PASS: base64-test

** ERROR **: naive_bit_nth_lsf (18446744073709551615, 31) = 32; builtin_bit_nth_lsf1 (18446744073709551615, 31) = 0;
aborting...
/bin/sh: line 4: 31413 Abortito                srcdir=. LIBCHARSET_ALIAS_DIR=../glib/libcharset MALLOC_CHECK_=2 MALLOC_PERTURB_=$((${RANDOM:-256} % 256)) ${dir}$tst
FAIL: bit-test
PASS: cxx-test
[...]
PASS: node-test
Cannot set locale to de_DE, skipping
PASS: option-test
[...]
PASS: slist-test
Usage: slice-test [n_threads] [G|S|M|O][f][c] [maxblocksize] [seed]
Starting 1 threads allocating random blocks <= 1021 bytes with seed=<random> using slab allocator + magazine cache
Done.
PASS: slice-test
Usage: slice-color <block-size> [memory-size] [repeats] [colorization]
Will allocate and touch 682 blocks of 512 bytes (= 349184 bytes) 1000000 times with color increment: 0x00000001
Access-time = 12.475210s
PASS: slice-color
[...]
PASS: type-test
Cannot set locale to tr_TR, skipping
Cannot set locale to tr_TR, skipping
Cannot set locale to tr_TR, skipping
Cannot set locale to tr_TR.UTF-8, skipping
Cannot set locale to tr_TR.UTF-8, skipping
Cannot set locale to tr_TR.UTF-8, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
Cannot set locale to lt_LT.UTF-8, skipping
PASS: unicode-caseconv
PASS: unicode-encoding
PASS: utf8-validate
PASS: utf8-pointer
PASS: uri-test
PASS: run-markup-tests.sh
PASS: run-collate-tests.sh
PASS: run-bookmark-test.sh
=====================================================================
1 of 51 tests failed
Please report to http://bugzilla.gnome.org/enter_bug.cgi?product=glib
=====================================================================
make[4]: *** [check-TESTS] Error 1
make[4]: Leaving directory `/var/tmp/portage/dev-libs/glib-2.12.7/work/glib-2.12.7/tests'
make[3]: *** [check-am] Error 2
make[3]: Leaving directory `/var/tmp/portage/dev-libs/glib-2.12.7/work/glib-2.12.7/tests'
make[2]: *** [check-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-libs/glib-2.12.7/work/glib-2.12.7/tests'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/glib-2.12.7/work/glib-2.12.7'
make: *** [check] Error 2

!!! ERROR: dev-libs/glib-2.12.7 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_test
  ebuild.sh, line 1026:   Called qa_call 'src_test'
  environment, line 3641:   Called src_test
  ebuild.sh, line 653:   Called die

!!! Make check failed. See above for details.
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/dev-libs/glib-2.12.7/temp/build.log'.


Portage 2.1.2-r9 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.18-gentoo-r3 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System release 1.12.9
Timestamp of tree: Thu, 15 Feb 2007 09:50:02 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.3.5-r2, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache collision-protect distcc distlocks metadata-transfer parallel-fetch sandbox sfperms strict test"
GENTOO_MIRRORS="ftp://gentoo.inode.at/source http://gentoo.osuosl.org"
LANG="it_IT.utf8"
LINGUAS="it"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/zugaina-portage /usr/local/portage /usr/portage/local/layman/sunrise"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi alsa altra_var1 altra_var2 amd64 amuled ao arts asf audiofile avi bash-completion berkdb bidi bitmap-fonts browserplugin bzip2 cairo canna cdda cddb cdr chasen cjk cli cracklib crypt cups dbus divx4linux dlloader dri dvb dvd dvdr dvdread eds emboss encode esd fam fbcon ffmpeg firefox flac foomatic fortran freewnn ftp gcj gdbm gif gimpprint gnome gnutls gphoto2 gpm gstreamer gtk gtk2 hal httpd i8x0 icecast iconv icq imagemagick immqt-bc isdnlog jack java javascript jikes jpeg kde ldap libg++ live mad matroska midi mikmod mjepeg mng mozilla mp3 mp4 mpeg mplayer msn nas ncurses network nls nptl nptlonly nsplugin nsplugins nvidia ogg oggvorbis openal opengl oss pam pcre pdflib perl png ppds pppd python qt qt3 qt4 quicktime rar rdesktop readline reflection remote samba scanner sdl session shout skins socks5 spell spl ssl stats stream subtitles tcpd test theora tiff transparent-proxy truetype truetype-fonts type1-fonts unicode usb v4l vcd visualization vlm vorbis wxwindows x264 xine xinerama xml xorg xprint xv xvid yahoo zlib" ALSA_CARDS="intel8x0 ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="mouse keyboard aiptek" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia vesa vga"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-02-15 17:29:13 UTC

*** This bug has been marked as a duplicate of bug 162123 ***