Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 166812

Summary: sys-apps/hal <pciutils-2.2.4 dependency forces multiple versions within a single package slot
Product: Gentoo Linux Reporter: Miroslav Šulc <fordfrog>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 161057    
Bug Blocks:    

Description Miroslav Šulc gentoo-dev 2007-02-14 11:49:42 UTC
# emerge -uDvNa world

These are the packages that would be merged, in order:

Calculating world dependencies /
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

('ebuild', '/', 'sys-apps/pciutils-2.2.3-r2', 'merge') pulled in by
  ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r5', 'merge')

('ebuild', '/', 'sys-apps/pciutils-2.2.4-r1', 'merge') pulled in by
  ('ebuild', '/', 'media-sound/alsa-utils-1.0.14_rc2', 'nomerge')

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

!!! Depgraph creation failed.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-02-14 12:00:51 UTC
Feel free to reopen Bug 161057 because this solution is stupid.


*** This bug has been marked as a duplicate of bug 1343 ***