Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 165505

Summary: net-wireless/zd1211-firmware-1.3 unable to load firmware for AL2230RF
Product: Gentoo Linux Reporter: garfungiloops <stepankov>
Component: New packagesAssignee: Daniel Drake (RETIRED) <dsd>
Severity: normal    
Priority: High    
Version: 2006.0   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description garfungiloops 2007-02-05 20:50:10 UTC
root:/home/bob# dmesg | grep zd1211
usbcore: registered new interface driver zd1211rw
usb 1-2: Could not load firmware file zd1211/zd1211b_ub. Error number -2
zd1211rw 1-2:1.0: couldn't load firmware. Error number -2
zd1211rw: probe of 1-2:1.0 failed with error -2

Reproducible: Always

Steps to Reproduce:
1.System starting

Actual Results:  
unable to start wlan0

Expected Results:  
wlan0 started

root:~# emerge --info
Portage 2.1.1-r2 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r4, 2.6.19-gentoo-r5 i686)
System uname: 2.6.19-gentoo-r5 i686 AMD Athlon(tm) XP 3100+
Gentoo Base System version 1.12.6
Last Sync: Mon, 05 Feb 2007 20:30:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.31-r3
dev-lang/python:     2.3.5-r2, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O3 -march=athlon-xp -pipe -fomit-frame-pointer -mfpmath=sse"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O3 -march=athlon-xp -pipe -fomit-frame-pointer -mfpmath=sse"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="3dnow X a52 aac alsa alsa_cards_intel8x0 alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2 apm berkdb bidi bitmap-fonts cdr cli clucene cracklib crypt cups cvs dbus directfb divx4linux dlloader dri dvd dvdr dvdread eds elibc_glibc emboss encode esd exif faad fbcon ffmpeg foomaticdb fortran gdbm gif gimpprint gpm gstreamer gtk gtk2 icc iconv imlib input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog jack jpeg kde kernel_linux lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text libg++ libwww mad matroska midi mikmod mjpeg mmx motif mozilla mp3 mpeg ncurses nls nptl nptlonly nvidia ogg opengl oss pam pcre pdf perl png pppd python qt qt3 qt4 quicktime readline real reflection sdl session spell spl sqlite3 sse ssl tcpd threads tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU v41 v412 video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_nvidia video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo vidix vorbis win32codecs wxwindows x86 xcomposite xine xml xorg xv xvid xvmc zlib"
Comment 1 garfungiloops 2007-02-05 20:50:56 UTC
Device: Longshine LCS-8131G3 RFType AL2230RF
Comment 2 garfungiloops 2007-02-05 20:52:23 UTC
Comment 3 Matthias Schwarzott gentoo-dev 2007-02-05 21:26:14 UTC
Which version of udev do you have installed?
Comment 4 garfungiloops 2007-02-05 21:40:01 UTC
udev ver 103
Comment 5 Matthias Schwarzott gentoo-dev 2007-02-05 21:44:11 UTC
Then problem should be easily solvable by updating to now stable udev-104-r9.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-02-05 21:58:31 UTC

*** This bug has been marked as a duplicate of bug 147006 ***
Comment 7 garfungiloops 2007-02-06 00:31:14 UTC
Sorry for Reopen, but:

I've updated udev to udev-104-r9
- the same error

unmerged hotplug
- the same

then updated a baselayout as suggested in comment#23 of bug 147006

nothing of that helps,
still have the same error
Comment 8 garfungiloops 2007-02-08 20:17:01 UTC
The same problem is discussing in the forum:
Comment 9 Daniel Drake (RETIRED) gentoo-dev 2007-02-08 20:27:04 UTC
Do you have zd1211rw built into the kernel? If so, build it as a module instead.
Comment 10 garfungiloops 2007-02-08 20:49:23 UTC

Thanks, just did that
as the module it works.
Comment 11 garfungiloops 2007-02-08 20:50:30 UTC
However I also emerged netplug, as suggested in forum