Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 165315

Summary: media-gfx/sane-backends-1.0.18-r2 breaks some scanner compatibilities
Product: Gentoo Linux Reporter: Tobias Leupold <tobias.leupold>
Component: Current packagesAssignee: Patrick Kursawe (RETIRED) <phosphan>
Status: RESOLVED OBSOLETE    
Severity: normal CC: frederic.heulin, polar88bear, serge, vslavik
Priority: Low    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Tobias Leupold 2007-02-04 19:04:19 UTC
Hi :-)

I have a Canon LiDE 25 scanner, woking perfectly with sane-backends-1.0.17. After an upgrade to version 1.0.18 (Gentoo
release 1.0.18-r2), the scanner didn't work anymore; other people also experienced problems with other scanners (see
http://forums.gentoo.org/viewtopic-t-506227.html -- German).

sane-find-scanner lists the scanner anyway, but scanimage -L didn't work anymore.

After a downgrade to version 1.0.17, everything works as expected again.

Greetings, Tobias

Reproducible: Always

Steps to Reproduce:
Comment 1 Patrick Kursawe (RETIRED) gentoo-dev 2007-02-05 12:52:25 UTC
I am not sure what I can do about this, but I will check the source differences and sane CVS as soon as I find some time (which is quite a problem at the moment).

About the forums thread:
Sorry, but sane-backends 1.0.18 has been in ~x86 since july 2006 and in x86 since september. Since no developer has all the hardware I have to rely on user feedback. This is the first time I am told about such problems with .18.
Comment 2 Tobias Leupold 2007-02-05 13:04:55 UTC
They just didn't report a bug, as the downgrade worked for them ;-) I don't know if dev-libs/libusb-1.1.11 matters (as reported on the forums), as just downgrading sane-backends worked for me. I also reported this bug on the SANE bugtacker: https://alioth.debian.org/tracker/index.php?func=detail&aid=304426&group_id=30186&atid=410366
Comment 3 Achim Strobelt 2007-02-12 07:58:42 UTC
Hi,

I have another possible solution to the problem:

My LiDE 25 worked again after removing the kernel-option "Device Drivers - USB Support - USB selective suspend/resume and wakeup". The problem appeared with gentoo-sources-2.6.19.

Other versions:
libusb 0.1.12
sane-backends 1.0.18-r2
Comment 4 Todor Zviskov 2007-04-04 00:39:47 UTC
Same issue with my LiDE 30, however downgrading sane-backends didn't fix it. Fixed after removing `USB selective suspend/resume and wakeup' as suggested by  Achim Strobelt above. My kernel is 2.6.20.4, libusb 0.1.12.
Comment 5 Slava Gorbunov 2007-07-01 17:10:30 UTC
I also have some problems with Mustek BearPaw 1200 when using sane-backends-1.0.18. The obtained image looks overexposed - I suspect that there are problems with calibration. Downgrading to sane-backends-1.0.17 solves this problem.
Comment 7 Kai Krakow 2007-08-30 20:23:23 UTC
Same problem here with this hardware:

jupiter linux # lsusb
Bus 002 Device 017: ID 04a9:220d Canon, Inc. CanoScan N670U/N676U/LiDE 20

If you keep the device awake with

while true; do sleep 1; cat /dev/bus/usb/002/017; done > /dev/null
(replace 002 and 017 with your bus and device id from lsusb)

you can do a preview and a full scan in e.g. kooka, but usually only one time. When it stops working, the scanning application has to be restarted. Looks like the backend or libusb cannot keep the device awake long enough.

Ideas for this found here: https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/85488
Comment 8 MarisN 2008-04-03 13:44:46 UTC
Unfortunately Hewlett-Packard ScanJet 7400c also is affected by this bug.
I tried sane-backends-1.0.19 and my scanner was not working at all. I recompiled kernel without USB suspend support and still no go. 
Downgraded to 1.0.17 and everything started to work.
With 1.0.18-r6 it's starts to scan but hangs in middle of A4 sheet.

~x86 2.6.24-gentoo-r4
Comment 9 Patrick Kursawe (RETIRED) gentoo-dev 2008-08-12 19:41:00 UTC
sane-backends 1.0.19 had some problems that while probing backends the epson2 backend did not properly release the device. This is fixed in 1.0.19-r2 - could you perhaps try this version?
Comment 10 Frédéric Heulin 2008-09-17 18:09:50 UTC
I don't when the variable was first introduced but for canon lide25,
SANE_BACKENDS should be setted to plustek and not canon in make.conf
sane-find-scanner look for the sane db so no problem but scanimage -L needs the correct backend to be available to test the device.
This solved the problem for me.
Comment 11 Patrick Kursawe (RETIRED) gentoo-dev 2011-09-19 20:00:15 UTC
I guess this is history...