Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 163873

Summary: hal- + kdebase-kioslaves-3.5.5-r1 + mysql-5.0.26-r2 + amarok-1.4.4-r3 gives an empty collection in amarok
Product: Gentoo Linux Reporter: sharpshopter
Component: [OLD] KDEAssignee: Diego Elio Pettenò (RETIRED) <flameeyes>
Severity: minor CC: esigra, jeremy.william.murphy, kde, timmy
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 245954    

Description sharpshopter 2007-01-26 08:51:02 UTC
Using hal- + kdebase-kioslaves-3.5.5-r1 + mysql-5.0.26-r2 + amarok-1.4.4-r3, when kdebase-kioslaves is built with hal support, the collection does not appear in amarok.

Note the collection still exists in the mysql database.  Rebuilding kioslaves without hal support restores the collection to amaraok.

Reproducible: Always

Steps to Reproduce:
1.Have kioslaves built with hal support
2.Logout and login (to force rebuild kioslaves to have hal support)
3.start amarok (assuming an existing mysql collection)

Actual Results:  
The collection is empty (where it wasn't before)

Expected Results:  
Amarok should show the collection as it usually does

Portage 2.1.1-r2 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r6 i686)
System uname: 2.6.18-gentoo-r6 i686 AMD Sempron(tm)   2400+
Gentoo Base System version 1.12.6
Last Sync: Tue, 23 Jan 2007 22:20:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O1 -march=athlon-xp -pipe -fforce-addr"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O1 -march=athlon-xp -pipe -fforce-addr"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch sandbox sfperms splitdebug strict"
LINGUAS="en_AU en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 3dnow X aac acpi alsa alsa_cards_intel8x0 alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2 asf audiofile avi bash-completion berkdb bitmap-fonts bzip2 caps cdparanoia cdr cjk cli cracklib crypt curl dbus directfb dlloader dri dvd elibc_glibc emacs encode exif expat fam fastcgi ffmpeg firefox flac gcj gd gdbm gif glut gmp gnutls gpm gtk gtk2 hal iconv idn imagemagick imap imlib input_devices_keyboard input_devices_mouse ipv6 isdnlog javascript jikes jpeg kernel_linux lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text lcms libg++ linguas_en linguas_en_AU logrotate mad maildir mbox mhash mime mmap mmx mng mono mp3 mpeg mysql ncurses nls nptl nptlonly nvidia offensive ogg oggvorbis openal opengl pam pcre pdf perl php png ppds pppd python qt4 readline real reflection ruby samba sdl session skey slang sockets source speex spell spl srvdir sse ssl tcltk tcpd tetex theora threads tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU video_cards_fbdev video_cards_nv video_cards_nvidia video_cards_vesa vorbis win32codecs xcomposite xine xml xml2 xorg xsl xv zlib"
Comment 1 Doug Goldstein (RETIRED) gentoo-dev 2007-02-14 05:53:52 UTC
According to the URL you posted, you figured out what the problem was. (revdep-rebuild and making sure all the depends we satisfied in an emerge -auDNv world)
Comment 2 sharpshopter 2007-02-14 06:29:08 UTC
No, I worked around the problem by compiling kioslaves without the hal use flag.  If I emerge kioslaves with the hal use flag, the problem still exists (even after revdep-rebuild and emerge -uDN world).
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-06-08 20:02:28 UTC
Please try with the current versions of the packages (hint: there's a 1.4.6 snapshot of amarok in portage), and reopen if it's still a problem.
Comment 4 sharpshopter 2007-06-09 02:31:44 UTC
The bug still exists with amarok-1.4.6_pre20070608 + kdebase-kioslaves-3.5.5-r1 + hal- + mysql-5.0.42
Comment 5 Jeremy Murphy 2008-09-06 10:49:21 UTC
I have just encountered this bug for the first time, using:

Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-03-28 14:36:08 UTC
Can anyone confirm if this still happens?

I have it working here with:
sys-apps/hal-0.5.12_rc1 (X acpi crypt kernel_linux)
kde-base/kdebase-kioslaves-3.5.10-r1 (hal openexr samba)
dev-db/mysql-5.0.76 (berkdb embedded perl ssl)
media-sound/amarok-1.4.10-r2 (amazon ipod kde mp4 musicbrainz mysql njb opengl python visualization)
Comment 7 sharpshopter 2009-03-30 02:22:16 UTC
I have moved on to KDE4 (but still amarok 1.4) for now, I'll see if I can find some time to test later.

Anyway, I think I eventually worked out that if I tried to use amarok with kdebase-kioslaves +hal when the collection was built with a kioslaves -hal, or vice versa, then the collection showed up as blank.  The collection was still there when the "hal" use flag was toggled back.

In other words, building a collection, then toggling the hal use flag, rebuilding kioslaves with this new use flag would cause amarok to think the collection was empty.  Toggling the hal flag back and rebuilding kioslaves would make the collection appear again.

I bit the bullet and rebuilt my collection from scratch with +hal, and have had no problems since.
Comment 8 sharpshopter 2009-04-07 13:58:52 UTC
So I tested with:

sys-apps/hal-0.5.11-r8 (X acpi crypt)
dev-db/mysql-5.0.70-r1 (embedded perl ssl)
kde-base/kdebase-kioslaves-3.5.10-r1 (hal ldap samba)
media-sound/amarok-1.4.10-r2 (amazon daap kde mp4 musicbrainz mysql opengl python)

The bug still seems to exist.  If a collection is built when kioslaves has -hal, then accessing it with kioslaves +hal causes it to seem blank.  The reverse case didn't seem to be true (at least with my limited testing).  This suggests my memory was incorrect when I made the previous comment.

As before, amarok could hold a collection built with +hal.
Comment 9 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-11-01 21:52:32 UTC
Does this also apply to KDE4 and amarok-2.2?
If not, we'll close it as KDE3 is on its way out of the tree.
Comment 10 Samuli Suominen (RETIRED) gentoo-dev 2009-11-07 20:17:08 UTC
(In reply to comment #9)
> Does this also apply to KDE4 and amarok-2.2?
> If not, we'll close it as KDE3 is on its way out of the tree.

It's now masked for removal, closing...