Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 159255

Summary: media-libs/xine-lib-1.1.3 possible buffer overflow
Product: Gentoo Linux Reporter: Harris Landgarten <harrisl>
Component: [OLD] LibraryAssignee: media-video herd <media-video>
Status: RESOLVED TEST-REQUEST    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Harris Landgarten 2006-12-27 17:21:23 UTC
When running applications that use the xine backend (gxine, democracyplayer) with a 1920x1200 display and ati-drivers-8.32.5 screen corruption occurs in the area of the panel. In the case of gxine, the corruption occurs after the splash and player have appeared but before any video is played. 

Running under gdb shows the following
[Thread debugging using libthread_db enabled]
[New Thread -1208575808 (LWP 14308)]
[Switching to Thread -1208575808 (LWP 14308)]

Breakpoint 1, 0x0805216a in _init ()
(gdb) cont
Continuing.
[New Thread -1212105840 (LWP 14311)]
[New Thread -1221882992 (LWP 14312)]
[New Thread -1230546032 (LWP 14313)]
[New Thread -1243186288 (LWP 14314)]
[New Thread -1255679088 (LWP 14315)]
[New Thread -1265960048 (LWP 14316)]
[New Thread -1353692272 (LWP 14317)]
[New Thread -1541100656 (LWP 14318)]

(gxine:14308): Gtk-CRITICAL **: gtk_style_detach: assertion `style->attach_count > 0' failed
[New Thread -1549493360 (LWP 14319)]
[New Thread -1562125424 (LWP 14320)]
[New Thread -1570518128 (LWP 14321)]
[New Thread -1516598384 (LWP 14322)]
[New Thread -1578910832 (LWP 14323)]
[New Thread -1582478448 (LWP 14324)]
[Thread -1582478448 (LWP 14324) exited]
[Thread -1578910832 (LWP 14323) exited]

Program received signal SIGINT, Interrupt.
0xb7fe1410 in ?? ()
(gdb) bt
#0  0xb7fe1410 in ?? ()
#1  0xbfe50888 in ?? ()
#2  0x000001f2 in ?? ()
#3  0x00000003 in ?? ()
#4  0x4a42f8d0 in poll () from /lib/libc.so.6
#5  0x4bbef872 in ?? () from /usr/lib/libglib-2.0.so.0
#6  0x08765b10 in ?? ()
#7  0x00000003 in ?? ()
#8  0x000001f2 in ?? ()
#9  0x08765b10 in ?? ()
#10 0x00000003 in ?? ()
#11 0x4bc504c4 in ?? () from /usr/lib/libglib-2.0.so.0
#12 0x080b9508 in ?? ()
#13 0x4a4d6b22 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2007-09-04 12:30:00 UTC
and 1.1.8?
Comment 2 Gef 2011-07-26 21:38:49 UTC
Current version in portage is 1.1.19. Is this bug still relevant ?
Comment 3 Christian Ruppert (idl0r) gentoo-dev 2011-10-03 22:34:09 UTC
Closing this bug report as no further information has been provided. Please reopen this bug if you can provide the information asked for.
Thanks!