Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 158498

Summary: app-benchmarks/jmeter-3.1: last rites (was: version bump)
Product: Gentoo Linux Reporter: Petteri Räty (RETIRED) <betelgeuse>
Component: Current packagesAssignee: Java team <java>
Status: RESOLVED FIXED    
Severity: normal CC: asl, bug, charles, coldwind, ercpe, kmhzsem, mgorny
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 158497, 161942, 471834    
Bug Blocks: 63309    

Description Petteri Räty (RETIRED) gentoo-dev 2006-12-18 14:19:15 UTC
http://jakarta.apache.org/site/downloads/downloads_jmeter.cgi
Comment 1 Petteri Räty (RETIRED) gentoo-dev 2007-01-14 22:30:33 UTC
Got this building with no bundled jars but only after two eclasses and a buch of packages using them. Had to package quite a slice of excalibur. Well see to committing the eclasses and packages to the overlay some time next week.
Comment 2 Marat Radchenko 2007-04-28 13:04:00 UTC
in java-experimental. without any bundled jars. enjoy.
Comment 3 Charles Nérot 2009-09-10 14:25:35 UTC
Summary should be changed to 
"version bump app-benchmarks/jmeter to 2.2"
(with an 's' to app-benchmark)
Comment 4 Petteri Räty (RETIRED) gentoo-dev 2009-09-11 16:23:54 UTC
*** Bug 284484 has been marked as a duplicate of this bug. ***
Comment 5 Charles Nérot 2009-09-11 17:18:21 UTC
Current version is 2.3.4 not  2.4, isn't it?
Comment 6 Arnaud Launay 2010-10-13 08:09:06 UTC
No, it's 2.4.
Comment 7 Denny Reeh 2012-02-09 11:30:48 UTC
Version 2.6 is out now.
Comment 8 Charles Nérot 2013-06-09 07:48:07 UTC
Version 2.9 is out now.
Comment 9 Johann Schmitz (ercpe) (RETIRED) gentoo-dev 2014-02-28 18:32:42 UTC
2.11 is latest.
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2014-10-28 09:24:59 UTC
Please update the version indication in the Summary when a new version is released.
Comment 11 James Le Cuirot gentoo-dev 2015-02-28 09:59:26 UTC
This is still active. It still ships with Excalibur, which is long dead, but it looks as though this support is deprecated and probably optional as a result. I haven't tried to build it yet but we could hopefully strip out the Excalibur support or just bundle those jars.
Comment 12 Wolfram Schlich (RETIRED) gentoo-dev 2017-04-04 09:40:07 UTC
Latest version is 3.1 now (http://www-eu.apache.org/dist/jmeter/source/apache-jmeter-3.1_src.tgz).
Comment 13 James Le Cuirot gentoo-dev 2017-08-29 21:18:27 UTC
I'm sorry but I've decided to last-rite this for the time being, primarily because it's holding up the removal of Java 7. I did try very hard to bump it about a year ago but there's only so many unpackaged deps and confusing build failures you can put up with before you start to wonder why you're wasting so much time on something you're never going to use. I hope it may return following the creation of our mythical next generation infrastructure that should make this stuff much easier but don't hold your breath.
Comment 14 Larry the Git Cow gentoo-dev 2017-10-03 22:12:45 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=43ca78d3fd660f50e62cd9a140dc4d86257aeefe

commit 43ca78d3fd660f50e62cd9a140dc4d86257aeefe
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2017-10-03 22:09:54 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2017-10-03 22:12:31 +0000

    app-benchmarks/jmeter: Remove last-rited pkg
    
    Closes: https://bugs.gentoo.org/158498

 app-benchmarks/jmeter/Manifest               |  1 -
 app-benchmarks/jmeter/jmeter-2.0.1-r4.ebuild | 59 ---------------------
 app-benchmarks/jmeter/jmeter-2.0.1-r5.ebuild | 71 -------------------------
 app-benchmarks/jmeter/jmeter-2.0.1-r6.ebuild | 77 ----------------------------
 app-benchmarks/jmeter/metadata.xml           | 11 ----
 profiles/package.mask                        |  6 ---
 6 files changed, 225 deletions(-)