Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 156402

Summary: sci-misc/boinc-5.4.11 emerge failed
Product: Gentoo Linux Reporter: Bakus <bakus>
Component: Current packagesAssignee: Tomáš Chvátal (RETIRED) <scarabeus>
Status: RESOLVED TEST-REQUEST    
Severity: normal CC: sci
Priority: High    
Version: 2006.1   
Hardware: All   
OS: Linux   
URL: http://boinc.berkeley.edu/
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge log

Description Bakus 2006-11-27 05:17:41 UTC
Portage 2.1.1-r2 (hardened/x86/2.6, gcc-3.4.6, glibc-2.3.6-r5, 2.6.16-hardened-r10 i686)
=================================================================
System uname: 2.6.16-hardened-r10 i686 Pentium II (Deschutes)
Gentoo Base System version 1.12.6
Last Sync: Mon, 27 Nov 2006 07:00:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium2 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-march=pentium2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache confcache distcc distclean distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperm sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.idn.net.pl http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="pl_PL"
LC_ALL="pl_PL"
LINGUAS="pl"
MAKEOPTS="-j7"
PKGDIR="/usr/portage//packages/x86/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage/"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip apache2 bash-completion berkdb bz2 bzip2 clamav crypt dlloader elibc_glibc gpm hardened input_devices_keyboard input_devices_mouse javascript jpeg kernel_linux linguas_pl mailbox mysql nls pam perl php pic png proftpd readline samba sqlite ssl tcpd tiff userland_GNU userlocales x86 xorg zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Bakus 2006-11-27 05:18:52 UTC
Created attachment 102841 [details]
emerge log
Comment 2 Marcus D. Hanwell (RETIRED) gentoo-dev 2006-11-27 07:19:23 UTC
Looks like the error is due to,

base64.C:161: error: exception handling disabled, use -fexceptions to enable

I can see -fno-exceptions in the build lines but it does not appear to be coming from your CFLAGS. I can't reproduce the error here, something strange on your system or may be a hardened error?
Comment 3 Christian Knieling 2006-11-28 13:19:51 UTC
I've experienced the same problem with boinc-5.5.6:

The line "^MYSQL_CFLAGS=.*" in the Makefile beneath /var/tmp/portage/boinc-5.5.6/work/boinc-5.5.6/lib contains the flag "-fno-exeption". I've started the emerge process and delayed (CTRL-Z) it after the configure step. I removed this flag from that line and went on with compiling (fg). It ran through though. Can't tell so far if there is any drawback or unexpected behavior.
Comment 4 Marcus D. Hanwell (RETIRED) gentoo-dev 2007-01-06 20:01:10 UTC
I can't see where that -fno-exeption and don't seem to be able to reproduce the bug here. I am using an ~amd64 system to test on using GCC 4.1. Is your system also a hardened system? I don't get where that flag is coming from in the boinc sources either - I can't see it hardcoded anywhere.

Can anyone else spot it?
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2009-01-09 15:04:39 UTC
# ChangeLog for sci-misc/boinc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.45 2009/01/02 20:40:21 cryos Exp $

  02 Jan 2009; Marcus D. Hanwell <cryos@gentoo.org> metadata.xml:
  Removed myself as maintainer.
Comment 6 Tomáš Chvátal (RETIRED) gentoo-dev 2009-02-01 15:46:33 UTC
Please test with 6.4.5.
Thanks