Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 156187

Summary: media-libs/flac-1.1.2-r8 does not compile, because of the xmms plugin references
Product: Gentoo Linux Reporter: Wojtek Arabczyk <arabek+bgo>
Component: Current packagesAssignee: Gentoo Sound Team <sound>
Status: VERIFIED INVALID    
Severity: normal    
Priority: High    
Version: 2006.0   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Emerge log of media-libs/flac-1.1.2-r8

Description Wojtek Arabczyk 2006-11-25 02:10:25 UTC
$ emerge --info
Portage 2.1.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.18-ck1-r1 i686)
=================================================================
System uname: 2.6.18-ck1-r1 i686 Intel(R) Pentium(R) M processor 1400MHz
Gentoo Base System version 1.12.6
Last Sync: Sat, 23 Sep 2006 09:00:07 +0000
distcc[23842] (dcc_trace_version) distcc 2.18.3 i686-pc-linux-gnu; built Oct 14 2006 03:23:31 [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -mtune=pentium-m -fomit-frame-pointer -pipe -w"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium-m -mtune=pentium-m -fomit-frame-pointer -pipe -w"
DISTDIR="/usr/src/gentoo/distfiles"
FEATURES="autoconfig buildpkg distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.prz.rzeszow.pl/"
LANG="pl"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O2,-z,now,--as-needed,--reduce-memory-overheads,--enable-new-dtags,--sort-common"
LINGUAS="pl"
MAKEOPTS="-j1"
PKGDIR="/usr/src/gentoo/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--progress --exclude=metadata/* --exclude=/usr/portage/metadata/*"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/musicbrainz /usr/portage/local/layman/custom-kernels"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac aalib acpi alsa amarok aoss bash-completion bzip2 cddb crypt cups curl dmi dts dvdread elibc_glibc encode exif ffmpeg gif glitz glut gnutls gpm hal idn imagemagick imlib input_devices_evdev input_devices_keyboard input_devices_mouse input_devices_synaptics java javascript jpeg kdeenablefinal kdehiddenvisibility kernel_linux libcaca linguas_pl mad mmap mmx mp3 mp4 nls nptl nptlonly offensive ogg opengl pam pdf png rdesktop readline reiserfs sdl shared slang sqlite sse sse2 ssl svg symbol_visibility theora threads tiff truetype unicode usb userland_GNU video_cards_i810 vorbis wifi x264 xcomposite xorg xscreensaver xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK
Comment 1 Wojtek Arabczyk 2006-11-25 02:12:29 UTC
Created attachment 102695 [details]
Emerge log of media-libs/flac-1.1.2-r8

I know i don't have gtk as i don't use it, but as xmms got removed
from the tree, flac should not try to build the xmms-plugin.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-11-25 02:29:39 UTC
You have stale xmms junk in /usr/include/xmms/
Comment 3 Wojtek Arabczyk 2006-11-25 02:42:24 UTC
(In reply to comment #2)

> You have stale xmms junk in /usr/include/xmms/

Confirmed. After removing flac compiled cleanly. Thanks.
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-11-25 03:07:04 UTC
I've hard-disabled it in media-libs/flac, so the problem is gone.