Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 155873

Summary: yEd - java based graph editor
Product: Gentoo Linux Reporter: Renato Alves <simpledark>
Component: New packagesAssignee: Java team <java>
Status: RESOLVED CANTFIX    
Severity: enhancement CC: ainsaar, burcheri.massimo+bugs-gentoo, c.a.strahl, gentoobugs, hermes.trismegistos, it-knodel, j0inty, java, jiri.tyr, nelchael, timo.warns
Priority: High Keywords: EBUILD
Version: 2006.1   
Hardware: All   
OS: Linux   
URL: http://www.yworks.com/en/products_yed_about.htm
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: yed-2.4.2.2.ebuild
yed-2.4.2.2.ebuild
yed-2.4.2.2.ebuild
yed-2.4.2.2.ebuild
yed-3.0.0.8.ebuild
yed-3.1.1.ebuild
yed-3.1.2.1.ebuild
yed-3.5.0.2.ebuild
yed-3.6.1.1.ebuild
yed-3.7.0.2.ebuild
yed-3.9.1.ebuild
yed-3.11.1.ebuild
updated ebuild
yed-bin-3.11.1.ebuild
Ebuild for 3.14.1
Ebuild for version 3.14.4
Ebuild for v3.16.2.1

Description Renato Alves 2006-11-21 10:53:00 UTC
Request ebuild for software

The software is composed only by yed.jar and needs java-1.4.2 or newer.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-11-28 11:58:55 UTC
*** Bug 156538 has been marked as a duplicate of this bug. ***
Comment 2 Markus Ullmann (RETIRED) gentoo-dev 2007-09-14 14:19:35 UTC
seems this request hasn't turned into an ebuild yet. If you want to help with it, it's not that hard to write one: http://devmanual.gentoo.org/quickstart/index.html

If you need further help, feel free to ask on forums or #gentoo-dev-help or #gentoo-sunrise on irc (latter is also useful if you want to maintain the app yourself)

note: we're not turning you down for this request in any way, it's just that we don't have ressources to fix all of them. though if you're willing to help, it would be more than nice to do so, as that is what we definately need :)
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-09-24 09:28:47 UTC
*** Bug 193596 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-09-24 09:29:27 UTC
Reopen wrt Bug 193596
Comment 5 Jiri Tyr 2007-09-24 10:04:02 UTC
Created attachment 131764 [details]
yed-2.4.2.2.ebuild
Comment 6 Renato Alves 2007-09-24 14:36:31 UTC
(In reply to comment #5)
> Created an attachment (id=131764) [edit]
> yed-2.4.2.2.ebuild
> 

The homepage address is incorrect. The correct address should be:
http://www.yworks.com/en/products_yed_about.htm

Thanks, I will try the ebuild when I get to my gentoo box.
Comment 7 Jiri Tyr 2007-09-24 18:39:13 UTC
Created attachment 131796 [details]
yed-2.4.2.2.ebuild

Home page correction.
Comment 8 Jiri Tyr 2007-09-25 09:58:04 UTC
Created attachment 131833 [details]
yed-2.4.2.2.ebuild

Added application icon and desktop entry.
Comment 9 Jiri Tyr 2007-09-25 10:05:58 UTC
Created attachment 131835 [details]
yed-2.4.2.2.ebuild

Correction of the application icon location.
Comment 10 Jiri Tyr 2008-01-18 15:51:05 UTC
Created attachment 141226 [details]
yed-3.0.0.8.ebuild

Ebuild for yEd-3.0.0.8.
Comment 11 Jiri Tyr 2008-07-20 12:49:56 UTC
Created attachment 160927 [details]
yed-3.1.1.ebuild

Ebuild for yed-3.1.1.
Comment 12 Jiri Tyr 2009-01-08 00:03:27 UTC
Created attachment 177724 [details]
yed-3.1.2.1.ebuild

Ebuild for the yed-3.1.2.1.
Comment 13 Joel Berendzen 2010-09-01 17:37:56 UTC
Created attachment 245647 [details]
yed-3.5.0.2.ebuild

Version bump to 3.5.0.2
Comment 14 Qingping Hou 2011-03-23 14:58:52 UTC
Created attachment 266993 [details]
yed-3.6.1.1.ebuild
Comment 15 Steffen 'j0inty' Stollfuß 2011-08-05 19:18:27 UTC
Created attachment 282235 [details]
yed-3.7.0.2.ebuild
Comment 16 Amadeusz Żołnowski (RETIRED) gentoo-dev 2012-04-27 10:07:34 UTC
Created attachment 310239 [details]
yed-3.9.1.ebuild

I've tweaked yed-3.7.0.2.ebuild a bit and here is yed-3.9.1.ebuild. I've removed license.html installation, because license will go to $PORTDIR/licenses if approved. I also rdepend on >=jre-1.6, because bundled version include that one and it is also supposed to work with jre-1.7.

I haven't run it on x86. If it works fine on x86 for any of you, please let me know, so I'll add ~x86 keyword.
Comment 17 Amadeusz Żołnowski (RETIRED) gentoo-dev 2012-04-28 07:12:45 UTC
I have to wait with committing it because of some concerns about yEd license which are being discussed.
Comment 18 Amadeusz Żołnowski (RETIRED) gentoo-dev 2012-05-07 14:55:35 UTC
Because of concerns wrt yEd license I haven't committed ebuild into portage tree so far.  Meanwhile I've added it into my overlay.  To get it:

layman -a aidecoe
emerge yed

(layman -s aidecoe to sync with my overlay)
Comment 19 Lars 2013-12-08 10:21:44 UTC
Created attachment 364916 [details]
yed-3.11.1.ebuild
Comment 20 Amadeusz Żołnowski (RETIRED) gentoo-dev 2013-12-08 12:44:25 UTC
(In reply to Lars from comment #19)
> Created attachment 364916 [details]
> yed-3.11.1.ebuild

Why install to /opt?
Comment 21 Lars 2013-12-08 17:38:10 UTC
(In reply to Amadeusz Żołnowski from comment #20)
> Why install to /opt?

yed.jar depends on vectorgraphics.jar which was not installed in your ebuild. To install it I added the 'doins' line. I set the destination to /opt since it is a binary-only application:
http://devmanual.gentoo.org/general-concepts/filesystem/

But maybe there is a better way to install the two *.jar files I am not aware of? 

"In general, the directory policies are handled for you by the helper functions in the java-utils-2 eclass."
http://www.gentoo.org/proj/en/java/java-devel.xml#doc_chap3

This ebuild will install the following:

equery files app-office/yed
 * Searching for yed in app-office ...
 * Contents of app-office/yed-3.11.1:
/opt
/opt/yed
/opt/yed/icons
/opt/yed/icons/yicon.icns
/opt/yed/icons/yicon.ico
/opt/yed/icons/yicon16.png
/opt/yed/icons/yicon32.png
/opt/yed/license.html
/opt/yed/vectorgraphics.jar
/opt/yed/yed.jar
/usr
/usr/bin
/usr/bin/yed
/usr/share
/usr/share/applications
/usr/share/applications/yed-yed.desktop
/usr/share/pixmaps
/usr/share/pixmaps/yicon32.png
/usr/share/yed
/usr/share/yed/package.env


I just edited the ebuild because I needed a recent version of yed and your ebuild did not work with 3.11.1 . Feel free to improve it.
Comment 22 Ralph Sennhauser (RETIRED) gentoo-dev 2013-12-11 17:33:49 UTC
(In reply to Lars from comment #19)
> Created attachment 364916 [details]
> yed-3.11.1.ebuild

Having had a look at the ebuild:

vectorgraphics.jar looks a lot like a bundled 3rd party dependency, if so a separate ebuild would be preferable.

Installing to /opt is fine, tho we do not require it.

The ebuild first "doins" the jars and then adds them a second time to the image using dojar. Please only use dojar.

The vast majority of java binary packages is suffixed with -bin. I'd suggest to call the package yed-bin for consistencies sake.
Comment 23 Lars 2014-02-03 23:54:14 UTC
(In reply to Ralph Sennhauser from comment #22)

> Installing to /opt is fine, tho we do not require it.

ok

> The ebuild first "doins" the jars and then adds them a second time to the
> image using dojar. Please only use dojar.

fixed
 
> The vast majority of java binary packages is suffixed with -bin. I'd suggest
> to call the package yed-bin for consistencies sake.

ok, done

> vectorgraphics.jar looks a lot like a bundled 3rd party dependency, if so a
> separate ebuild would be preferable.

vectorgraphics.jar contains org.freehep.* classes that are in these ebuilds:

dev-java/freehep-graphics2d
dev-java/freehep-graphicsio
dev-java/freehep-graphicsio-emf
dev-java/freehep-graphicsio-pdf
dev-java/freehep-graphicsio-ps
dev-java/freehep-graphicsio-swf
dev-java/freehep-util

I added them to RDEPEND and JAVA_GENTOO_CLASSPATH. However, yed does not find them:

yed-bin
Exception in thread "main" java.lang.NoClassDefFoundError: org/freehep/graphics2d/AbstractVectorGraphics
...
Comment 24 Lars 2014-02-03 23:55:41 UTC
Created attachment 369482 [details]
updated ebuild
Comment 25 Lars 2014-02-04 00:17:17 UTC
Created attachment 369484 [details]
yed-bin-3.11.1.ebuild
Comment 26 Amadeusz Żołnowski (RETIRED) gentoo-dev 2014-05-13 18:44:08 UTC
Maybe someone could talk again with these guys about licensing? Because this is the only issue holding from adding yed to the tree.

I am not going do it myself again, so I'm reassigning to java herd - are you OK with this?
Comment 27 Lars 2015-04-10 13:02:46 UTC
Created attachment 400962 [details]
Ebuild for 3.14.1
Comment 28 James Le Cuirot gentoo-dev 2015-04-10 13:09:01 UTC
*** Bug 475746 has been marked as a duplicate of this bug. ***
Comment 29 Lars 2015-12-04 14:10:23 UTC
Created attachment 418560 [details]
Ebuild for version 3.14.4
Comment 30 Lars 2015-12-04 19:23:00 UTC
(In reply to Amadeusz Żołnowski from comment #26)
> Maybe someone could talk again with these guys about licensing? Because this
> is the only issue holding from adding yed to the tree.
> 
> I am not going do it myself again, so I'm reassigning to java herd - are you
> OK with this?

What are your concerns with the license? Isn't it just another case of fetch restriction?
Comment 31 Lars 2016-10-14 20:02:59 UTC
Created attachment 450224 [details]
Ebuild for v3.16.2.1

Because I could not find out how to handle upstream version numbers with 4 places I hard-coded the last place.