Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 152151

Summary: aMule-cvs critical (gtk+
Product: Gentoo Linux Reporter: Piotr Stachura <albert1>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: High    
Version: 2006.1   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Piotr Stachura 2006-10-20 11:53:56 UTC
Hi, I know that CVS version's isn't "stable" but I was using aMule-cvs for a long time and after I updated gtk+ from 2.8 to 2.10 I noticed text formatting errors and critical error when I click "clear" button after searching files. That's error message:

(amule:4712): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

Gtk-ERROR **: file gtkcontainer.c: line 2447 (gtk_container_propagate_expose): assertion failed: (child->parent == GTK_WIDGET (container))
aborting...

I'm using gtk+-2.10.6 (.5 was also affected)
wxGTK version: 2.6.3.3, previously 2.6.2-r1 (but bug appears when I updated gtk+.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-10-20 11:59:10 UTC

*** This bug has been marked as a duplicate of 151528 ***