Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 15119

Summary: x11-libs/openmotif emerge fails with "$LANG contains an unknown character set"
Product: Gentoo Linux Reporter: Hamilton Coutinho <hamiltonc>
Component: Current packagesAssignee: Ulrich Müller <ulm>
Severity: normal CC: a_voloshin, dhp_gentoo, hamiltonc
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Hamilton Coutinho 2003-02-04 13:46:36 UTC
Running programs that need motif failed with "error while loading shared libraries: cannot open shared object file: No such file or directory". 

Reproducible: Always
Steps to Reproduce:
1. emerge openmotif 
2. hellomotif 
Actual Results:  
hamilton@hamilton hamilton $ hellomotif 
hellomotif: error while loading shared libraries: cannot open shared 
object file: No such file or directory 

Expected Results:  
Show motif window.
Comment 1 Nick Hadaway 2003-02-05 14:56:43 UTC
It appears some files are missing... specifically /usr/X11R6/lib/*
Re-emerge openmotif... 

I get a different problem running openmotif which I am still looking into though.
Comment 2 Alastair Tse (RETIRED) gentoo-dev 2003-04-02 17:17:52 UTC
i'll take a further look into this one

can you tell me which version of openmotif you are using, try re-emerging and if that doesn't work, please paste the output of "emerge info"
Comment 3 Hamilton Coutinho 2003-04-03 07:01:46 UTC
Trying to re-emerge produced this: 
mkdir .libs 
gcc -march=pentium4 -O3 -pipe -Wall -Wno-unused -Wno-comment -o .libs/xmanimate 
xmanimate.o  ../../lib/Xmd/libXmd.a ../../../lib/Mrm/.libs/ 
/var/tmp/portage/openmotif-2.2.2-r1/work/openMotif-2.2.2/lib/Xm/.libs/ -L/usr/X11R6/lib 
../../../lib/Xm/.libs/ -lXmu -lXt -lSM -lICE -lXext -lXp -lX11 -Wl,--rpath -Wl,/usr/X11R6/lib 
creating xmanimate 
../../../clients/uil/uil -o dog.uid dog.uil -I./../../../clients/uil -I../../../clients/uil 
Error: $LANG contains an unknown character set 
Info: no UID file was produced 
Info: errors: 1  warnings: 0  informationals: 1 
make[3]: *** [dog.uid] Error 1 
make[3]: Leaving directory 
make[2]: *** [all-recursive] Error 1 
make[2]: Leaving directory 
make[1]: *** [all-recursive] Error 1 
make[1]: Leaving directory `/var/tmp/portage/openmotif-2.2.2-r1/work/openMotif-2.2.2/demos' 
make: *** [all-recursive] Error 1 
!!! ERROR: x11-libs/openmotif-2.2.2-r1 failed. 
!!! Function src_compile, Line 36, Exitcode 2 
!!! make failed 
emerge info: 
Portage 2.0.47-r10 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r4) 
System uname: 2.4.20-gentoo-r2 i686 Intel(R) Pentium(R) 4 CPU 1.60GHz 
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share/config 
/usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/share/config" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d" 
USE="x86 oss 3dnow apm avi crypt cups encode gif jpeg libg++ mikmod mmx mpeg ncurses 
nls pdflib png quicktime spell truetype xml2 xmms xv zlib gdbm berkdb slang readline arts 
tetex svga tcltk java mysql X sdl gpm tcpd pam libwww ssl perl python imlib oggvorbis motif 
opengl ldap cdr acpi gtk gtk2 kde mbox qt -gnome -maildir" 
CFLAGS="-march=pentium4 -O3 -pipe" 
CXXFLAGS="-O2 -mcpu=i686 -pipe" 
FEATURES="sandbox ccache" 
Comment 4 Alastair Tse (RETIRED) gentoo-dev 2003-04-05 14:30:04 UTC
what is your LANG set to? The error implies there is a problem with your environment.

try just doing LANG=C emerge openmotif
Comment 5 Alastair Tse (RETIRED) gentoo-dev 2003-04-28 16:15:29 UTC
any lucky Hamilton?
Comment 6 Hamilton Coutinho 2003-04-29 08:07:42 UTC
Sorry for taking so long to respond you. First I tried 'unset LANG; emerge openmotif' and it 
failed with the same error -- because I set LANG in env.d, I guess. But then I tried as you 
suggested and it worked. Thanks. 
Comment 7 Alastair Tse (RETIRED) gentoo-dev 2003-04-30 05:26:14 UTC
thanks. i've added a workaround in the ebuild so you shouldn't come across that error with this ebuild again.
Comment 8 Martin Holzer (RETIRED) gentoo-dev 2003-05-05 09:35:47 UTC
*** Bug 16726 has been marked as a duplicate of this bug. ***
Comment 9 Ulrich Müller gentoo-dev 2010-03-14 15:22:25 UTC
Problem still exists (seen with openmotif-2.3.2), reopening.
Looks like "unset LANG" is not enough, the ebuild should assign "LANG=C" as suggested in comment #4.
Comment 10 Ulrich Müller gentoo-dev 2010-03-14 15:23:08 UTC
*** Bug 309299 has been marked as a duplicate of this bug. ***
Comment 11 Ulrich Müller gentoo-dev 2010-03-14 15:28:54 UTC
Fixed in openmotif-2.3.2-r2. No revbump since it's a build failure.