Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 150765

Summary: expat 2.0.0 - XML::Parser perl module is required for intltool
Product: Gentoo Linux Reporter: Jim Moffat <jwmoffat>
Component: New packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Jim Moffat 2006-10-10 10:05:35 UTC
While doing "emerge -avuDN world" it failed on the package x11-misc/xkeyboard-config-0.8-r1  It gave:

checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

This was a bit vague, so running:

  /usr/bin/perl -e "require XML::Parser" 

showed that it could not load expat.so  Some searching on the net suggested that it was expat-2.0.0, so I downgraded from expat-2.0.0 to expat-1.95.8

This seems to have fixed this (by adding an entry in package.mask) 

(I was going to paste my config.log, but on submitting it said it was too long.. yet I don't see an attachment field.)
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-10-10 10:32:15 UTC

*** This bug has been marked as a duplicate of 41124 ***
Comment 2 Gregg Hesling 2007-01-08 05:33:33 UTC
NOT resolved.  Did an "emerge --sync" on Jan 6, 2007 followed by "emerge --update world" and got this error:

checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
!!! ERROR: dev-util/intltool-0.35.0 failed.

ran "emerge -a XML-Parser" then "emerge -a intltool" and it worked fine.

Note: Hadn't updated my system in about six months.