Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 1501

Summary: when wine is installed, xemacs needs --with-msw=no
Product: Gentoo Linux Reporter: jseng
Component: New packagesAssignee: Matthew Kennedy (RETIRED) <mkennedy>
Status: RESOLVED FIXED    
Severity: normal CC: agenkin, sloan
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description jseng 2002-04-03 11:26:31 UTC
When wine is installed, in order to compile xemacs correctly you need to have
the --with-msw=no flag in the ./configure or else it will try to include
windows libraries
Comment 1 Sloan Poe 2002-04-06 09:48:31 UTC
I also had a compile error... So I added this to the ebuild file, and now it
seems to compile without a hitch.. Could someone maybe add this officially?
Comment 2 Sloan Poe 2002-04-06 09:58:38 UTC
Ok so maybe I spoke to soon, it seems that though it compiled, trying to run
xemacs causes a segfault.. :(
Comment 3 Sloan Poe 2002-04-06 10:43:23 UTC
Well to wrap it up, I got it to run twice.  I'm not really sure that I did
anything, but it ran.  Now its back to segfaulting.
Comment 4 Arcady Genkin (RETIRED) gentoo-dev 2002-04-08 23:46:05 UTC
What version of Xemacs are you guys talking about?
Comment 5 jseng 2002-04-08 23:51:37 UTC
xemacs version 21.1.14.  I get the segfaulting too.
Comment 6 Seemant Kulleen (RETIRED) gentoo-dev 2002-04-11 01:14:44 UTC
Matt is an xemacs user, and he seems familiar with this issue, so I am passing
this on to him.
Comment 7 Eugene Koontz 2002-04-11 13:52:00 UTC
Just to give another data point for the debugging people, emerge 
xemacs worked fine for me, after I added the --with-msw=no switch. 
Doing "emerge xemacs" installed xemacs version 21.4.6. No segfaults 
for me. 
Comment 8 Matthew Kennedy (RETIRED) gentoo-dev 2002-04-15 01:51:56 UTC
Howdy all,

The xemacs segfaults you are seeing seem to be related to sandbox. This is a
problem that is being currently researched by gentoo developers. In the mean
time, there are two work-arounds:

1. If you have a segfaulting xemacs you can run xemacs like this to avoid the
segfaulting:

   LD_PRELOAD=/usr/lib/portage/lib/libsandbox.so xemacs

Better yet, define yourself an alias:

   alias xemacs='LD_PRELOAD=/usr/lib/portage/lib/libsandbox.so xemacs'

2. If you feel like re-emerging xemacs, temporarily change the FEATURES="..."
line in /etc/make.conf from "sandbox" to "-sandbox". Then "emerge xemacs". The
resulting xemacs binary should no longer segfault. At this point you can restore
your old FEATURES="..." line in /etc/make.conf to include "sandbox" (a good idea).

eg. If my FEATURES line looks like:

    FEATURES="sandbox digest noclean"

then I change it to:

    FEATURES="-sandbox digest noclean"

then "emerge xemacs", then change back to 

    FEATURES="sandbox digest noclean"

Then run xemacs as you normally would (ie. no LD_PRELOAD setting required).
Comment 9 Matthew Kennedy (RETIRED) gentoo-dev 2002-04-15 11:06:53 UTC
Oh, and option 2. above can be replaced with:

   SANDBOX_DISABLED="1" emerge xemacs

Thanks to Sloan Poe et. al.

Matt
Comment 10 Matthew Kennedy (RETIRED) gentoo-dev 2002-04-16 23:21:26 UTC
The segfaulting problem in relation to sandbox should be fixed in
xemacs-21.4.6-r4. You no longer need to use the work-arounds above in -r4 -- the
work-around is built into the ebuild (sandbox has ben turned off for this ebuild
only).
Comment 11 Matthew Kennedy (RETIRED) gentoo-dev 2002-04-16 23:22:00 UTC
*** Bug 1574 has been marked as a duplicate of this bug. ***