Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 147987

Summary: sys-apps/coreutils-6.1 DEPEND >=sys-devel/autoconf-2.59d installs autoconf-2.60 but coreutils needs 2.59 autoconf during install - coreutils coreutils-6.1 autoconf autoconf-2.60 autoconf-2.59 Failed Running aclocal /usr/bin/autom4te-2.59 is missing or...
Product: Gentoo Linux Reporter: Alexander Gabert (RETIRED) <pappy>
Component: [OLD] Core systemAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Severity: minor    
Priority: Normal    
Version: 2006.1   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Alexander Gabert (RETIRED) gentoo-dev 2006-09-17 14:52:34 UTC
>>> Emerging (1 of 14) sys-apps/coreutils-6.1 to /

                                                                                                              [ ok ]
>>> Unpacking source...
>>> Unpacking coreutils-6.1.tar.bz2 to /var/tmp/portage/coreutils-6.1/work
>>> Unpacking coreutils-6.1-patches-1.0.tar.bz2 to /var/tmp/portage/coreutils-6.1/work


 * Done with patching
 * Running eautoreconf in '/var/tmp/portage/coreutils-6.1/work/coreutils-6.1' ...
 * Running aclocal -I m4 ...                                                                                                                                         [ !! ]

 * Failed Running aclocal !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/coreutils-6.1/temp/aclocal-679.out

!!! ERROR: sys-apps/coreutils-6.1 failed.
Call stack:, line 1546:   Called dyn_unpack, line 708:   Called src_unpack
  coreutils-6.1.ebuild, line 77:   Called eautoreconf
  autotools.eclass, line 65:   Called eaclocal
  autotools.eclass, line 102:   Called autotools_run_tool 'aclocal' '-I' 'm4'
  autotools.eclass, line 193:   Called die

!!! Failed Running aclocal !
!!! If you need support, post the topmost build error, and the call stack if relevant.

 23:49:08 [/space/chroots/chroot002:5262.pts-5.apocalypse]apocalypse ~
 # cat /var/tmp/portage/coreutils-6.1/temp/aclocal-679.out
***** aclocal *****

ac-wrapper: /usr/bin/autom4te-2.59 is missing or not executable.
            Please try emerging the correct version of autoconf.
aclocal-1.9: autom4te failed with exit status: 1

 # emerge info
*** Deprecated use of action 'info', use '--info' instead
Portage 2.1.1 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8 i686)
System uname: 2.6.17-gentoo-r8 i686 Intel(R) Celeron(R) CPU 2.53GHz
Gentoo Base System version 1.12.1
Last Sync: Sat, 16 Sep 2006 01:55:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r3
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17
CFLAGS="-O2 -mcpu=i686 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 berkdb bitmap-fonts cli crypt cups dlloader dri elibc_glibc fortran gdbm gpm input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog kernel_linux libg++ ncurses nls nptl nptlonly pam pcre perl ppds pppd python readline reflection session spl ssl tcpd truetype-fonts type1-fonts udev unicode userland_GNU video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo xorg zlib"

 23:46:15 [/space/chroots/chroot002:5262.pts-5.apocalypse]apocalypse /usr/portage/sys-apps/coreutils

This is an ~arch bug, so there is no priority in solving it!

The sys-apps/coreutils-6.1.ebuild uses the following DEPEND:


At the moment of this writing, portage installs autoconf-2.60 with the appropriate filenames because there is no 2.59d as far as i can see.

But coreutils-6.1 needs autoconf files to work that contain the suffix autoconf-2.59.

I was mangling the following two files but stopped doing this "fast hack" and instead started this bug thread:

1651682 -rwxr-xr-x 1 root root  13604 Sep 17 23:37 /usr/bin/autoconf-2.59
1817312 -rwxr-xr-x 1 root root  13604 Sep 17 23:33 /usr/bin/autoconf-2.60

1651722 -rwxr-xr-x 1 root root  30297 Sep 17 23:37 /usr/bin/autom4te-2.59
1817311 -rwxr-xr-x 1 root root  30297 Sep 17 23:33 /usr/bin/autom4te-2.60

As you can see from the file Size, its the same files, only copied from 2.60 to 2.59.

This way i could reproduce the error and provoke some others in correlation to the missing autoconf-2.59.


Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-09-17 14:55:55 UTC
Uh, please, use description field for description, writing 3 line summary sucks. 

The problem most likely is that you are mixing stable autoconf-wrapper with unstable autoconf. Make sure you have autoconf-wrapper-3.2-r2 installed.
Comment 2 Alexander Gabert (RETIRED) gentoo-dev 2006-09-18 23:33:54 UTC

sorry for being so undescriptive, i was never good at writing bug reports.

I was using a current stage3 from the mirrors, unpacked it, emerge synced and put "~x86" into the /etc/make.conf.

From then on i run emerge -uv world and then the error appeared.
Hope this helps, i am going to investigate the hint with the autoconf-wrapper now.

Comment 3 Alexander Gabert (RETIRED) gentoo-dev 2006-09-18 23:40:10 UTC
emerge -v autoconf-wrapper autoconf coreutils

this solved it.

interesting, the other ~arch chroot on another machine didn't suffer from that "hickup", probably this bug is just an odd behaviour that only happens under special circumstances.

Nevermind, thanks for your help and thanks for the good advice with the autoconf-wrapper.-

Comment 4 Alexander Gabert (RETIRED) gentoo-dev 2011-03-07 00:06:51 UTC
The original summary for this bug was longer than 255 characters, and so it was truncated when Bugzilla was upgraded. The original summary was:

sys-apps/coreutils-6.1 DEPEND >=sys-devel/autoconf-2.59d installs autoconf-2.60 but coreutils needs 2.59 autoconf during install - coreutils coreutils-6.1 autoconf autoconf-2.60 autoconf-2.59 Failed Running aclocal  /usr/bin/autom4te-2.59 is missing or not executable