Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 146441

Summary: mc-4.6.(0|1) bug in subshell
Product: Gentoo Linux Reporter: Yaroslav Isakov <yaroslav.isakov>
Component: [OLD] Core systemAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: VERIFIED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Other   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: patch for setup.c
patch for subshell.c

Description Yaroslav Isakov 2006-09-05 12:49:57 UTC
I have strange bug. Steps to reproduce
1) start mc
2) press ctrl-o
3) press <space> then <backspace>
4) press ctrl-o again
5) when change direcories in mc, the name of dir in command prompt is unchanged and when i try to execute command in command prompt, then mc show me the message:
   The shell is already running a command
The solution of this is to switch back to subshell and hit <enter> (maybe others keys, i didn't test) 

I was found the patch for mc-4.6.0 and ported it to 4.6.1. This patch blocked ctrl-o until subshell is non-blocking (i use <enter> key to enable ctrl-o)
Comment 1 Yaroslav Isakov 2006-09-05 12:53:28 UTC
Created attachment 96102 [details, diff]
patch for setup.c
Comment 2 Yaroslav Isakov 2006-09-05 12:54:06 UTC
Created attachment 96103 [details, diff]
patch for subshell.c

you need both
Comment 3 Raúl Porcel (RETIRED) gentoo-dev 2006-09-05 13:18:27 UTC
Please, include those patches in bug #146437

*** This bug has been marked as a duplicate of 146437 ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-09-05 13:41:35 UTC
.