Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 145805

Summary: sys-apps/hal-0.5.7.1 should not depend on sys-apps/hotplug
Product: Gentoo Linux Reporter: Heiko Baums <heiko>
Component: New packagesAssignee: Doug Goldstein (RETIRED) <cardoe>
Status: RESOLVED INVALID    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Heiko Baums 2006-08-31 22:18:39 UTC
Analogous to bug #142604 and bug #143660 sys-apps/hal-0.5.7.1 should not depend on sys-apps/hotplug.

The reason is that hotplug and udev conflicts with each other because of udev's built in hotplug functionality. So hotplug and udev shouldn't be installed parallel.

I've explained the reasons for this more detailed in the bug reports mentioned above.

It would be better if hal depended on sys-apps/hotplug-base because this is a dependency of hotplug as well as of udev.
Comment 1 Heiko Baums 2006-08-31 22:24:23 UTC
*** Bug 145806 has been marked as a duplicate of this bug. ***
Comment 2 Doug Goldstein (RETIRED) gentoo-dev 2006-10-30 17:35:13 UTC
Actually yes it should. According to the udev author himself, udev does not provide that functionality fully yet.