Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 145475

Summary: CUPS 1.2.2 web interface does not work
Product: Gentoo Linux Reporter: Arno Hahma <arno>
Component: [OLD] PrintingAssignee: Printing Team <printing>
Status: RESOLVED NEEDINFO    
Severity: normal CC: iellis
Priority: High    
Version: 2006.0   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Arno Hahma 2006-08-29 06:47:16 UTC
After upgrading cups 1.2.0 to 1.2.2 the web interface (localhost:631) broke completely. Now there are no background, no buttons etc. visible and clicking on them produces mostly no result or html-errors. No special USE -flags apart from the ones below were used.



Portage 2.1-r2 (default-linux/alpha/2006.0, gcc-3.3.2, glibc-2.3.5-r3, 2.6.15.1 alpha)
=================================================================
System uname: 2.6.15.1 alpha EV6
Gentoo Base System version 1.6.14
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5, 2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r4
ACCEPT_KEYWORDS="alpha"
AUTOCLEAN="yes"
CBUILD="alpha-unknown-linux-gnu"
CFLAGS="-mieee -O3 -mcpu=ev6"
CHOST="alpha-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-mieee -O3 -mcpu=ev6"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="alpha X X509 acl alsa apache2 arts berkdb bitmap-fonts bzip2 cli crypt cups dlloader dri dvd eds encode esd foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imap imlib ipv6 isdnlog jpeg kde kerberos libg++ libwww mad maildir mikmod motif mp3 mpeg mysql ncurses nls nptl nptlonly ogg opengl oss pam pcre pdflib perl png pppd python qt qt3 quicktime readline reflection samba sasl sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts udev unicode vorbis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux userland_GNU video_cards_cirrus video_cards_ati video_cards_dummy video_cards_fbdev video_cards_glint video_cards_mga video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_v4l video_cards_vga video_cards_voodoo"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Stefan Schweizer (RETIRED) gentoo-dev 2006-08-30 18:07:46 UTC
please try to restart cups and tell me if it helps.
Comment 2 Ian Ellis 2006-08-31 14:33:10 UTC
I agree, it really is fubared.  If I go to http://localhost:631 I get a "404 Not Found" error, but if I go to http://localhost:631/printers it does list the printers.  From there I can start doing administration tasks, but none of the images on the page show and it is simply a white background.  It is usable but really does need to be fixed.
Comment 3 Stefan Schweizer (RETIRED) gentoo-dev 2006-08-31 14:37:02 UTC
and you are sure you restarted cups? I really cannot reproduce this here.
Comment 4 Ian Ellis 2006-08-31 16:14:52 UTC
I fixed it.  The problem was that I didn't follow all those instructions that portage spit out in the notification because it got updated with a bunch of other things.  I downgraded, then upgraded again and followed them this time.  So everything's good now.