Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 144424

Summary: !!! ERROR: sys-fs/e2fsprogs-1.39 failed.
Product: Gentoo Linux Reporter: Ty <rndbox>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: 2006.0   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Ty 2006-08-19 08:30:25 UTC
making all in intl
make[2]: Entering directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39/intl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39/intl'
make[1]: Leaving directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39'
make progs
make[1]: Entering directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39'
make[2]: Entering directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39'
make[2]: `lib/ext2fs/ext2_types.h' is up to date.
make[2]: Leaving directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39'
make[2]: Entering directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39'
make[2]: `lib/blkid/blkid_types.h' is up to date.
make[2]: Leaving directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39'
make[2]: Entering directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39'
make[2]: `lib/uuid/uuid_types.h' is up to date.
make[2]: Leaving directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39'
making all in e2fsck
make[2]: Entering directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39/e2fsck'
CC dict.c
COMPILE_ET prof_err.et
CC unix.c
CC e2fsck.c
CC super.c
CC pass1.c
CC pass1b.c
pass1b.c: In function `e2fsck_pass1_dupblocks':
pass1b.c:231: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [pass1b.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39/e2fsck'
make[1]: *** [all-progs-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/e2fsprogs-1.39/work/e2fsprogs-1.39'
make: *** [all] Error 2

!!! ERROR: sys-fs/e2fsprogs-1.39 failed.
Call stack:
ebuild.sh, line 1539:   Called dyn_compile
ebuild.sh, line 939:   Called src_compile
e2fsprogs-1.39.ebuild, line 97:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.

I'm doing emerge and viewing this page in elinks hopefully the text pasted correctly.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-08-19 08:32:16 UTC
Can you reproduce the problem, i.e. - does it fail again at *exactly* the same place? If so, you need to post emerge --info and attach the preprocessed source here.
Comment 2 Ty 2006-08-19 08:39:24 UTC
wow! I'm v.surprise I think you've probably break the fastest record in replying to a bug report :p

I continue with the emerge and it has now passed that point.  Previously my first post the compilation output says it's not reproducible.

Here's the emerge --info, and btw, please enlightened me what's a preprocessed source and where to find it?

Portage 2.1-r2 (hardened/x86/2.6, gcc-3.4.6, glibc-2.3.6-r4, 2.6.17-gentoo-r4 i686)
=================================================================
System uname: 2.6.17-gentoo-r4 i686 AMD Athlon(tm) XP 1700+
Gentoo Base System version 1.12.4
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i386-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O3 -pipe"
CHOST="i386-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon-xp -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.gentoo.gr.jp ftp://ftp.twaren.net/Linux/Gentoo/ http://ftp://ftp.ncnu.edu.tw/Linux/Gentoo/ http://modzer0.cs.uaf.edu/public/gentoo/ "
MAKEOPTS="-j2"
PKGDIR="/usr/portage//packages/x86/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage/"
SYNC="rsync://rsync.asia.gentoo.org/gentoo-portage"
USE="3dnow 7zip X acpi alsa automount bash-completion berkdb c++ c3p0 cdr cdrom chroot cjk crypt css cups dhcp dlloader firefox
gaim gdb gtk2 gvim hal hardened html j2ee jad java javacomm javamail javascript jce jcs junit log4j logrotate md5sum mmx mp3 msn netbeans nforce2 nls nptl nptlonly ntfs ntlm odbc opengl openssh openssl oscache oss pam pic posix readline reiser4 reiserfs scim scp screen servlet-2.3 servlet-2.4 sftp soap sql sse ssl subversion symlink syslog sysvipc tcpd truetype-fonts unicode usb userlocales vcd vim vim-with-x vnc vncviewer wma x11vnc x86 xmms xorg yahoo zlib elibc_glibc input_devices_mouse input_devices_keyboard kernel_linux userland_GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-08-19 08:42:11 UTC
Oh, OK - if you can't reproduce it, we don't need the preprocessed source. Check the other bug for hints what may cause random compile failures. Thanks.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-08-19 08:42:24 UTC

*** This bug has been marked as a duplicate of 20600 ***