Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 143660

Summary: net-wireless/bluez-bluefw-1.0 shouldn't depend on hotplug
Product: Gentoo Linux Reporter: Heiko Baums <heiko>
Component: New packagesAssignee: Alastair Tse (RETIRED) <liquidx>
Status: RESOLVED FIXED    
Severity: normal CC: mobile+disabled
Priority: High    
Version: 2006.0   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Heiko Baums 2006-08-12 05:42:28 UTC
Analogous to bug #142604 shouldn't also net-wireless/bluez-bluefw-10 depend on sys-apps/hotplug because >=sys-fs/udev-096 has hotplug functionality built in and seems to have conflicts with sys-apps/hotplug.

Hints for the conflicts can be found here in bugzilla and in the forums. Unfortunately I don't have a link right now. But I had some issues with my usb scanner, the /dev/cdrom and /dev/dvd links and udev rules which have been ignored by udev. After unmerging hotplug everything is working well again as before I'd upgraded to the first udev version with hotplug and coldplug functionality, before udev-089 I guess.

So it's not really useful if hotplug is installed automatically again because of the bluez-bluefw dependency.

Maybe there are other packages which depend on hotplug. They are of course also affected and should be changed correspondingly.

Maybe there could be made a virtual/hotplug on which these packages could depend and virtual/hotplug is inherited by hotplug as well as the newer udev versions.

It's possibly sufficient if bluez-bluefw depended on sys-apps/hotplug-base instead of sys-apps/hotplug because sys-apps/hotplug-base is a dependecy of sys-apps/hotplug as well as sys-fs/udev.

emerge --info:

Gentoo Base System version 1.12.1
Portage 2.1.1_pre4-r2 (default-linux/x86/2006.0, gcc-3.4.6/vanilla,
glibc-2.4-r3, 2.6.17-gentoo-r4 i686)
=================================================================
System uname: 2.6.17-gentoo-r4 i686 AMD Athlon(tm) XP 1600+
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: [Not Present]
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler
/etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo
/etc/texmf/web2c"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
http://gd.tuwien.ac.at/opsys/linux/gentoo/
ftp://pandemonium.tiscali.de/pub/gentoo/
http://pandemonium.tiscali.de/pub/gentoo/"
LANG="de_DE.UTF-8"
LINGUAS="de"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/usr/var"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X a52 aac aalib accessibility acpi alsa apache2 apm
arts asf audiofile avi berkdb bitmap-fonts bluetooth bzip2 cdda cddb cdparanoia
cdr chipcard cli crypt cups curl dga directfb divx4linux dlloader doc dri dv
dvb dvd dvdr dvdread eds effects emacs emboss encode expat extrafilters fame
fbcon ffmpeg flac foomaticdb fortran ftp gcc-libffi gcj gd gdbm geldkarte gif
gimp gimpprint glitz gmp gpm graphviz gs gstreamer gtk gtk2 gtkhtml hbci iconv
idn imagemagick imlib inkjar ipv6 irmc isdnlog jce jpeg kde lcms ldap leim
libg++ libwww lirc live mad mailwrapper mbox mbrola mikmod ming mjpeg mmx mmx2
mmxext mng modplug motif mozilla mp3 mp4 mpeg mplayer mysql mysqli nas ncurses
network nls nptl nptlonly nsplugin nvidia objc objc-gc odbc offensive ofx ogg
oggvorbis opengl oss pam pcre pdf pdflib perl php plugin png ppds pppd print
python qt qt3 qt4 quicktime quotes readline real reflection rtc rtsp scanner
sdl session slang slideshow smime speex spell spl sqlite sse sse-filters ssl
svg svga tcltk tcpd tetex theora threads tidy tiff tokenizer tools truetype
truetype-fonts type1-fonts udev unicode usb v4l v4l2 vdr vidix visualization
vlm vorbis win32codecs wmf xcomposite xine xml xml2 xmms xorg xpm xv xvid yv12
zip zlib elibc_glibc input_devices_evdev input_devices_keyboard
input_devices_mouse kernel_linux linguas_de lirc_devices_devinput userland_GNU
video_cards_nvidia video_cards_v4l"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, MAKEOPTS,
PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alastair Tse (RETIRED) gentoo-dev 2006-08-12 06:30:51 UTC
without any context except for the hpilp bug, i don't quite understand what the problem is since i have both hotplug and udev installed and they don't seem to conflict.

but nevertheless, i'll change the dep to hotplug-base. hope that somehow solves the issue for you. bluez-bluefw isn't really required for more modern kernels because /lib/firmware/ supercedes it. but if you are using an older kernel, then maybe you still require it.
Comment 2 Heiko Baums 2006-08-12 07:33:18 UTC
I guess bluez-bluefw was installed as a dependency and wasn't uninstalled by emerge --depclean. If it's not needed anymore I'll try to uninstall it.

As you possibly know there are many and long discussions about inconsistant linkings for some devices like /dev/cdrom, /dev/cdrw etc. in the forums.

Many people including myself have the problem that randomly after each reboot sometimes /dev/cdrom is their CD-ROM drive and /dev/cdrw is their CD-RW burner and sometimes it's vice versa. Additional there are sometimes links like /dev/cdrom1 which are randomly linked against different devices.

Another problem is that some udev rules for some usb devices like setting the owner and group for the usb scanner are ignored even if they look correct.

After searching and reading a lot in the forums and in bugzilla I had the idea to uninstall hotplug and delete the directories /etc/hotplug*.

After this and rebooting the system every problem with the device links and the udev rules were fixed without changing anything else. The device links are consitant and link to the correct devices and the udev rules are applied again so that the correct permissions are set again.

That's why I suppose that there is a conflict between hotplug and udev.

And, btw., hotplug isn't needed anylonger if a newer udev version with built in hotplug functionality is installed. ;-)

If you have both udev and hotplug installed you have the same software installed twice. It's not quite unusual that this can lead to conflicts.

And thanks for the fix. :-)
Comment 3 Alastair Tse (RETIRED) gentoo-dev 2006-08-12 09:16:22 UTC
ok, that does seem to make sense to me. i suppose because i have one of everything, this never really happens to me. but it might explain on my machine why i'm able to use udev to rename only one of my network devices and not the other as maybe hotplug is interfering with udev's operation.

btw, i should also make explicit, bluez-bluefw is replaced by bluez-firmware which  recent kernel modules will use the built in firmware loading features and will search /lib/firmware/.

you only need bluez-firmware if you have a non-CSR (cambridge silicon radio) bluetooth device.

Comment 4 Heiko Baums 2006-08-12 09:55:11 UTC
bluez-firmware looks more familiar than bluez-bluefw. So I'll uninstall it. I don't know if I really need firmware related package for a simple bluetooth dongle to connect to a cell phone.

I think you should just try it out and also unmerge hotplug. I guess then you can rename your other network devices again.

After my next emerge -uDN world which is hopefully in about 1 1/2 or 2 days I'll search the forums again and post the hotplug/udev thing in a more appropriate place and/or file another bug/feature request that the udev ebuild should not only block coldplug but also hotplug.