Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 140783

Summary: x11-apps/xclock-1.0.2 - won't compile due to missing libexpat.so.0
Product: Gentoo Linux Reporter: Arnvid L. Karstad <arnvid>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: minor    
Priority: High    
Version: 2006.0   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Arnvid L. Karstad 2006-07-17 07:22:36 UTC
When upgrading an older machine I stumbeled into alot of small problems. And one of them were this one. 

i686-pc-linux-gnu-gcc  -march=pentium4 -msse2 -O3 -mmmx -mfpmath=sse -pipe -fomit-frame-pointer   -o xclock  xclock-Clock.o xclock-xclock.o -lX11   -lXaw7 -lXmu -lXt -lX11 -lSM -lICE   -lXft -lXrender -lfontconfig -lfreetype -lz -lX11   -lxkbfile   -lm
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../../i686-pc-linux-gnu/bin/ld: warning: libexpat.so.0, needed by /usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_SetElementHandler'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_SetDoctypeDeclHandler'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_ParserFree'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_SetCharacterDataHandler'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_ErrorString'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_ParseBuffer'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_ParserCreate'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_SetUserData'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_GetErrorCode'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_GetBuffer'
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../libfontconfig.so: undefined reference to `XML_GetCurrentLineNumber'
collect2: ld returned 1 exit status
make[1]: *** [xclock] Error 1
make[1]: Leaving directory `/var/tmp/portage/xclock-1.0.2/work/xclock-1.0.2'
make: *** [all] Error 2

!!! ERROR: x11-apps/xclock-1.0.2 failed.
Call stack:
  ebuild.sh, line 1545:   Called dyn_compile
  ebuild.sh, line 940:   Called src_compile
  ebuild.sh, line 1254:   Called x-modular_src_compile
  x-modular.eclass, line 327:   Called x-modular_src_make
  x-modular.eclass, line 322:   Called die

!!! emake failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


/usr/lib/libexpat.so.1 - exists
/usr/lib/libexpat.so.0 - does not exist..

updating symlink from so.0 -> libexpat.so.1.5.0 works

Portage 2.1.1_pre3-r1 (default-linux/x86/2006.0, gcc-3.4.5/vanilla, glibc-2.4-r3, 2.6.13-ck2 i686)
=================================================================
System uname: 2.6.13-ck2 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.12.1
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-lang/python:     2.3.4-r1, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -msse2 -O3 -mmmx -mfpmath=sse -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/eselect/compiler /etc/gconf /etc/terminfo"
CXXFLAGS="-march=pentium4 -msse2 -O3 -mmmx -mfpmath=sse -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X aac acpi acpi4linux alsa apache2 apm arts autofs avi berkdb bitmap-fonts cddb chroot cli crypt cups dlloader dri dvd dvdr eds emboss encode escreen esd foomaticdb fortran gdbm gif gpm gstreamer gtk gtk2 imlib ipv6 isdnlog jpeg kde libg++ libwww mad mikmod motif mp3 mpeg mpeg4 mppe-mppc ncurses nptl nptlonly ogg opengl openssh oss pam pcre pdflib perl png pppd python qt qt3 qt4 quicktime readline reflection sdl session spell spl sse ssl tcpd truetype truetype-fonts type1-fonts udev usb vhosts vorbis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_vesa video_cards_fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-07-17 07:27:52 UTC
Run revdep-rebuild...


*** This bug has been marked as a duplicate of 128069 ***