Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 140588

Summary: autotrace-0.31.1 fails with --as-needed
Product: Gentoo Linux Reporter: Brant Gurganus <brant>
Component: Current packagesAssignee: Gentoo Graphics Project <graphics+disabled>
Status: RESOLVED FIXED    
Severity: normal CC: flameeyes, masterdriverz
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 129413    
Attachments: patch for when --as-needed is used

Description Brant Gurganus 2006-07-15 20:50:30 UTC
autotrace-0.31.1 fails with --as-needed in LDFLAGS. I have created a patch for the issue.
Comment 1 Brant Gurganus 2006-07-15 20:52:02 UTC
Created attachment 91843 [details, diff]
patch for when --as-needed is used

This patch adds libpng and ImageMagick libraries to the Automake instruction building the autotrace library.
Comment 2 Brant Gurganus 2006-07-15 20:57:45 UTC
I have sent an e-mail to the upstream maintainer listed at the bottom of http://autotrace.sourceforge.net/index.html with the patch as well.
Comment 3 Petteri R├Ąty (RETIRED) gentoo-dev 2007-09-07 12:01:32 UTC
This seems to be fixed in 0.31.1-r2 for some time now:


*autotrace-0.31.1-r2 (20 Jan 2007)

  20 Jan 2007; Mike Frysinger <vapier@gentoo.org>
  +files/autotrace-0.31.1-libs.patch, +autotrace-0.31.1-r2.ebuild:
  Cleanup ebuild, add support for USE=pdf, and fix linking of libautotrace.