Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 140197

Summary: compile problem: media-gfx/imagemagick-6.2.5.5
Product: Gentoo Linux Reporter: Felix von Courten <courten>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: VERIFIED DUPLICATE    
Severity: major    
Priority: High    
Version: 2006.0   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Felix von Courten 2006-07-13 01:59:36 UTC
emerge media-gfx/imagemagick-6.2.5.5

produces following error:
If /bin/sh ./libtool --silent --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc-D
HAVE_CONFIG_H -I. -I. -I./magick -I./wand -march=k8 -02 -pipe -wall -pthread
 -MT coders/coders_png_la-png.lo -MD -MP -MF "coders/.deps/coders_png_la-png.Tpo
" -c -o coders/coders_png_la-png.lo `test -f 'coders/png.c' || echo './'`coders/
png.c; \
then mv -f "coders/.deps/coders_png_la-png.Tpo" "coders/.deps/coders_png_la-png.Plo";
else rm -f "coders/.deps/coders_png_la-png.Tpo"; exit 1; fi
coders/png.c: in function `ReadOnePNGImage':
coders/png.c:1755: warning: implicit declaration of function `png_access_version'
coders/png.c:1764: error: `png_ptr' undeclared (first use in this function)
coders/png.c:1764: error: (Each undeclared identifier is reported only once
coders/png.c:1764: error: for each function it appears in.)

make: ***[coders/coders_png_la_png_lo] Fehler 1
make: *** Warte auf noch nicht beendete Prozesse...

!!! Error: media-gfx/imagemagick-6.2.5.5 failed.
Call Stack
ebuild.sh, line 1539: Called dyn_compile
ebuild.sh, line 939: Called src_compile
imagemagick-6.2.5.5.ebuld, line 86 Called die
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-07-13 02:09:03 UTC

*** This bug has been marked as a duplicate of 140196 ***
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-07-13 02:15:51 UTC
.