Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 138366

Summary: kernel-2.6.16.19: Eeek! page_mapcount(page) went negative! (-1)
Product: Gentoo Linux Reporter: Evert <evert.gentoo>
Component: [OLD] Core systemAssignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers <kernel>
Status: VERIFIED UPSTREAM    
Severity: normal CC: desowin
Priority: High    
Version: 2006.0   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Evert 2006-06-28 08:54:03 UTC
I don't know how this happened, but on a remote root-logged-in terminal I saw the following after the computer crashed. I had to do a hard reset to reboot the computer since the crash also caused ssh to stop. I hope the kernel developers can do something with this information.

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: Eeek! page_mapcount(page) went negative! (-1)

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:   page->flags = 8001003c

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:   page->count = 1

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:   page->mapping = f6ad2418

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: ------------[ cut here ]------------

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: kernel BUG at mm/rmap.c:560!

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: invalid opcode: 0000 [#1]

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: PREEMPT

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: CPU:    0

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: EIP is at page_remove_rmap+0x93/0xa0

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: eax: ffffffff   ebx: c1234040   ecx: 0000827e   edx: c0374d01

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: esi: b2570000   edi: c1234040   ebp: cdf8bf2c   esp: cdf8be84

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: ds: 007b   es: 007b   ss: 0068

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: Process X (pid: 27937, threadinfo=cdf8a000 task=dc73da90)

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: Stack: <0>c0327022 f6ad2418 dc6fd5c0 c014592f c1234040 b2570000 11a0 2067 11a02067

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:        fffffffc ffffffff d6c562e0 b26ab000 e465fb28 b26ab000 cdf8bf2 c c0145ac5

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:        c03dbbec f0cd96fc e465fb24 b256c000 b26ab000 cdf8bf2c 0000000 0 b26aafff

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: Call Trace:

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [zap_pte_range+351/576] zap_pte_range+0x15f/0x240

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [<c014592f>] zap_pte_range+0x15f/0x240

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [unmap_page_range+181/320] unmap_page_range+0xb5/0x140

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [<c0145ac5>] unmap_page_range+0xb5/0x140

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [unmap_vmas+239/496] unmap_vmas+0xef/0x1f0

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [<c0145c3f>] unmap_vmas+0xef/0x1f0

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [unmap_region+149/304] unmap_region+0x95/0x130

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [<c014a255>] unmap_region+0x95/0x130

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [do_munmap+275/384] do_munmap+0x113/0x180

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [<c014a5d3>] do_munmap+0x113/0x180

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [sys_munmap+68/112] sys_munmap+0x44/0x70

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [<c014a684>] sys_munmap+0x44/0x70

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [sysenter_past_esp+84/117] sysenter_past_esp+0x54/0x75

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel:  [<c0102ddb>] sysenter_past_esp+0x54/0x75

Message from syslogd@amd at Tue Jun 27 12:25:13 2006 ...
amd kernel: Code: 53 0c 8b 42 04 c7 04 24 0b 70 32 c0 40 89 44 24 04 e8 c2 b0 fc  ff 8b 43 10 c7 04 24 22 70 32 c0 89 44 24 04 e8 af b0 fc ff eb 86 <0f> 0b 30 02  e0 6f 32 c0 eb 82 8d 76 00 83 ec 2c 89 5c 24 1c 8b
#



# emerge --info
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16.19 i686)
=================================================================
System uname: 2.6.16.19 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.6.15
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/data/linux/gentoo/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://ftp6.uni-muenster.de/pub/linux/distributions/gentoo http://gentoo.mirror.sdv.fr http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://gentoo.inode.at/"
MAKEOPTS="-j2"
PKGDIR="/data/linux/gentoo/packages/amd_athlon-xp"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/compile"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac aalib alsa apache2 apm audiofile avi berkdb bitmap-fonts bzip2 cdr cli crypt cups curl directfb dri dts dvd dvdr dvdread eds emboss encode esd exif expat fam ffmpeg flac foomaticdb fortran gdbm gif glut gmp gnome gpm gstreamer gtk gtk2 gtkhtml idn imagemagick imlib ipv6 isdnlog jack java jpeg lcms ldap libg++ libwww mad mikmod mmx mng motif mozilla mp3 mpeg mplayer mysql ncurses nls nptl ogg openal opengl oss pam pcre pdflib perl png pppd python qt quicktime readline recode reflection ruby samba sdl session slang spell spl sse ssl svg svga tcltk tcpd tiff truetype truetype-fonts type1-fonts udev unicode usb vcd vorbis wmf xine xml xml2 xmms xorg xv xvid zlib elibc_glibc kernel_linux userland_GNU video_cards_nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Daniel Drake (RETIRED) gentoo-dev 2006-07-01 10:02:45 UTC
Sent a message to the linux kernel list. If this happens again, please reopen.
Comment 2 Daniel Drake (RETIRED) gentoo-dev 2006-07-01 11:53:37 UTC
Were those messages edited at all by yourself?
Were there any binary modules loaded at time of crash? (e.g. nvidia-kernel video driver)
Comment 3 Evert 2006-07-02 00:39:54 UTC
No, those messages were all copy/pasted by myself which is possible since I was  remote logged in as root from a command line terminal on another gentoo machine, and in that terminal, those messages appeared.

And yes, there were binary modules loaded since the computer is both a server (apache2, bind, ldap, nfs, ssh) and a workstation (gnome, xmms, mozilla ...), and yes, nvidia-kernel (1.0.7174-r2) was also loaded since I have a GeForce2 Pro.
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2006-07-02 05:22:16 UTC
This message is near impossible to occur on clean linux sources. The crash happened in the X process, you are running the closed source nvidia drivers, and the nvidia drivers are apparently known to cause this crash. We aren't able to take any action here, sorry.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-07-02 07:47:20 UTC
*** Bug 138863 has been marked as a duplicate of this bug. ***
Comment 6 Evert 2006-07-03 03:19:14 UTC
> the nvidia drivers are apparently known to cause this crash.
>  We aren't able to take any action here, sorry.

Well, at least now I'm pretty sure about the cause of the crash ;-)
Thanx for the answer!
Comment 7 Tomasz Mon 2006-07-03 03:51:51 UTC
(In reply to comment #4)
> This message is near impossible to occur on clean linux sources. The crash
> happened in the X process, you are running the closed source nvidia drivers,
> and the nvidia drivers are apparently known to cause this crash. We aren't able
> to take any action here, sorry.
> 

I've got this bug, and I don't have nvidia card

Eeek! page_mapcount(page) went negative! (-1)
page->flags = 400
page->count = 1
page->mapping = 00000000
------------[ cut here ]------------
kernel BUG at mm/rmap.c:560!
invalid opcode: 0000 [#1]
Modules linked in: snd_pcm_oss snd_mixer_oss snd_seq_oss snd_seq_midi_event
snd_seq snd_seq_device rt61 snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_pcm
snd_timer snd soundcore snd_page_alloc i2c_sis96x sis_agp rtc lirc_serial
lirc_dev radeon drm agpgart sl811_hcd ohci_hcd uhci_hcd usb_storage scsi_mod
usbhid ehci_hcd usbcore
CPU:    0
EIP:    0060:[<c014ce23>]    Tainted: P      VLI
EFLAGS: 00010286   (2.6.16-gentoo-r9 #6) 
EIP is at page_remove_rmap+0x93/0xa0
eax: ffffffff   ebx: c1000000   ecx: 00000001   edx: c03d7a0c
esi: b6dc4000   edi: c1000000   ebp: c6c85f34   esp: c6c85e8c
ds: 007b   es: 007b   ss: 0068
Process stardict (pid: 20508, threadinfo=c6c84000 task=cc676550)
Stack: <0>c038d7f4 00000000 ca889710 c01463f9 c1000000 b6dc4000 00000001
00000001 
00000000 fffffffe c31b6d80 b7000000 cf1b4b70 b7000000 c6c85f34 c0146595 
c045405c c0b038b4 cf1b4b6c b6d6b000 b7000000 c6c85f34 00000000 b747efff 
Call Trace:
[<c01463f9>] zap_pte_range+0x139/0x220
[<c0146595>] unmap_page_range+0xb5/0x140
[<c014670f>] unmap_vmas+0xef/0x1d0
[<c014b1db>] exit_mmap+0x6b/0xf0
[<c0116776>] mmput+0x26/0x80
[<c011b283>] do_exit+0xf3/0x3a0
[<c011b5a4>] do_group_exit+0x34/0x70
[<c010300f>] sysenter_past_esp+0x54/0x75
Code: 53 0c 8b 42 04 c7 04 24 dd d7 38 c0 40 89 44 24 04 e8 c2 c5 fc ff 8b 43
10 c7 04 24 f4 d7 38 c0 89 44 24 04 e8 af c5 fc ff eb 86 <0f> 0b 30 02 b2 d7 38
c0 eb 82 8d 76 00 83 ec 28 89 74 24 1c 8b 
<1>Fixing recursive fault but reboot is needed!


localhost ~ # emerge --info
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4,
2.6.16-gentoo-r9 i686)
=================================================================
System uname: 2.6.16-gentoo-r9 i686 AMD Duron(tm)
Gentoo Base System version 1.6.15
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon-tbird -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf
/etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=athlon-tbird -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="pl_PL.utf8"
LC_ALL="pl_PL.utf8"
LINGUAS="pl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
--force --whole-file --delete --delete-after --stats --timeout=180
--exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X aac alsa apache2 apm avi berkdb bitmap-fonts browserplugin cli
crypt cups dlloader dri dvd emboss encode fam flac foomaticdb fortran gdbm gif
gpm gstreamer gtk gtk2 hal imlib ipv6 isdnlog ithreads jpeg justify kde
kerberos libg++ libwww mad mikmod mmx motif mp3 mpeg ncurses nls nptl nsplugin
ogg openexr opengl pam pcre pdflib perl png ppds pppd python qt qt3 qt4
quicktime readline reflection sdl session spell spl ssl svg tcpd tiff truetype
truetype-fonts type1-fonts udev unicode utf8 vcd vorbis win32codecs xml xorg xv
zeroconf zlib elibc_glibc input_devices_keyboard input_devices_mouse
kernel_linux linguas_pl lirc_devices_irdeo userland_GNU video_cards_dri
video_cards_radeon video_cards_ati"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS,
PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Daniel Drake (RETIRED) gentoo-dev 2006-07-03 04:07:03 UTC
Your kernel is tainted (a binary module is loaded, or has been loaded since boot) and you are running some out-of-tree modules such as lirc. It is not possible to diagnose or send this on unless your kernel is clean.
Comment 9 Mat 2006-07-14 02:40:19 UTC
i have the same problem with kernel 2.6.16-gentoo-r7

Pasted by: pippocaru
Language: C++
Description: No description
Add line numbers
Download as Text
Other recent pastes
Create new paste

Jul 13 22:30:12 mail Eeek! page_mapcount(page) went negative! (-1)
Jul 13 22:30:12 mail page->flags = 8001007c
Jul 13 22:30:12 mail page->count = 1
Jul 13 22:30:12 mail page->mapping = ded13ef8
Jul 13 22:30:12 mail ------------[ cut here ]------------
Jul 13 22:30:12 mail kernel BUG at mm/rmap.c:560!
Jul 13 22:30:12 mail invalid opcode: 0000 [#4]
Jul 13 22:30:12 mail Modules linked in: rtc e100 mii dm_mirror dm_mod uhci_hcd
Jul 13 22:30:12 mail CPU:    0
Jul 13 22:30:12 mail EIP:    0060:[<c014b4de>]    Tainted: G    B VLI
Jul 13 22:30:12 mail EFLAGS: 00010286   (2.6.16-gentoo-r7 #1) 
Jul 13 22:30:12 mail EIP is at page_remove_rmap+0x9b/0xa8
Jul 13 22:30:12 mail eax: ffffffff   ebx: c1101500   ecx: 00000001   edx: c04539ac
Jul 13 22:30:12 mail esi: 0826e000   edi: c1101500   ebp: df926e40   esp: df926d98
Jul 13 22:30:12 mail ds: 007b   es: 007b   ss: 0068
Jul 13 22:30:12 mail Process apache2 (pid: 6673, threadinfo=df926000 task=df9af550)
Jul 13 22:30:12 mail Stack: <0>c0408586 ded13ef8 db3329b8 c0144ec7 c1101500 0826e000 080
a8067 080a8067 
Jul 13 22:30:12 mail fffffe7b ffffffff df654200 08400000 df656080 08400000 df926e40 c014
5064 
Jul 13 22:30:12 mail c04e60bc db312a14 df656080 08098000 08400000 df926e40 00000000 0860
1fff 
Jul 13 22:30:12 mail Call Trace:
Jul 13 22:30:12 mail [<c0144ec7>] zap_pte_range+0x139/0x222
Jul 13 22:30:12 mail [<c0145064>] unmap_page_range+0xb4/0x13a
Jul 13 22:30:12 mail [<c01451d5>] unmap_vmas+0xeb/0x1b7
Jul 13 22:30:12 mail [<c01499e2>] exit_mmap+0x6b/0xe4
Jul 13 22:30:12 mail [<c0115700>] mmput+0x26/0x6f
Jul 13 22:30:12 mail [<c0119ebe>] do_exit+0xf5/0x392
Jul 13 22:30:12 mail [<c011a1be>] do_group_exit+0x34/0x68
Jul 13 22:30:12 mail [<c01227b1>] get_signal_to_deliver+0x1bf/0x264
Jul 13 22:30:12 mail [<c0102bc0>] do_signal+0x73/0x15d
Jul 13 22:30:12 mail [<c0107de3>] convert_fxsr_from_user+0x25/0xef
Jul 13 22:30:12 mail [<c01080b5>] restore_i387_fxsave+0x88/0x9c
Jul 13 22:30:12 mail [<c010813f>] restore_i387+0x76/0x78
Jul 13 22:30:12 mail [<c010225e>] restore_sigcontext+0x10b/0x152
Jul 13 22:30:12 mail [<c0102348>] sys_sigreturn+0xa3/0xb2
Jul 13 22:30:12 mail [<c0102ce0>] do_notify_resume+0x36/0x3a
Jul 13 22:30:12 mail [<c0102e72>] work_notifysig+0x13/0x19
Jul 13 22:30:12 mail Code: 8b 42 04 c7 04 24 6f 85 40 c0 83 c0 01 89 44 24 04 e8 a7 cc f
Jul 13 22:30:12 mail <1>Fixing recursive fault but reboot is needed!
Jul 13 22:31:32 mail Eeek! page_mapcount(page) went negative! (-1)
Jul 13 22:31:32 mail page->flags = 80010078
Jul 13 22:31:32 mail page->count = 1
Jul 13 22:31:32 mail page->mapping = ded13ef8
Jul 13 22:31:32 mail ------------[ cut here ]------------
Jul 13 22:31:32 mail kernel BUG at mm/rmap.c:560!
Jul 13 22:31:32 mail invalid opcode: 0000 [#5]
Jul 13 22:31:32 mail Modules linked in: rtc e100 mii dm_mirror dm_mod uhci_hcd
Jul 13 22:31:32 mail CPU:    0
Jul 13 22:31:32 mail EIP:    0060:[<c014b4de>]    Tainted: G    B VLI
Jul 13 22:31:32 mail EFLAGS: 00010286   (2.6.16-gentoo-r7 #1) 
Jul 13 22:31:32 mail EIP is at page_remove_rmap+0x9b/0xa8
Jul 13 22:31:32 mail eax: ffffffff   ebx: c1105d40   ecx: 00000001   edx: c04539ac
Jul 13 22:31:32 mail esi: 08237000   edi: c1105d40   ebp: df92de40   esp: df92dd98
Jul 13 22:31:32 mail ds: 007b   es: 007b   ss: 0068
Jul 13 22:31:32 mail Process apache2 (pid: 6671, threadinfo=df92d000 task=c16c9550)
Jul 13 22:31:32 mail Stack: <0>c0408586 ded13ef8 db2e38dc c0144ec7 c1105d40 08237000 082
ea067 082ea067 
Jul 13 22:31:32 mail fffffeb2 ffffffff df5f2ac0 08400000 df60a080 08400000 df92de40 c014
5064 
Jul 13 22:31:32 mail c04e60bc db2c3964 df60a080 08098000 08400000 df92de40 00000000 0854
afff 
Jul 13 22:31:32 mail Call Trace:
Jul 13 22:31:32 mail [<c0144ec7>] zap_pte_range+0x139/0x222
Jul 13 22:31:32 mail [<c0145064>] unmap_page_range+0xb4/0x13a
Jul 13 22:31:32 mail [<c01451d5>] unmap_vmas+0xeb/0x1b7
Jul 13 22:31:32 mail [<c01499e2>] exit_mmap+0x6b/0xe4
Jul 13 22:31:32 mail [<c0115700>] mmput+0x26/0x6f
Jul 13 22:31:32 mail [<c0119ebe>] do_exit+0xf5/0x392
Jul 13 22:31:32 mail [<c011a1be>] do_group_exit+0x34/0x68
Jul 13 22:31:32 mail [<c01227b1>] get_signal_to_deliver+0x1bf/0x264
Jul 13 22:31:32 mail [<c0102bc0>] do_signal+0x73/0x15d
Jul 13 22:31:32 mail [<c0107de3>] convert_fxsr_from_user+0x25/0xef
Jul 13 22:31:32 mail [<c01080b5>] restore_i387_fxsave+0x88/0x9c
Jul 13 22:31:32 mail [<c010813f>] restore_i387+0x76/0x78
Jul 13 22:31:32 mail [<c010225e>] restore_sigcontext+0x10b/0x152
Jul 13 22:31:32 mail [<c0102348>] sys_sigreturn+0xa3/0xb2
Jul 13 22:31:32 mail [<c0102ce0>] do_notify_resume+0x36/0x3a
Jul 13 22:31:32 mail [<c0102e72>] work_notifysig+0x13/0x19
Jul 13 22:31:32 mail Code: 8b 42 04 c7 04 24 6f 85 40 c0 83 c0 01 89 44 24 04 e8 a7 cc f
c ff 8b 43 10 89 44 24 04 c7 04 24 86 85 40 c0 e8 94 cc fc ff eb 80 <0f> 0b 30 02 44 85 
40 c0 e9 7b ff ff ff 83 ec 28 89 74 24 1c 89 
Jul 13 22:31:32 mail <1>Fixing recursive fault but reboot is needed!
 
emerge --info
Gentoo Base System version 1.6.15
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r7 i6
86)
=================================================================
System uname: 2.6.16-gentoo-r7 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force 
--whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --excl
ude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 alsa apache2 apm arts avi berkdb bitmap-fonts cli crypt cups dlloader dri eds e
mboss encode esd foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imlib isdnlog 
jpeg kde libg++ libwww logrotate mad mikmod motif mp3 mpeg mysql ncurses nls nptl nptlon
ly ogg opengl oss pam pcre pdflib perl png pppd python qt qt3 qt4 quicktime readline ref
lection sasl sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts udev vor
bis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse input_d
evices_evdev kernel_linux userland_GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORT
AGE_RSYNC_EXTRA_OPTS

Comment 10 Daniel Drake (RETIRED) gentoo-dev 2006-07-14 03:02:40 UTC
Your kernel is also tainted, you are using some out-of-tree module which is screwing things up...