Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 136790

Summary: Xorg-X11 7x and nvidia-glx dri issues
Product: Gentoo Linux Reporter: Susie Edgeworth <mistatengwar>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Severity: major    
Priority: High    
Version: 2006.0   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---

Description Susie Edgeworth 2006-06-14 08:10:19 UTC
$ emerge --info
Portage 2.1 (default-linux/amd64/2006.0, gcc-3.4.4/amd64-vanilla, glibc-2.4-r3,                  
2.6.16-gentoo-r9 x86_64)
System uname: 2.6.16-gentoo-r9 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.1
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=athlon64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/mozilla/defaults/pref /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/eselect/compiler /etc/gconf /etc/revdep-reb                 
uild /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -pipe"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS=" ftp://         http://gento                         
ributions/gentoo/ "
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress                  
--force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/d                 
istfiles' --exclude='/local' --exclude='/packages'"
USE="amd64 7zip X a52 aac aalib acl acpi aim alsa ao apm artworkextra audiofile                  
bash-completion berkdb bitmap-fonts bonjour bonobo buttons bzip2 calendar cdda c                 
dio cdparanoia cdr corba crypt curl curlwrappers dga directfb disablexmb djbfft                  
dlloader dpms dri dts dvd dvdr dvdread edl emul-linux-x86 encode erandom esd exi                 
f extrafilters fame fat fbcon fbdev ffmpeg firefox flac fltk font-server fortran                 
 gatos ggi gif gimp glut gnome gpm grammar gs gtk gtk2 gtkhtml icq ieee1394 imag                 
emagick imlib imlib2 infopipe ipv6 jabber java javascript jikes jpeg jpeg2k lcms                 
 lesstif libcaca libwww live lzo lzw mad mbox mcal mikmod mime mjpeg mng mod mot                 
if mp3 mpeg mplayer msession msn musepack ncurses network nomac nptl nptlonly ns                 
plugin ntfs nvidia offensive ogg openal opengl oscar pam parse-clocks pcre pda p                 
df perl png portaudio python qt quicktime rar readline reiserfs rtc rtsp scanner                 
 sdk sdl shout skins sndfile spamassassin spell ssl stream svg symlink tcltk tcp                 
d tga theora thesaurus tiff timidity toolbar transcode truetype truetype-fonts t                 
ype1 type1-fonts usb v4l v4l2 vcd verbose vorbis wmf wordperfect x264 xanim xcha                 
tdccserver xface xml xml2 xmms xorg xpm xscreensaver xv xvid xvmc yahoo zlib eli                 
bc_glibc input_devices_keyboard input_devices_mouse input_devices_acecad kernel_                 
linux userland_GNU video_cards_nvidia video_cards_fbdev video_cards_v4l"


While X does load after emerging nvidia-glx and xorg-x11 it is having rendering issues.  For example right now for links on this page I see a medium blue underline but no text.  Submit buttons lack text.  This happens not just in mozilla firefox but other apps too.  Opera has invisible text menu, fluxbox is missing part of it's menu unless items are highlighted.  Switching to the login terminal from X I see it's complaining DRI didn't load and I should re emerge nvidia-glx.  But to do that because xorg-server blocks nvidia-glx and nvidia-glx blocks nvidia server you have to unmerge nvidia-server and remerge nvidia-glx.  Even in doing that it doesn't fix the problem.  The rendering issue remains. 

I tried turning off the nvidia in make.conf in both the USE and VIDEO_CARDS flags.  Figuring maybe I should give up and try the NV driver.  That didn't work either because of the blocks.

It would be nice if maybe there was a second xorg-server ebuild maybe rename one xorg-server-nvidia.  Because I can't update my system easily.  When I run "emerge -uDvN world" I'm presented with a block/block loop.  Nvidia-glx blocks xorg-server and xorg-server blocks nvidia-glx.  So to update my system I have to manually enter every package it says needs updated.  As mentioned even removing nvidia flags and trying to use the nv34 driver instead gets me nowhere because the block/block means I can't update my system unless it's manual.

Frustrated with the rendering issue and the update issue I tried Fedora Core 5.  I'm obviously back on Gentoo.  But I had hoped in the days I had been on Fedora that by the time I got back to gentoo things would be fixed.(fedora using modular X worked fine but I missed gentoo)  

I did search this bugzilla for a solution.  Maybe it is under a different subject line.  I also posted on forums about this.  Still nothing on how to fix these issues.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-06-14 08:23:37 UTC
It doesn't work, it's blocked, unmerge it and go complain upstream, or wait for a fixed version, or use xf86-video-nv, or downgrade xorg-server.

We can't fix binary drivers, end of story. 
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-06-14 08:26:30 UTC
For completeness sake, the incorrect blocks are handled in Bug 136788. 

Closing this, nothing we could do here.