Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 136742

Summary: portage does digest verifications for versions of a package that it does not need to emerge
Product: Portage Development Reporter: Andrei Slavoiu <ansla80>
Component: UnclassifiedAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: VERIFIED UPSTREAM    
Severity: enhancement    
Priority: High    
Version: 2.1   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Andrei Slavoiu 2006-06-13 23:48:11 UTC
>>> Emerging (17 of 40) kde-base/kdeaddons-3.5.2-r1 to /
>>> checking ebuild checksums
!!! Digest verification failed:
!!! /usr/portage/kde-base/kdeaddons/kdeaddons-3.5.3.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 940
!!! Expected: 942

I just want to emerge version 3.5.2-r1, I don't care that version 3.5.3 is broken.
Comment 1 Andrei Slavoiu 2006-06-13 23:48:59 UTC
Portage 2.1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r3, 2.6.16-gentoo-r7 i686)
=================================================================
System uname: 2.6.16-gentoo-r7 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -mfpmath=sse -pipe -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -mfpmath=sse -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms splitdebug strict"
GENTOO_MIRRORS="ftp://distfiles:distfiles@192.168.4.102 ftp://ftp.roedu.net/pub/mirrors/gentoo.org ftp://ftp.lug.ro/gentoo http://gentoo.romnet.org http://distfiles.gentoo.org"
LANG="ro_RO.UTF-8"
LC_ALL="ro_RO.UTF-8"
LDFLAGS="-Wl,-O1,--enable-new-dtags,--sort-common,-z,combreloc"
LINGUAS="ro eo"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.ro.gentoo.org/gentoo-portage"
USE="x86 7zip X a52 aac aalib accessibility acl acpi akode alsa amr apache2 apm asf audiofile avi bash-completion berkdb bitmap-fonts bzip2 bzlib caps cddb cdparanoia clamav crypt css cups curl dga doc dpms dri dv dvd dvdr dvdread eds emboss encode erandom examples exif expat fbcon ffmpeg flac foomaticdb fortran gcj gd gdbm gif glut gmp gnokii gnutls gphoto2 gpm graphviz hal idn imagemagick ipv6 isdnlog java javascript jpeg jpeg2k justify kde kdeenablefinal kdehiddenvisibility kerberos kig-scripting kipi kqemu lcms ldap libcaca libclamav libg++ libwww live lm_sensors lzo mad matroska mbrola mikmod mjpeg mmap mmx motif mp3 mp4 mpeg musepack musicbrainz mythtv ncurses network nls nodrm nowin nptl nptlonly offensive ofx ogg openal openexr opengl oss pam pcre pdf pdflib perl php physfs png postgres povray pppd python qt quicktime rdesktop readline reflection reiserfs rtc ruby samba sasl sdl session sms speex spell spl sqlite sse sse2 ssl subversion svg symlink syslog sysvipc tcpd theora threads tidy tiff truetype truetype-fonts type1-fonts udev unicode usb videos visualization voice vorbis win32codecs wmf x264 xcomposite xine xml xmlrpc xorg xv xvid xvmc zeroconf zip zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_ro linguas_eo userland_GNU video_cards_nv"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-06-14 00:26:19 UTC
That's a feature, not a bug. Either the Manifest is correct or not.
Comment 3 Andrei Slavoiu 2006-06-14 05:21:46 UTC
(In reply to comment #2)
> That's a feature, not a bug. Either the Manifest is correct or not.
In this case it is definetelly a miss-feature. So how do you suggest fixing it? Submit a GLEP for version specific manifest files?

Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-06-14 05:25:38 UTC
(In reply to comment #3)
> In this case it is definetelly a miss-feature. So how do you suggest fixing it?
> Submit a GLEP for version specific manifest files?

We won't fix it, it's not a bug so there's nothing to fix... Either the Manifest is correct, then there's no integrity breach, or it's broken, nothing between... When it comes to signing the Manifest, you only sign it as a whole, so it needs to be checked as a whole.

Thanks, closing.
Comment 5 Andrei Slavoiu 2006-06-14 06:03:49 UTC
Ok, you are right, it's not a bug so it can't be "fixed", but the situation can be improved.
Do you think a global Manifest file would be acceptable? So that you can not emerge any package if the portage tree was corrupted? Wouldn't an error that says you can't emerge sys-libs/glibc because kdeaddons is broken sound ridiculous? I think the error saying you can't emerge the stable version because of the unstable one.

BTW, I will not reopen it again if you close it this time, I just wanted to make sure you realize just how stupid this "desired" behavior is.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-06-14 06:06:49 UTC
There's gentoo-portage-dev mailing list for such discussions. [1] This is an intended behaviour, as such not a bug.

Thanks again, closing.

[1] http://www.gentoo.org/main/en/lists.xml
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-06-14 06:07:27 UTC
Closing.