Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 136243

Summary: [modular xorg] vnc-4.0-r1 fails to build at attributes.c
Product: Gentoo Linux Reporter: Nathan Sullivan <nathan>
Component: New packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED FIXED    
Severity: normal CC: askwar, fauli, omschaub, vapier, Werner.Peter
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Nathan Sullivan 2006-06-09 19:34:14 UTC
spooler.c:153: warning: string length '581' is greater than the length '509' ISO C89 compilers are required to support
spooler.c:160: warning: string length '581' is greater than the length '509' ISO C89 compilers are required to support
rm -f attributes.o
i686-pc-linux-gnu-gcc -c -O2 -march=pentium3 -pipe -ansi -pedantic -Wall -Wpointer-arith -Wundef    -fno-merge-constants -I../../../exports/include/X11 -I. -I../mfb -I../mi -I../cfb              -I../include -I../../../include -I../../../lib              -I../../../include/extensions -I../../../include/fonts -I../../../lib/X11  -I../../.. -I../../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                                -D_POSIX_SOURCE -D_XOPEN_SOURCE                                 -D_BSD_SOURCE -D_SVID_SOURCE                     -D_GNU_SOURCE                              -DSHAPE -DXINPUT -DXKB -DLBX -DXAPPGROUP       -DXCSECURITY -DTOGCUP   -DXF86BIGFONT -DDPMSExtension    -DPIXPRIV -DPANORAMIX   -DRENDER -DRANDR -DXFIXES -DDAMAGE -DCOMPOSITE -DXEVIE -DGCCUSESGAS -DAVOID_GLYPHBLT -DPIXPRIV -DSINGLEDEPTH                              -DXFreeXDGA -DXvExtension                               -DXFree86LOADER  -DXFree86Server                           -DXF86VIDMODE                           -DXvMCExtension                                 -DSMART_SCHEDULE                                -DBUILDDEBUG -DXResExtension                               -DX_BYTE_ORDER=X_LITTLE_ENDIAN                          -DXORG_VERSION_CURRENT="(((6) * 10000000) + ((8) * 100000) + ((1) * 1000) + 0)" -DNDEBUG   -DFUNCPROTO=15 -DNARROWPROTO   -DXPRINTDIR=\"/usr/lib/X11/xserver\" -DXPRASTERDDX -DXPPCLDDX -DXPMONOPCLDDX          -DXPPSDDX -DHAS_MKSTEMP -UXFree86LOADER -D_XP_PRINT_SERVER_   attributes.c
attributes.c: In function 'XpGetConfigDirBase':
attributes.c:152: warning: assignment from incompatible pointer type
attributes.c:152: warning: comparison of distinct pointer types lacks a cast
attributes.c:153: warning: assignment from incompatible pointer type
attributes.c:155: warning: return from incompatible pointer type
attributes.c: In function 'BuildPrinterAttrs':
attributes.c:327: warning: unused variable 'dirName'
attributes.c: In function 'XpGetOneAttribute':
attributes.c:627: warning: unused variable 'retVal'
attributes.c: In function 'AppendEntry':
attributes.c:819: warning: 'return' with no value, in function returning non-void
attributes.c: In function 'XpGetAttributes':
attributes.c:878: warning: unused variable 'retVal'
attributes.c: At top level:
attributes.c:1094: error: static declaration of 'ExecCommand' follows non-static declaration
attributes.h:113: error: previous declaration of 'ExecCommand' was here
attributes.c: In function 'SendFileToCommand':
attributes.c:1187: warning: implicit declaration of function 'initgroups'
attributes.c:1202: warning: unused variable 'res'
attributes.c: In function 'VectorizeCommand':
attributes.c:1440: warning: unused variable 'i'
attributes.c:1439: warning: unused variable 'curTok'
attributes.c: In function 'XpSubmitJob':
attributes.c:1466: warning: unused variable 'cmdOpt'
attributes.c: In function 'XpGetTrayMediumFromContext':
attributes.c:1590: warning: unused variable 'pLast'
attributes.c:1590: warning: unused variable 'pE'
attributes.c:1590: warning: unused variable 'pS'
attributes.c: In function 'XpSubmitJob':
attributes.c:1518: warning: control reaches end of non-void function
make[5]: *** [attributes.o] Error 1
make[5]: Leaving directory `/var/tmp/portage/vnc-4.0-r1/work/vnc-4.0-unixsrc/xc/programs/Xserver/Xprint'
make[4]: *** [Xprint] Error 2
make[4]: Leaving directory `/var/tmp/portage/vnc-4.0-r1/work/vnc-4.0-unixsrc/xc/programs/Xserver'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/vnc-4.0-r1/work/vnc-4.0-unixsrc/xc/programs'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/vnc-4.0-r1/work/vnc-4.0-unixsrc/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/var/tmp/portage/vnc-4.0-r1/work/vnc-4.0-unixsrc/xc'
make: *** [World] Error 2

!!! ERROR: net-misc/vnc-4.0-r1 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  vnc-4.0-r1.ebuild, line 88:   Called die

!!! (no error message)

more to follow...
Comment 1 Nathan Sullivan 2006-06-09 19:34:40 UTC
emerge info for the affected installation...

---------------------------------------------------------------------

Portage 2.1_rc4-r3 (default-linux/x86/2006.0, gcc-4.1.1/vanilla, glibc-2.4-r3, 2.6.16-ck11 i686)
=================================================================
System uname: 2.6.16-ck11 i686 Pentium III (Coppermine)
Gentoo Base System version 1.12.1
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r1
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks fixpackages metadata-transfer nostrip sandbox sfperms strict"
GENTOO_MIRRORS="ftp://mirror.pacific.net.au/linux/Gentoo ftp://mirror.isp.net.au/pub/gentoo/ ftp://ftp.swin.edu.au/gentoo"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-overlays/testing"
SYNC="rsync://10.100.10.1/gentoo-portage"
USE="X aac acpi aim alsa apache2 apm audiofile avi bash-completion berkdb big-tables bitmap-fonts bzip2 cairo canvas cdr cli cpdflib crypt cups curl dba debug divx4linux dlloader dri dvb dvd dvdr emboss encode ethereal exif extraengine fam ffmpeg firefox flac foomaticdb fortran gd gdbm gif gimpprint glut gmp gnutls gpm gstreamer gtk gtk2 icq idn imap imlib innodb ipv6 isdnlog jabber java jpeg kerberos lcms ldap libcaca libg++ libwww logrotate mad mhash mikmod mmx mng mono motif mozsvg mp3 mpeg mppe-mppc mysql mysqli ncurses nls nptl nptlonly nsplugin nvidia ogg opengl pam pcntl pcre pdflib pear perl php png posix pppd python quicktime readline real reflection ruby samba sdl session slang snmp soap sockets sox spell spl sqlite sse ssl svg tcpd tiff truetype truetype-fonts type1-fonts udev unicode userlocales utf8 vorbis wddx win32codecs x86 xine xinerama xml xml2 xmlrpc xorg xosd xprint xsl xv xvid yahoo zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Nathan Sullivan 2006-06-09 19:35:34 UTC
------------------------------

nsys-homedesktop1-gt nathan # genlop xorg-x11
 * x11-base/xorg-x11

     Tue May 23 22:04:43 2006 >>> x11-base/xorg-x11-7.0-r1
     Mon May 29 19:01:22 2006 >>> x11-base/xorg-x11-7.0-r1
     Wed May 31 08:18:12 2006 >>> x11-base/xorg-x11-7.0-r1
nsys-homedesktop1-gt nathan # eix xprint
* x11-libs/libXprintAppUtil 
     Available versions:  1.0.1
     Installed:           none
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org XprintAppUtil library

* x11-libs/libXprintUtil 
     Available versions:  1.0.1
     Installed:           none
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org XprintUtil library


Found 2 matches
nsys-homedesktop1-gt nathan # genlop xorg-server
 * x11-base/xorg-server

     Sun May 21 23:20:28 2006 >>> x11-base/xorg-server-1.0.2-r4
     Tue May 23 17:26:52 2006 >>> x11-base/xorg-server-1.0.2-r4
     Sat May 27 22:28:23 2006 >>> x11-base/xorg-server-1.0.2-r4
     Mon May 29 14:11:53 2006 >>> x11-base/xorg-server-1.0.2-r4
     Tue May 30 22:17:26 2006 >>> x11-base/xorg-server-1.0.2-r4
nsys-homedesktop1-gt nathan #

( not sure if the above helps :))

marked x86 to start, change if it appears on other archs...
Comment 3 Alexander Skwar 2006-06-22 02:06:24 UTC
Same here.

[11:02:37 vz6tml@dewup-ww02:~] $ emerge --info
Portage 2.1.1_pre1-r1 (default-linux/x86/2006.0, gcc-4.1.1/vanilla, glibc-2.4-r3, 2.6.15-gentoo-r3.05 i686)
=================================================================
System uname: 2.6.15-gentoo-r3.05 i686 Intel(R) Xeon(TM) CPU 2.40GHz
Gentoo Base System version 1.12.1
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r1
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -pipe"
DISTDIR="/Gentoo/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="autoconfig buildpkg ccache collision-protect distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="        http://localhost/~vz6tml/gentoo-files http://dewup-ww02.dewup.europe.delphiauto.net/~vz6tml/gentoo-files    http://localhost/gentoo-files/ http://dewup-ww02.dewup.europe.delphiauto.net/gentoo-files/      http://localhost/~vz6tml/gentoo-files/ http://cifs-srvr1.europe.delphiauto.net/~vz6tml/Misc._Software/Gentoo/       http://alexander.skwar.name/~askwar/stuff/gentoo/           http://mirrors.sec.informatik.tu-darmstadt.de:80/gentoo/        http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/        ftp://ftp.tu-clausthal.de/pub/linux/gentoo/     http://localhost:60081/pub/Mirrors/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/     http://localhost:60080/pub/gentoo/ http://pandemonium.tiscali.de/pub/gentoo/        http://localhost:60082/mirror/rsync.gentoo.org/gentoo/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://pandemonium.tiscali.de/pub/gentoo/        http://localhost:60083/pub/linux/distributions/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/    http://distro.ibiblio.org/pub/linux/distributions/gentoo/       ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/    http://localhost:60084/ http://distfiles.gentoo.org/ "
LANG="de_DE.utf8"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/Gentoo/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/Gentoo/portage/tmp"
PORTDIR="/Gentoo/portage/tree"
PORTDIR_OVERLAY="/Gentoo/portage/local-tree/misc"
SYNC="rsync://localhost:10873/gentoo-portage"
USE="x86 7zip GAPING_SECURITY_HOLE X acl apache apache2 artworkextra async avi bash-completion berkdb bitmap-fonts ccache ck-server cli crypt css cups dbus dri dvd encode exif fam fat firefox font-server foomaticdb gd gdbm gif gmail gmailtimestamps gnome gpm gs gtk gtk2 hal hfs hpn i8x0 iconv id3 imagemagick imlib imlib2 isdnlog java javascript jfs jikes jpeg kde kdeenablefinal kdehiddenvisibility lame libg++ libwww linuxthreads-tls lm_sensors lynxkeymap lzo lzw lzw-tiff mad mailbox maildir matroska mmx motif mozsvg mp3 mpeg mpm-worker msdav mysql mysqli ncurses network nfs nis nls no-old-linux no-suexec nodrm nomusic nptl nptlonly ntlm offensive ogg oggvorbis pam pcre pdflib perl php png posix postfix pppd python qt quicktime rar rdesktop readline real recode reflection reiserfs samba sapdb screen sdl sendfile session sftp smp sockets spell spl sse sse2 ssl stream subtitles symlink sysvipc tcpd tiff transcode truetype truetype-fonts udev unicode usb userlocales utf8 vhosts vim vim-pager vim-with-x vorbis webdav win32codecs xattr xfs xinetd xml xmms xorg xprint xv xvid yp zlib elibc_glibc input_devices_evdev input_devices_keyboard input_devices_mouse input_devices_vmmouse input_devices_void kernel_linux linguas_de userland_GNU video_cards_ati video_cards_vesa video_cards_vga video_cards_vmware"
Unset:  CTARGET, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 4 Christian Faulhammer (RETIRED) gentoo-dev 2006-08-18 04:53:05 UTC
Could you please try it with vnc 4.1.2?  If the error vanishes, we can one more reason for stabling that version.  I suppose this is an error produced by GCC 4.1.1, as there is one in bug #125164
Comment 5 Nathan Sullivan 2006-08-18 22:14:56 UTC
4.1.2 seems good on x86 here, built with USE=server, but havent tested starting X with the server module loaded just yet... client works fine so far...
Comment 6 SpanKY gentoo-dev 2006-08-28 00:56:18 UTC
4.1.2 resolves things
Comment 7 P├ęter Werner 2006-09-02 23:44:20 UTC
See bug 146092 as poor man's reopen.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-09-03 00:33:43 UTC
*** Bug 146092 has been marked as a duplicate of this bug. ***