Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 135537

Summary: app-crypt/hashalot-0.3-r2 emerge failed w/ FEATURES="confcache"
Product: Gentoo Linux Reporter: Matteo Spreafico <matteo>
Component: Current packagesAssignee: Diego Elio Pettenò (RETIRED) <flameeyes>
Severity: normal CC: ferringb
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: config.log
emerge --info
genlop -l

Description Matteo Spreafico 2006-06-04 09:55:29 UTC
>>> Emerging (1 of 2) app-crypt/hashalot-0.3-r2 to /
>>> checking ebuild checksums ;-)
>>> checking auxfile checksums ;-)
>>> checking miscfile checksums ;-)
>>> checking hashalot-0.3.tar.gz ;-)
>>> Unpacking source...
>>> Unpacking hashalot-0.3.tar.gz to /var/tmp/portage/hashalot-0.3-r2/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/hashalot-0.3-r2/work/hashalot-0.3 ...
/usr/bin/confcache --confcache-ignore /var/tmp/ccache:/var/tmp/.distcc --confcache-dir /var/tmp/confcache ./configure --prefix=/usr --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --build=x86_64-pc-linux-gnu
configure: loading cache config.cache
checking for a BSD-compatible install... (cached) /bin/install -c
checking whether build environment is sane... yes
checking for gawk... (cached) gawk
checking whether make sets $(MAKE)... (cached) yes
checking for a BSD-compatible install... /bin/install -c
checking for x86_64-pc-linux-gnu-gcc... (cached) x86_64-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... (cached) o
checking whether we are using the GNU C compiler... (cached) yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... (cached) yes
checking for x86_64-pc-linux-gnu-gcc option to accept ANSI C... (cached) none needed
checking for style of include used by make... GNU
checking dependency style of x86_64-pc-linux-gnu-gcc... (cached) none
checking whether ln -s works... yes
checking how to run the C preprocessor... (cached) x86_64-pc-linux-gnu-gcc -E
checking for egrep... (cached) grep -E
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking libgen.h usability... yes
checking libgen.h presence... yes
checking for libgen.h... yes
checking for stdio.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for unistd.h... (cached) yes
checking assert.h usability... yes
checking assert.h presence... yes
checking for assert.h... yes
checking for sys/types.h... (cached) yes
checking for sys/mman.h... (cached) yes
checking endian.h usability... yes
checking endian.h presence... yes
checking for endian.h... yes
checking for getopt... (cached) no
configure: error: required function not found

!!! Please attach the following file when filing a report to
!!! /var/tmp/portage/hashalot-0.3-r2/work/hashalot-0.3/config.log

!!! ERROR: app-crypt/hashalot-0.3-r2 failed.
Call stack:, line 1539:   Called dyn_compile, line 939:   Called src_compile, line 606:   Called econf, line 541:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 1 Matteo Spreafico 2006-06-04 09:56:04 UTC
Created attachment 88358 [details]
Comment 2 Matteo Spreafico 2006-06-04 09:56:57 UTC
Created attachment 88359 [details]
emerge --info
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-06-04 12:10:22 UTC
Can you try w/ FEATURES="-confcache"?
Comment 4 Matteo Spreafico 2006-06-04 12:42:16 UTC
Now it works, thanks

How can I clean my confcache?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-06-04 12:46:06 UTC
(In reply to comment #4)
> Now it works, thanks
> How can I clean my confcache?

Won't help most likely. See Bug 134454, Comment #0 for information about what we need to fix this bug. Attach it here and reopen then.
Comment 6 Matteo Spreafico 2006-06-04 12:50:59 UTC
Created attachment 88374 [details]
Comment 7 Matteo Spreafico 2006-06-04 12:56:12 UTC
Created attachment 88375 [details]
genlop -l
Comment 8 Matteo Spreafico 2006-06-04 12:56:58 UTC
information attached. reopening
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-06-29 11:37:53 UTC
I'm closing them as UPSTREAM as for now I can't do much until Brian provides me a new version of confcache that allows to trace who poisoned the cache.
This is also the main reason why confcache is masked right now.