Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 1343

Summary: Later decisions need to be able to adjust earlier ones during graph building
Product: Portage Development Reporter: Dan Armak (RETIRED) <danarmak>
Component: UnclassifiedAssignee: Portage team <dev-portage>
Status: RESOLVED DUPLICATE    
Severity: normal CC: alonbl, ansla80, antarus, askwar, ben.tucker, betelgeuse, carlo, carpaski, clmason, csights, daevid, dberkholz, dev, douglas.pollock, drobbins, el.vooft, emilio_estevez_2, esigra, farcaller, flash3001, fordfrog, gentoo-bugs, gentoobugs, griffon26, hramrach, hsggebhardt, iyosifov, jusic, khoganson, Klaus.Kusche, m.debruijne, marchelly, maris.gis, mark, martinoc, matlerouge, matt+bugzilla, Max, max, menaheme, michaeljshannon, mmokrejs, mschiff, niogic, nix, pacho, philsexton, qbit, sascha-gentoo-bugzilla, seemantk, siegerstein, StormByte, sveinung, swtaylor, tester, throw_away_2002, tr.bgo, utx, vhata-gentoo, victor.bucutea, vitaly, yoshi3, zlin, zzam
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 155723, 300071, 136087, 260225, 260353, 264434    

Description Dan Armak (RETIRED) gentoo-dev 2002-03-25 12:30:09 UTC
If I run "emerge a-1 b", and b has a dep of >=a-1, but in portage there are 
both a-1 and a-2, then: 
 
IMO what should happen is that since a-1 satisifies b's dep, and I emerge it 
anyway, only these 2 packages should be emerged. 
 
But what actually happens is that both b, a-1 and a-2 are emerged. In other 
words a package explicitly specified for emerging isn't allowed to specify 
deps in the same emerge run. 
 
Real life example: I need this to work the way I described because I'm dealing 
with two sets of KDE3 ebuilds: 3.0 (current cvs) and 3.0_rc3 (last tagged 
release). When I want to emerge the RC3 set of ebuilds, I emerge =kde-3.0_rc3 
which depends on ~{kdelibs,kdebase,...}-${PV}. However I get both 
kdelibs-3.0_rc3, kdelibs-3.0 and kdebase-3.0, with the two kdelibs overwriting 
one another.
Comment 1 Daniel Robbins (RETIRED) gentoo-dev 2002-04-29 10:31:20 UTC
*** Bug 2231 has been marked as a duplicate of this bug. ***
Comment 2 SpanKY gentoo-dev 2002-11-18 11:14:42 UTC
*** Bug 10909 has been marked as a duplicate of this bug. ***
Comment 3 SpanKY gentoo-dev 2003-09-25 23:39:57 UTC
*** Bug 29635 has been marked as a duplicate of this bug. ***
Comment 4 Marius Mauch (RETIRED) gentoo-dev 2003-11-26 16:22:40 UTC
*** Bug 27763 has been marked as a duplicate of this bug. ***
Comment 5 SpanKY gentoo-dev 2004-03-24 20:22:24 UTC
*** Bug 45493 has been marked as a duplicate of this bug. ***
Comment 6 Marius Mauch (RETIRED) gentoo-dev 2004-04-01 01:24:05 UTC
*** Bug 25224 has been marked as a duplicate of this bug. ***
Comment 7 Donnie Berkholz (RETIRED) gentoo-dev 2004-04-18 22:12:06 UTC
This is preventing me from unmasking xfree-4.3.0-r6 without some extreme hackery involving dependency checks in the pkg_setup() of xterm. It would be nice if someone could take a look at it.
Comment 8 Bernd Pachur 2004-04-26 03:34:29 UTC
This bug can even lead to the parallel installation of blocking packages.
At least I think it can, because "emerge package -pv" states that two mutually blocking packages will be installed. I never did this without "-p".

Here is my example:

emerge xorg-x11 -pv (with USE including Xaw3d)

states that it will first emerge xorg-x11 and then xfree and some other packages including Xaw3d.

When I mask xfree in /etc/portage/package.mask portage complains that there is no ebuild that can satisfy xfree as dependancy of Xaw3d, but Xaw3d does not depend directly on xfree but on virtual/x11. It seems that portage does not recognize xorg as provider of virtual/x11 in this scenario.

For testing purposes I edited /etc/make.profile/virtuals and changed virtual/x11 from x11-base/xfree to x11-base/xorg-x11. After this the problem no longer exists and portage recognizes that xorg-x11 will be installed and is satisfied with it.

Another sceanrio I tested was not to change /etc/make.profile/virtuals but first do

emerge --nodeps xorg-x11

(I checked that all dependecies that have to be installed before xorg-x11 where installed.)

and then emerge Xaw3d. In this scenario protage recognizes that virtual/x11 is already provided by xorg-x11 and doesn't want to emerge xfree.

P.S.: I hope that this is really related to this bug and not a new bug.
Comment 9 Jason Stubbs (RETIRED) gentoo-dev 2004-06-21 02:50:31 UTC
In CVS. Will be included by 2.0.51.
Comment 10 Jason Stubbs (RETIRED) gentoo-dev 2004-07-08 00:31:58 UTC
*** Bug 56318 has been marked as a duplicate of this bug. ***
Comment 11 Marius Mauch (RETIRED) gentoo-dev 2004-08-09 14:49:23 UTC
Doesn't work for me, try `emerge -pv virtuaL/php dev-php/php`, it wants to install mod_php because it doesn't recognize the PROVIDE from dev-php/php.
Comment 12 SpanKY gentoo-dev 2004-08-09 14:53:09 UTC
no, mod_php depends on php now
Comment 13 Michal Suchanek 2004-08-09 15:32:56 UTC
*** Bug 58569 has been marked as a duplicate of this bug. ***
Comment 14 Marius Mauch (RETIRED) gentoo-dev 2004-08-09 15:45:39 UTC
read again
Comment 15 SpanKY gentoo-dev 2004-08-09 17:23:38 UTC
ah i see ... you're right, i missed, sorry about that
Comment 16 Jason Stubbs (RETIRED) gentoo-dev 2004-10-04 07:28:00 UTC
It's only half fixed. To use the initial example, assuming nothing is installed:
"emerge =apache-1* php" won't install apache-2
"emerge php =apache-1*" will install apache-2
Comment 17 Marius Mauch (RETIRED) gentoo-dev 2004-11-21 00:25:04 UTC
*** Bug 71885 has been marked as a duplicate of this bug. ***
Comment 18 Martin OConnor 2004-12-30 19:12:32 UTC
*** Bug 76197 has been marked as a duplicate of this bug. ***
Comment 19 Martin OConnor 2005-01-02 15:35:57 UTC
*** Bug 76197 has been marked as a duplicate of this bug. ***
Comment 20 Marius Mauch (RETIRED) gentoo-dev 2005-02-18 11:56:20 UTC
*** Bug 82488 has been marked as a duplicate of this bug. ***
Comment 21 Marius Mauch (RETIRED) gentoo-dev 2005-02-18 11:57:50 UTC
new problem with conditional PROVIDEs, see bug 82488
Comment 22 Jason Stubbs (RETIRED) gentoo-dev 2005-04-19 21:06:55 UTC
*** Bug 89730 has been marked as a duplicate of this bug. ***
Comment 23 Marius Mauch (RETIRED) gentoo-dev 2005-07-04 11:54:06 UTC
*** Bug 97893 has been marked as a duplicate of this bug. ***
Comment 24 Jakub Moc (RETIRED) gentoo-dev 2005-07-14 03:25:12 UTC
*** Bug 98981 has been marked as a duplicate of this bug. ***
Comment 25 Jason Stubbs (RETIRED) gentoo-dev 2005-10-07 03:09:25 UTC
*** Bug 23018 has been marked as a duplicate of this bug. ***
Comment 26 Jason Stubbs (RETIRED) gentoo-dev 2005-10-07 07:26:39 UTC
*** Bug 13632 has been marked as a duplicate of this bug. ***
Comment 27 Jason Stubbs (RETIRED) gentoo-dev 2005-10-07 08:19:06 UTC
*** Bug 33545 has been marked as a duplicate of this bug. ***
Comment 28 Jason Stubbs (RETIRED) gentoo-dev 2005-10-07 09:21:15 UTC
*** Bug 51411 has been marked as a duplicate of this bug. ***
Comment 29 Petteri Räty (RETIRED) gentoo-dev 2005-11-01 13:27:44 UTC
*** Bug 111182 has been marked as a duplicate of this bug. ***
Comment 30 Petteri Räty (RETIRED) gentoo-dev 2005-11-01 13:29:45 UTC
Using the latest ~x86 portage (sys-apps/portage-2.0.53_rc7)

pena tomcat # emerge -pvt kaffe

These are the packages that I would merge, in reverse order:

Calculating dependencies ...done!
[ebuild  N    ] dev-java/gjdoc-0.7.6  0 kB [2]
[ebuild  N    ]  dev-java/blackdown-jdk-1.4.2.02-r1  -doc +nsplugin 0 kB [2]
[ebuild  N    ] dev-java/kaffe-1.1.6-r2  +alsa +esd -gmp -gtk -nls 0 kB [2]

Kaffe does provide virtual/jre but the PDEPEND on gjdoc makes it pull the
default provider too. It would be great to have some resolution to this to for
example 2.0.54. Maybe this should be added to the list of targeted things.
Comment 31 Jakub Moc (RETIRED) gentoo-dev 2006-01-03 03:19:17 UTC
*** Bug 117564 has been marked as a duplicate of this bug. ***
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2006-03-08 08:28:49 UTC
*** Bug 125486 has been marked as a duplicate of this bug. ***
Comment 33 Jakub Moc (RETIRED) gentoo-dev 2006-06-04 11:50:09 UTC
*** Bug 135546 has been marked as a duplicate of this bug. ***
Comment 34 Jakub Moc (RETIRED) gentoo-dev 2006-06-04 12:22:52 UTC
*** Bug 135546 has been marked as a duplicate of this bug. ***
Comment 35 Jakub Moc (RETIRED) gentoo-dev 2006-06-26 10:43:37 UTC
*** Bug 138078 has been marked as a duplicate of this bug. ***
Comment 36 Simon Stelling (RETIRED) gentoo-dev 2006-07-18 10:28:17 UTC
*** Bug 140010 has been marked as a duplicate of this bug. ***
Comment 37 Jakub Moc (RETIRED) gentoo-dev 2006-08-10 08:30:14 UTC
*** Bug 143469 has been marked as a duplicate of this bug. ***
Comment 38 Zac Medico gentoo-dev 2006-10-01 12:01:52 UTC
*** Bug 149654 has been marked as a duplicate of this bug. ***
Comment 39 Nix N. Nix 2006-10-01 14:45:06 UTC
Re: bug #149654

ekiga doesn't really depend on dev-libs/pwlib-1.10.1, because it works just fine with dev-libs/pwlib-1.10.2, at least for me.

Perhaps we should mark ekiga as depending on >=dev-libs/pwlib-1.10.1 just as
opal does, and see if it causes any kind of havoc.
Comment 40 Zac Medico gentoo-dev 2006-10-23 18:20:59 UTC
*** Bug 152612 has been marked as a duplicate of this bug. ***
Comment 41 Jakub Moc (RETIRED) gentoo-dev 2006-11-08 22:42:31 UTC
*** Bug 154531 has been marked as a duplicate of this bug. ***
Comment 42 Jakub Moc (RETIRED) gentoo-dev 2006-12-06 11:56:03 UTC
*** Bug 157361 has been marked as a duplicate of this bug. ***
Comment 43 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2006-12-10 19:30:24 UTC
Adding bug 157201 as another bug caused by this, with hal, dbus and dbus-glib during the upgrade to dbus-1.0.1*.
Comment 44 Jakub Moc (RETIRED) gentoo-dev 2006-12-14 14:19:20 UTC
*** Bug 157201 has been marked as a duplicate of this bug. ***
Comment 45 Jakub Moc (RETIRED) gentoo-dev 2006-12-21 13:00:03 UTC
*** Bug 158741 has been marked as a duplicate of this bug. ***
Comment 46 Maurice van der Pot (RETIRED) gentoo-dev 2006-12-23 02:14:34 UTC
*** Bug 158634 has been marked as a duplicate of this bug. ***
Comment 47 Jakub Moc (RETIRED) gentoo-dev 2006-12-25 01:20:14 UTC
*** Bug 159044 has been marked as a duplicate of this bug. ***
Comment 48 Jakub Moc (RETIRED) gentoo-dev 2007-01-22 23:39:36 UTC
*** Bug 163368 has been marked as a duplicate of this bug. ***
Comment 49 Jakub Moc (RETIRED) gentoo-dev 2007-02-07 08:11:36 UTC
*** Bug 165709 has been marked as a duplicate of this bug. ***
Comment 50 Jakub Moc (RETIRED) gentoo-dev 2007-02-07 21:18:09 UTC
*** Bug 165709 has been marked as a duplicate of this bug. ***
Comment 51 Jakub Moc (RETIRED) gentoo-dev 2007-02-13 09:00:11 UTC
*** Bug 166609 has been marked as a duplicate of this bug. ***
Comment 52 Jakub Moc (RETIRED) gentoo-dev 2007-02-14 12:00:51 UTC
*** Bug 166812 has been marked as a duplicate of this bug. ***
Comment 53 Jakub Moc (RETIRED) gentoo-dev 2007-03-10 16:02:20 UTC
*** Bug 170263 has been marked as a duplicate of this bug. ***
Comment 54 Zac Medico gentoo-dev 2007-03-22 01:28:54 UTC
*** Bug 171720 has been marked as a duplicate of this bug. ***
Comment 55 Jakub Moc (RETIRED) gentoo-dev 2007-04-07 14:00:32 UTC
*** Bug 173668 has been marked as a duplicate of this bug. ***
Comment 56 Jakub Moc (RETIRED) gentoo-dev 2007-05-18 16:27:39 UTC
*** Bug 179020 has been marked as a duplicate of this bug. ***
Comment 57 Zac Medico gentoo-dev 2007-05-30 21:43:50 UTC
*** Bug 180355 has been marked as a duplicate of this bug. ***
Comment 58 Zac Medico gentoo-dev 2007-08-10 19:17:12 UTC
*** Bug 188079 has been marked as a duplicate of this bug. ***
Comment 59 Jakub Moc (RETIRED) gentoo-dev 2007-11-01 15:21:18 UTC
*** Bug 197783 has been marked as a duplicate of this bug. ***
Comment 60 Jakub Moc (RETIRED) gentoo-dev 2007-11-07 14:24:07 UTC
*** Bug 198358 has been marked as a duplicate of this bug. ***
Comment 61 Zac Medico gentoo-dev 2007-11-08 08:09:17 UTC
*** Bug 198432 has been marked as a duplicate of this bug. ***
Comment 62 Jakub Moc (RETIRED) gentoo-dev 2007-11-15 12:00:06 UTC
*** Bug 199228 has been marked as a duplicate of this bug. ***
Comment 63 Jakub Moc (RETIRED) gentoo-dev 2007-11-15 12:15:39 UTC
*** Bug 199228 has been marked as a duplicate of this bug. ***
Comment 64 Jakub Moc (RETIRED) gentoo-dev 2007-11-15 12:32:19 UTC
*** Bug 199228 has been marked as a duplicate of this bug. ***
Comment 65 Jakub Moc (RETIRED) gentoo-dev 2007-11-21 19:39:39 UTC
*** Bug 199913 has been marked as a duplicate of this bug. ***
Comment 66 Jakub Moc (RETIRED) gentoo-dev 2007-12-05 22:06:17 UTC
*** Bug 199913 has been marked as a duplicate of this bug. ***
Comment 67 Jakub Moc (RETIRED) gentoo-dev 2007-12-27 12:00:28 UTC
*** Bug 203448 has been marked as a duplicate of this bug. ***
Comment 68 Jakub Moc (RETIRED) gentoo-dev 2008-01-28 00:02:40 UTC
*** Bug 207805 has been marked as a duplicate of this bug. ***
Comment 69 Zac Medico gentoo-dev 2008-03-26 05:00:47 UTC
*** Bug 190860 has been marked as a duplicate of this bug. ***
Comment 70 Ingmar Vanhassel (RETIRED) gentoo-dev 2008-04-26 17:03:09 UTC
*** Bug 219356 has been marked as a duplicate of this bug. ***
Comment 71 manju 2008-05-06 19:37:15 UTC
aiurjqhgqjhjhqgrqjhgjqgjqh
Comment 72 Zac Medico gentoo-dev 2008-07-19 23:21:07 UTC
*** Bug 232246 has been marked as a duplicate of this bug. ***
Comment 73 Zac Medico gentoo-dev 2008-07-20 22:44:53 UTC
*** Bug 232290 has been marked as a duplicate of this bug. ***
Comment 74 Carsten Lohrke (RETIRED) gentoo-dev 2008-07-25 19:38:35 UTC
*** Bug 232957 has been marked as a duplicate of this bug. ***
Comment 75 Torsten Veller (RETIRED) gentoo-dev 2008-10-25 07:49:34 UTC
*** Bug 244188 has been marked as a duplicate of this bug. ***
Comment 76 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-12 09:48:41 UTC
*** Bug 269519 has been marked as a duplicate of this bug. ***
Comment 77 menaheme 2009-05-31 18:03:36 UTC
(In reply to comment #76)
> *** Bug 269519 has been marked as a duplicate of this bug. ***
>

I got here from dup bug 269519, 
while updating world i get:

[blocks B     ] net-wireless/bluez-libs ("net-wireless/bluez-libs" is blocking net-wireless/bluez-4.39)
[blocks B     ] net-wireless/bluez ("net-wireless/bluez" is blocking net-wireless/bluez-libs-3.36)

Total: 37 packages (28 upgrades, 6 new, 3 in new slots, 2 uninstalls), Size of downloads: 87,273 kB
Conflict: 4 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'net-wireless/bluez-4.39', 'nomerge') pulled in by
    net-wireless/bluez required by ('installed', '/', 'app-laptop/laptop-mode-tools-1.47-r1', 'nomerge')
    net-wireless/bluez required by ('ebuild', '/', 'dev-python/pybluez-0.16', 'merge')
    net-wireless/bluez required by ('installed', '/', 'net-wireless/kdebluetooth-1.0_beta8-r2', 'nomerge')
    (and 2 more)

  ('ebuild', '/', 'net-wireless/bluez-libs-3.36', 'merge') pulled in by
    >=net-wireless/bluez-libs-3.12 required by ('installed', '/', 'gnome-base/gvfs-1.0.3-r2', 'nomerge')
    net-wireless/bluez-libs required by ('installed', '/', 'app-mobilephone/obexftp-0.22', 'nomerge')

tried to oneshot bluz, but no go. 

can anyone point me in the right direction?
Thanks,

Memahem
Comment 78 Zac Medico gentoo-dev 2009-05-31 23:55:18 UTC
(In reply to comment #77)
>   ('ebuild', '/', 'net-wireless/bluez-libs-3.36', 'merge') pulled in by
>     >=net-wireless/bluez-libs-3.12 required by ('installed', '/',
> 'gnome-base/gvfs-1.0.3-r2', 'nomerge')
>     net-wireless/bluez-libs required by ('installed', '/',
> 'app-mobilephone/obexftp-0.22', 'nomerge')

It may be that the dependencies of gvfs-1.0.3-r2 or obexftp-0.22 need to be updated in order to pull in bluez instead of bluez-libs. If that's not the case, then try masking net-wireless/bluez-libs in /etc/portage/package.mask.
Comment 79 menaheme 2009-06-01 17:47:06 UTC
(In reply to comment #78)

Indeed updating the pakcages helped. i needed to unmask a bunch of packages 
(see below), but i can now complete the world update. 

Thanks Zac!

Menahem
     Mon Jun  1 20:22:55 2009 >>> app-text/build-docbook-catalog-1.4
     Mon Jun  1 20:22:55 2009 >>> app-text/sgml-common-0.6.3-r5
     Mon Jun  1 20:26:17 2009 >>> dev-libs/glib-2.20.2
     Mon Jun  1 20:26:34 2009 >>> app-pda/synce-libsynce-0.13
     Mon Jun  1 20:26:46 2009 >>> app-text/docbook-xsl-stylesheets-1.73.2
     Mon Jun  1 20:27:21 2009 >>> net-libs/libproxy-0.2.3
     Mon Jun  1 20:27:24 2009 >>> app-text/scrollkeeper-dtd-1.0
     Mon Jun  1 20:27:49 2009 >>> app-text/rarian-0.8.1
     Mon Jun  1 20:29:53 2009 >>> app-text/opensp-1.5.2-r1
     Mon Jun  1 20:30:30 2009 >>> app-pda/synce-librapi2-0.13.1
     Mon Jun  1 20:31:13 2009 >>> net-libs/libsoup-2.26.2
     Mon Jun  1 20:33:03 2009 >>> app-text/openjade-1.3.2-r1
     Mon Jun  1 20:33:09 2009 >>> app-text/docbook-sgml-dtd-3.0-r3
     Mon Jun  1 20:33:13 2009 >>> app-text/scrollkeeper-9999-r1
     Mon Jun  1 20:33:19 2009 >>> app-text/docbook-dsssl-stylesheets-1.79
     Mon Jun  1 20:33:26 2009 >>> app-text/docbook-xml-dtd-4.1.2-r6
     Mon Jun  1 20:33:41 2009 >>> dev-util/gtk-doc-1.10-r2
     Mon Jun  1 20:35:08 2009 >>> gnome-base/gvfs-1.2.3
     Mon Jun  1 20:35:37 2009 >>> app-pda/synce-gvfs-0.2.1
     Mon Jun  1 20:38:55 2009 >>> app-mobilephone/obexftp-0.23
Comment 80 Sebastian Luther (few) 2009-06-27 20:29:35 UTC
*** Bug 266775 has been marked as a duplicate of this bug. ***
Comment 81 Thomas Sachau gentoo-dev 2010-09-19 21:25:10 UTC
*** Bug 337178 has been marked as a duplicate of this bug. ***
Comment 82 Zac Medico gentoo-dev 2011-09-20 17:38:50 UTC

*** This bug has been marked as a duplicate of bug 300071 ***