Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 134227

Summary: mozilla-thunderbird 1.5.0.2-r1 fails (assertion failure)
Product: Gentoo Linux Reporter: Guillaume Ramelet <guillaume.ramelet>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: 2006.0   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Guillaume Ramelet 2006-05-24 09:18:31 UTC
Portage 2.1_rc2-r2 (default-linux/x86/2006.0, gcc-3.4.5, glibc-2.3.6-r3, 2.6.16-gentoo-r7 i686)
=================================================================
System uname: 2.6.16-gentoo-r7 i686 AMD Athlon(TM) MP 2400+
Gentoo Base System version 1.6.14
dev-lang/python:     2.3.5-r2, 2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i386-pc-linux-gnu"
CFLAGS="-march=athlon-mp -O2 -pipe"
CHOST="i386-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-mp -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/xgl-coffee"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex 3dnowext X a52 aac acpi alsa apache2 apm arts artswrappersuid asf avi bash-completion berkdb bigger-fonts bindist bitmap-fonts bonobo bootsplash browserplugin bzip2 cairo cdparanoia cdr chroot cli crypt cups curl dga directfb divx4linux dri dv dvb dvd dvdr dvdread eds emboss encode esd evo fam fbcon ffmpeg foomaticdb fortran gdbm ggi gif glitz gnome gphoto2 gpm gstreamer gtk gtk2 hal imap imlib isdnlog jack java jikes jpeg kde kdeenablefinal kdexdeltas kipi libg++ libwww lm_sensors logitech-mouse mad mikmod mmx mmxext mono motif mp3 mpeg nas ncurses nls nptl nvidia ogg oggvorbis opengl oss pam pcre pdflib perl png pppd python qt quicktime readline real reflection ruby samba sdl session slp sndfile spell spl sse ssl svg svga tcltk tcpd theora tiff truetype truetype-fonts type1-fonts udev unicode usb vorbis win32codecs x86 xml xml2 xmms xorg xosd xv xvid zlib elibc_glibc input_devices_keyboard input_devices_evdev input_devices_mouse kernel_linux linguas_fr userland_GNU video_cards_nvidia video_cards_nv"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Guillaume Ramelet 2006-05-24 09:20:14 UTC
when I get mail (from my gmail account I guess) since yesterday, thunderbird crashes with the following console message :

Assertion failure: tm.tm_month > -1 && tm.tm_mday > 0 && tm.tm_hour > -1 && tm.tm_min > -1 && tm.tm_sec > -1, at ../../../../mozilla/nsprpub/pr/src/misc/prtime.c:1558
/usr/libexec/mozilla-launcher: line 117: 25376 Aborted                 "$mozbin" "$@"
thunderbird-bin exited with non-zero status (134)


I guess one of my email (possibly spam) is wrongly formated but it shouldn't crash the reader ;)
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-05-24 09:48:19 UTC

*** This bug has been marked as a duplicate of 119677 ***