Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 132635

Summary: app-i18n/canna-3.7_p2 fails if doc use-flag is given
Product: Gentoo Linux Reporter: Mark Purtill <gentoo>
Component: New packagesAssignee: CJK Team <cjk>
Status: VERIFIED WORKSFORME    
Severity: normal CC: hiyuh.root
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Mark Purtill 2006-05-07 18:00:46 UTC
% USE=doc emerge canna
...
dvipdfmx canna.dvi
canna.dvi -> canna.pdf
[1][2
** ERROR ** Could not find encoding file "H".

Output file removed.
make: *** [canna.pdf] Error 1

!!! ERROR: app-i18n/canna-3.7_p2 failed.
Call stack:
  ebuild.sh, line 1525:   Called dyn_compile
  ebuild.sh, line 928:   Called src_compile
  canna-3.7_p2.ebuild, line 63:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.

% emerge --info
Portage 2.1_pre10-r3 (default-linux/x86/2005.0, gcc-3.3.6, glibc-2.3.6-r4, 2.6.16-gentoo-r6 i686)
=================================================================
System uname: 2.6.16-gentoo-r6 i686 AMD Athlon(tm) XP 1900+
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-g -O2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-g -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks fixpackages metadata-transfer nostrip sandbox sfperms strict userpriv"
GENTOO_MIRRORS="http://mymirror.asiaosc.org/gentoo/ ftp://213.186.33.38/gentoo-distfiles/ ftp://ftp.sh.cvut.cz/MIRRORS/gentoo/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://mirror.pacific.net.au/linux/Gentoo ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://gentoo.osuosl.org/ "
LINGUAS="en ja"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=300"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 3dnow X Xaw3d aac aalib alsa apm arts avi berkdb bindist bitmap-fonts bzip2 canna cdr cjk cli crypt cups debug doc dri dvd eds emboss encode esd foomaticdb fortran freetype freewnn gdbm gif gnome gpm gstreamer gtk gtk2 imlib ipv6 isdnlog java joystick jpeg kde kdexdeltas libg++ libwww lm_sensors mad maildir mbox mikmod mng mozsvg mp3 mpeg mule ncurses nls noantlr nobcel nobeanutils nobsh nocommonslogging nocommonsnet nodrm nojdepend nojsch nojython nolog4j nooro noregexp norhino noxalan noxerces ogg oggvorbis opengl oss pam pcre pdflib perl pic png pppd python qt quicktime readline reflection ruby scanner sdl session spell spl sse ssl tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts unicode usb vorbis wmf xine xinerama xml2 xmms xorg xv zlib elibc_glibc kernel_linux linguas_en linguas_ja userland_GNU video_cards_matrox"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, MAKEOPTS
Comment 1 Jeff 2006-05-17 09:04:26 UTC
Same thing here. Any idear what's going on here?

:-\
Comment 2 hiyuh 2006-06-25 22:50:43 UTC
canna has bit old stuff, IMHO.
you cann't mind to use others like scim or uim?
Comment 3 Mamoru KOMACHI (RETIRED) gentoo-dev 2006-06-26 05:07:51 UTC
Canna is in different layer from input methods like UIM and SCIM (for instance, you can use uim-canna to use canna from UIM or scim-canna from SCIM)

Original problem comes from malconfiguration in pTeX, and is probably resolved by re-merging dvipdfmx and/or ptex.
Comment 4 hiyuh 2006-06-26 05:48:00 UTC
(In reply to comment #3)
[SNIP]
> Original problem comes from malconfiguration in pTeX, and is probably resolved
> by re-merging dvipdfmx and/or ptex.
Ugh, sorry for my misdirection. :(
Comment 5 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-10-21 02:45:29 UTC
Cannot reproduce. As Hiyuh suggested, please make sure your ptex is configured correctly.
Comment 6 Mark Purtill 2006-10-21 12:16:45 UTC
I completely unemerged everything tex related, and then deleted /usr/share/texmf.  After that, re-emerging canna with the doc flag worked fine.  Thanks!