Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 130744

Summary: error compiling php-5.1.2
Product: Gentoo Linux Reporter: David Grant <davidgrant>
Component: New packagesAssignee: PHP Bugs <php-bugs>
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description David Grant 2006-04-21 08:53:18 UTC
/bin/sh /tmp/portage/php-5.1.2/work/php-5.1.2/libtool --silent --preserve-dup-deps --mode=compile /tmp/portage/php-5.1.2/work/php-5.1.2/meta_ccld  -Iext/pspell/ -I/tmp/portage/php-5.1.2/work/php-5.1.2/ext/pspell/ -DPHP_ATOM_INC -I/tmp/portage/php-5.1.2/work/php-5.1.2/include -I/tmp/portage/php-5.1.2/work/php-5.1.2/main -I/tmp/portage/php-5.1.2/work/php-5.1.2 -I/usr/include/libxml2 -I/tmp/portage/php-5.1.2/work/php-5.1.2/ext/date/lib -I/usr/include/freetype2 -I/usr/include/imap -I/usr/include/mysql -I/usr/include/postgresql/pgsql -I/usr/include/pspell -I/tmp/portage/php-5.1.2/work/php-5.1.2/TSRM -I/tmp/portage/php-5.1.2/work/php-5.1.2/Zend  -D_REENTRANT  -I/usr/include -march=athlon-xp -O2 -pipe -fomit-frame-pointer -pthread -DZTS  -prefer-pic -c /tmp/portage/php-5.1.2/work/php-5.1.2/ext/pspell/pspell.c -o ext/pspell/pspell.lo
/tmp/portage/php-5.1.2/work/php-5.1.2/ext/pgsql/pgsql.c: In function `php_pgsql_get_link_info':
/tmp/portage/php-5.1.2/work/php-5.1.2/ext/pgsql/pgsql.c:938: error: `PG_VERSION' undeclared (first use in this function)
/tmp/portage/php-5.1.2/work/php-5.1.2/ext/pgsql/pgsql.c:938: error: (Each undeclared identifier is reported only once
/tmp/portage/php-5.1.2/work/php-5.1.2/ext/pgsql/pgsql.c:938: error: for each function it appears in.)

sonata david # emerge info
Portage 2.0.54 (default-linux/x86/2005.0, gcc-3.4.5, glibc-2.3.5-r3, 2.6.15-gentoo-r1 i686)
System uname: 2.6.15-gentoo-r1 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.6.14
ccache version 2.3 [enabled]
dev-lang/python:     2.1.3-r1, 2.2.3-r6, 2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
USE="x86 3dnow 3dnowext 3ds X Xaw3d aac aalib acpi ada alsa anthy apache2 apm artworkextra asf async atlas audiofile avi bash-completion berkdb bigger-fonts bitmap-fonts bonobo browserplugin bzip2 c++ cairo canvas cdparanoia cdr cgi cli cpudetection crypt cscope css ctype cups curl dba dbus dga dhcp directfb divx4linux dri dv dvd dvdr dvdread dynagraph eds emacs emboss encode escreen exif expat fam fame fastbuild fastcgi fbcon ffmpeg fftw firefox flac foomaticdb force-cgi-redirect fortran ftp gd gdbm geoip gif gimp gimpprint ginac glut gmp gnome gnuplot gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile hal hddtemp iconv icq idn imagemagick imap imlib imlib2 ipv6 isdnlog java javascript jce joystick jpeg jpeg2k junit kde kdeenablefinal kdexdeltas kerberos krb4 latex lcms ldap lesstif libcaca libclamav libg++ libwww live lm_sensors logrotate lua lzo mad maildir matroska memlimit mhash migemo mikmod mjpeg mmx mmxext mng mono motif mozdevelop mozilla mozsvg mp3 mpeg mpi mplayer mppe-mppc msn musepack musicbrainz mysql nas nautilus ncurses net nethack network nfs nis nls nntp no-old-linux noplugin nptl nptlonly nsplugin nvidia oav odbc offensive ofx ogg oggvorbis openal opengl oscar oss pam pcre pda pdf pdflib pdo-external perl php pic plotutils png posix postgres povray ppds pppd python qhull qt quicktime quotas quotes readline real reflection ruby samba sasl scanner screen sdl sensord server session simplexml slang smtp soap sockets spell spl sqlite sse ssl subversion svg svga symlink tcltk tcpd tetex theora threads tidy tiff tokenizer truetype truetype-fonts type1 type1-fonts udev usb userlocales utf8 v4l v4l2 vcd vhosts virus-scan visualization vorbis webservices wifi win32codecs wmf wv wxwindows xanim xbase xine xml xml2 xmlwriter xorg xprint xscreensaver xsl xv xvid yahoo yv12 zip zlib linguas_en_GB userland_GNU kernel_linux elibc_glibc"
Comment 1 Luca Longinotti (RETIRED) gentoo-dev 2006-04-22 13:20:32 UTC
The error is in the pgsql module (PostgreSQL support, enabled through the "postgres" USE flag). It would help in this case to know the exact versions&revisions of dev-db/libpq and dev-db/postgresql you have installed on your system (emerge -pv output). It could be that dev-db/postgresql is not installed as it's not required, but if it IS installed, post the output of emerge -pv of that one too, thanks.
Best regards, CHTEKK.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-04-29 00:43:55 UTC
Response from user needed.
Comment 3 David Grant 2006-04-29 15:08:12 UTC
dev-db/libpq-8.0.4  +kerberos +nls +pam +readline +ssl +zlib

dev-db/postgresql-7.4.9  -doc +java +libg++ +nls +pam +perl -pg-hier -pg-intdatetime -pg-vacuumdelay +python +readline (-selinux) +ssl +tcltk +threads +xml2 +zlib

[ebuild     U ] dev-lang/php-5.1.2 [5.0.5-r5] -adabas -apache +apache2 -bcmath +berkdb -birdstep +bzip2 -calendar -cdb +cgi -cjk +cli +crypt +ctype +curl -curlwrappers -db2 -dbase -dbmaker -debug -discard-path -doc -empress -empress-bcs -esoob +exif +fastbuild -fdftk -filepro -firebird -flatfile +force-cgi-redirect -frontbase +ftp +gd -gd-external +gdbm +gmp -hardenedphp -hash -hyperwave-api +iconv +imap -informix -inifile -interbase -iodbc +ipv6 -java-external +kerberos +ldap -libedit -mcve +memlimit +mhash -ming -msql -mssql +mysql -mysqli +ncurses +nls -oci8 -oci8-instant-client +odbc -pcntl +pcre -pdo +pdo-external +pic +posix +postgres -qdbm +readline -recode +reflection* -sapdb +sasl +session -sharedext -sharedmem +simplexml -snmp +soap +sockets -solid +spell +spl +sqlite +ssl -sybase -sybase-ct -sysvipc +threads +tidy +tokenizer +truetype -unicode -vm-goto -vm-switch -wddx +xml -xmlreader -xmlrpc +xmlwriter* -xpm +xsl -yaz +zip +zlib
Comment 4 Luca Longinotti (RETIRED) gentoo-dev 2006-05-24 06:50:29 UTC
Hmm I'm not sure what this could be, maybe the difference between libpq and postgresql versions? It works perfectly fine here for me with both from the 8.0.X branch... Try dev-lang/php-5.1.4 too now that it is in the tree, it works here.
Best regards, CHTEKK.
Comment 5 David Grant 2006-05-24 23:39:31 UTC
I fixed it somehow, I can't remember how. But I did a massive cleanup of my system, cleaned up world, remove old packages, revdep-rebuilding, etc... and this eventually worked itself out.
Comment 6 David Grant 2006-05-24 23:39:50 UTC