Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 129494

Summary: Unable to emerge mono dev-lang/mono-1.1.13.2)
Product: Gentoo Linux Reporter: Joe DeRosa <garlik42>
Component: New packagesAssignee: dotnet <dotnet>
Status: VERIFIED FIXED    
Severity: normal CC: dhp_gentoo, garlik42, snex
Priority: High    
Version: 2005.1   
Hardware: x86   
OS: Other   
Whiteboard:
Package list:
Runtime testing required: ---

Description Joe DeRosa 2006-04-10 09:11:10 UTC
Gentoo Base System version 1.6.14
Portage 2.0.54 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.5-r3, 2.6.15-gent
oo-r1 i686)
=================================================================
System uname: 2.6.15-gentoo-r1 i686 Pentium II (Klamath)
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium2 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share
/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/
mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium2 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/home/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.mirrors.pair.com"
MAKEOPTS="-j2"
PKGDIR="/home/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa arts audiofile avi berkdb bitmap-fonts bzip2 crypt cups curl dri
 eds emboss encode esd exif expat fam foomaticdb fortran gdbm gif glut gmp gnome
 gpm gstreamer gtk gtk2 gtkhtml idn imlib ipv6 isdnlog java jpeg kde lcms libg++
 libwww mad mikmod mng motif mozilla mp3 mpeg ncurses nls ogg oggvorbis opengl o
ss pam pcre pdflib perl png pppd python qt quicktime readline samba sdl spell ss
l tcpd tiff truetype truetype-fonts type1-fonts udev vorbis xml2 xmms xv zlib us
erland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_
OVERLAY
Comment 1 Joe DeRosa 2006-04-10 09:13:13 UTC
make[8]: Entering directory `/var/tmp/portage/mono-1.1.13.2/work/mono-1.1.13.2/mcs/class/corlib'
MONO_PATH="../../class/lib/basic:$MONO_PATH" /var/tmp/portage/mono-1.1.13.2/work/mono-1.1.13.2/runtime/mono-wrapper  ../../class/lib/basic/mcs.exe /codepage:28591 -nowarn:169,612,618,649 -d:INSIDE_CORLIB  -d:NET_1_1 -d:ONLY_1_1 -debug /noconfig -unsafe -nostdlib /resource:resources/collation.core.bin /resource:resources/collation.tailoring.bin /resource:resources/collation.cjkCHS.bin /resource:resources/collation.cjkCHT.bin /resource:resources/collation.cjkJA.bin /resource:resources/collation.cjkKO.bin /resource:resources/collation.cjkKOlv2.bin -target:library -out:mscorlib.dll  @corlib.dll.sources

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Stacktrace:


Native stacktrace:

        /var/tmp/portage/mono-1.1.13.2/work/mono-1.1.13.2/mono/mini/mono(mono_handle_native_sigsegv+0xc0) [0x81518d0]
        /var/tmp/portage/mono-1.1.13.2/work/mono-1.1.13.2/mono/mini/mono [0x813dd9b]
        /lib/libpthread.so.0 [0xb7ea507d]
        [0xffffe440]
        [0x542e6d65]
make[8]: *** [../../class/lib/net_1_1_bootstrap/mscorlib.dll] Killed
make[8]: Leaving directory `/var/tmp/portage/mono-1.1.13.2/work/mono-1.1.13.2/mcs/class/corlib'
make[7]: *** [do-all] Error 2
make[7]: Leaving directory `/var/tmp/portage/mono-1.1.13.2/work/mono-1.1.13.2/mcs/class/corlib'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory `/var/tmp/portage/mono-1.1.13.2/work/mono-1.1.13.2/mcs/class'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/var/tmp/portage/mono-1.1.13.2/work/mono-1.1.13.2/mcs'
make[4]: *** [profile-do--net_1_1_bootstrap--all] Error 2
make[4]: Leaving directory `/var/tmp/portage/mono-1.1.13.2/work/mono-1.1.13.2/mcs'
Comment 2 DEMAINE BenoƮt-Pierre, aka DoubleHP 2006-07-07 01:12:26 UTC
would
emerge -C mono && emerge -1 mono
help users workaround this bug ? (not a fix thought )
Comment 3 Joe DeRosa 2006-07-20 11:23:59 UTC
Problem still occurs with 1.1.13.6. I am wondering if this could be a low memory problem, as the machine I am building this on has only 64 meg of ram.



MONO_PATH="../../class/lib/monolite:$MONO_PATH" /var/tmp/portage/mono-1.1.13.6/w                                                ork/mono-1.1.13.6/runtime/mono-wrapper  ../../class/lib/monolite/mcs.exe /codepa                                                ge:28591 -nowarn:169,612,618,649 -d:INSIDE_CORLIB  -d:NET_1_1 -d:ONLY_1_1 -d:BOO                                                TSTRAP_WITH_OLDLIB -debug /noconfig -unsafe -nostdlib /resource:resources/collat                                                ion.core.bin /resource:resources/collation.tailoring.bin /resource:resources/col                                                lation.cjkCHS.bin /resource:resources/collation.cjkCHT.bin /resource:resources/c                                                ollation.cjkJA.bin /resource:resources/collation.cjkKO.bin /resource:resources/c                                                ollation.cjkKOlv2.bin -target:library -out:mscorlib.dll  @corlib.dll.sources
make[8]: *** [../../class/lib/basic/mscorlib.dll] Segmentation fault

------

!!! ERROR: dev-lang/mono-1.1.13.6 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  mono-1.1.13.6.ebuild, line 80:   Called die

!!! MONO compilation failure
!!! If you need support, post the topmost build error, and the call stack if rel                                                evant.

Comment 4 Alex 2006-08-09 12:42:19 UTC
I had exactly the same pb.

by doing a:

emerge -C mono && emerge -1 mono

it unexpectedly ask for dev-dotnet/libgdiplus which was masked by ~x86 (never asked for it before.. how come?)

i added the package and tried again. It went all well.

Comment 5 Joe DeRosa 2006-08-11 06:45:55 UTC
It appears "emerge -C mono && emerge -1 mono" has worked more than once, and since this machine had mono on it, which was uninstalled (possibly not completely) It would be consistent with the -C. 

The machine in question has hard crashed, and I will be unable to continue to work on this, and I have been unable to reproduce on 3 other machines (2 i386 and one emt64) So I think it's safe to close the bug.
Comment 6 Joe DeRosa 2006-09-06 07:20:14 UTC
I have determined the cause of the bug.
After rebuilding the system with 2006.1, I got the same error in the same position. While rebuilding another package (cdrtools I think) I got an "illegal instruction" message, which led me to the fact that I had march=pentium3 in my make.conf file, well this system is a pentium2. After rebuilding the entire system  with march=pentium2 I emerged mono with no errors. I was able to merge the unmasked and masked versions.