Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 128454

Summary: Error when trying to access Samba network from gnome: "Couldn't display 'smb:///'"
Product: Gentoo Linux Reporter: Nicolas Laplante <nicolas-laplante>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED NEEDINFO    
Severity: major CC: yangdh
Priority: High    
Version: 2005.1   
Hardware: x86   
OS: Linux   
URL: http://nlaplante.homedns.org:1111/~nicolas/gentoo/Screen_SMB.png
Whiteboard:
Package list:
Runtime testing required: ---

Description Nicolas Laplante 2006-04-01 17:23:02 UTC
When I try to access Windows shares from my Gnome desktop, I get an error message: "Couldn't display 'smb:///'".

smbclient works fine.

It also happens when I try to connect to a remote smb server using "Connect to server".

My emerge --info:
Portage 2.0.54 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.5-r2, 2.6.15-gentoo-r1 i686)
=================================================================
System uname: 2.6.15-gentoo-r1 i686 AMD Athlon(tm) XP 2100+
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -mtune=athlon-xp -fomit-frame-pointer -momit-leaf-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -mtune=athlon-xp -fomit-frame-pointer -momit-leaf-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://adelie.polymtl.ca/ ftp://cs.ubishops.ca/pub/gentoo ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X alsa apm audiofile avi berkdb bitmap-fonts bzip2 cdr crypt cscope cups dri dvd dvdr eds emboss encode esd exif expat fam foomaticdb fortran gdbm gif glut gnome gpm gstreamer gtk gtk2 gtkhtml hal howl idn imagemagick imlib isdnlog java jpeg junit lcms libg++ libwww mad mikmod mng motif mp3 mpeg ncurses nptl nptlonly ogg oggvorbis opengl oss pam pcre pdflib perl png pppd python quicktime readline ruby samba sdl spell ssl svg tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales vorbis wmf x86 xml xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Yang Dehua 2006-07-10 19:01:23 UTC
I have the same problem: '"smb:///" is not a valid location. Please check the spelling and try again', when I tried to connect a windows machine in Nautilus.
Comment 2 Gilles Dartiguelongue gentoo-dev 2006-11-02 00:37:38 UTC
which version of gnome-base/gnome-vfs are you using ?
Comment 3 Steev Klimaszewski (RETIRED) gentoo-dev 2007-02-09 17:47:17 UTC
No response in quite a while, personally, I cannot reproduce.  Please reopen if you are still having this issue.