Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 127628

Summary: ebuild for Sali's modeller
Product: Gentoo Linux Reporter: Jeffrey Gardner (RETIRED) <je_fro>
Component: New packagesAssignee: Default Assignee for New Packages <maintainer-wanted>
Status: RESOLVED FIXED    
Severity: enhancement CC: jlec, sci-chemistry, weigt.mathias
Priority: High Keywords: EBUILD
Version: 2005.1   
Hardware: AMD64   
OS: Linux   
URL: http://salilab.org/modeller/about_modeller.html
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: ebuild for modeller - a protein homology modeling program
Diff to patch the ebuild to the new version of Modeller (9v2)
modeller-9.3.ebuild
modeller-bin-9.3.ebuild
modeller-bin-9.3.ebuild
modeller-bin-9.3-r2.ebuild
9v3-setup.patch
modeller-9.3.diff

Description Jeffrey Gardner (RETIRED) gentoo-dev 2006-03-26 04:25:55 UTC
Modeller is an extremely useful package for modeling protein structures.
I've attached an ebuild which has been tested and works on amd64. Any academic researcher is free to use this program for non-commercial projects. (Enjoy Marcus! :D )
Thanks!!
je_fro
Comment 1 Jeffrey Gardner (RETIRED) gentoo-dev 2006-03-26 04:27:28 UTC
Created attachment 83152 [details]
ebuild for modeller - a protein homology modeling program
Comment 2 Markus Dittrich (RETIRED) gentoo-dev 2006-03-28 09:00:59 UTC
Hi,

Thanks for the ebuild and Modeller surely is a nice package.
Unfortunately, I am currently pretty busy and won't get to
look at this in more detail until next week.

Best,
Markus
Comment 3 Mathias Weigt 2007-03-21 07:36:12 UTC
Created attachment 113953 [details, diff]
Diff to patch the ebuild to the new version of Modeller (9v2)

There is a new version out since january and I took the existing ebuild and modified it to fit to version 9v2 of Modeller. Main change was to copy also the new lib directory. Hopefully this gets sometimes into the tree.
Comment 4 Jeffrey Gardner (RETIRED) gentoo-dev 2007-04-17 19:01:54 UTC
ugh...I can't believe I ever suggested this.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-02-06 11:24:42 UTC
*** Bug 209119 has been marked as a duplicate of this bug. ***
Comment 6 Justin Lecher (RETIRED) gentoo-dev 2008-02-14 20:28:35 UTC
Created attachment 143526 [details]
modeller-9.3.ebuild
Comment 7 Justin Lecher (RETIRED) gentoo-dev 2008-03-13 16:26:40 UTC
Created attachment 146038 [details]
modeller-bin-9.3.ebuild

It's bin ...
Cleaned up some lines.
Comment 8 Justin Lecher (RETIRED) gentoo-dev 2008-03-13 16:36:56 UTC
Created attachment 146043 [details]
modeller-bin-9.3.ebuild
Comment 9 Donnie Berkholz (RETIRED) gentoo-dev 2008-04-08 21:27:52 UTC
I've got a need for this... Jeff, any particular reason you didn't like it?
Comment 10 Jeffrey Gardner (RETIRED) gentoo-dev 2008-04-09 16:23:11 UTC
9v3 is in the sci overlay. If anyone can find a unified LICENSE file for this package I'd be grateful.
Comment 11 Justin Lecher (RETIRED) gentoo-dev 2008-04-10 06:56:18 UTC
(In reply to comment #10)
> 9v3 is in the sci overlay. If anyone can find a unified LICENSE file for this
> package I'd be grateful.
> 

License is in Bug #209119.
Comment 12 Justin Lecher (RETIRED) gentoo-dev 2008-04-15 14:14:29 UTC
Created attachment 149811 [details]
modeller-bin-9.3-r2.ebuild

I reviewed what I wrote and found some enhancements. The bigest is thaat there is something which could be compiled. Than I cleaned up the ebuild from some unessecary lines.
Comment 13 Justin Lecher (RETIRED) gentoo-dev 2008-04-15 14:14:54 UTC
Created attachment 149813 [details]
9v3-setup.patch
Comment 14 Justin Lecher (RETIRED) gentoo-dev 2008-05-08 14:09:04 UTC
I reviewed again and found a lot of things. The biggest advantege is the pkg_config for the license key setup.
Comment 15 Justin Lecher (RETIRED) gentoo-dev 2008-05-08 14:09:50 UTC
Created attachment 152479 [details]
modeller-9.3.diff
Comment 16 Jeffrey Gardner (RETIRED) gentoo-dev 2008-10-06 01:35:32 UTC
In science overlay.