Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 127514

Summary: dev-lang/gnat-3.45 fails to configure (emerge)
Product: Gentoo Linux Reporter: Rumen Yotov <rumen>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: 2006.0   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Rumen Yotov 2006-03-25 03:13:21 UTC
Hi,
After checking some other gnat Bugs, on request in Bug-110831 open a new one.
Also have problems with gnat-3.45, here's the log:
...BEGIN...
FEATURES=autoconfig buildpkg ccache collision-protect distlocks enotice gpg parallel-fetch sandbox sfperms userpriv usersandbox
>>> Compiling source in /var/tmp/portage/gnat-3.45/work/gcc-3.4.5 ...
creating cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for a BSD compatible install... /bin/install -c
checking for i686-pc-linux-gnu-ar... i686-pc-linux-gnu-ar
checking for i686-pc-linux-gnu-as... i686-pc-linux-gnu-as
checking for i686-pc-linux-gnu-dlltool... no
checking for dlltool... dlltool
checking for i686-pc-linux-gnu-ld... i686-pc-linux-gnu-ld
checking for i686-pc-linux-gnu-nm... i686-pc-linux-gnu-nm
checking for i686-pc-linux-gnu-ranlib... i686-pc-linux-gnu-ranlib
checking for i686-pc-linux-gnu-windres... no
checking for windres... windres
checking for i686-pc-linux-gnu-objcopy... i686-pc-linux-gnu-objcopy
checking for i686-pc-linux-gnu-objdump... i686-pc-linux-gnu-objdump
checking for i686-pc-linux-gnu-ar... i686-pc-linux-gnu-ar
checking for i686-pc-linux-gnu-as... i686-pc-linux-gnu-as
checking for i686-pc-linux-gnu-dlltool... no
checking for dlltool... dlltool
checking for i686-pc-linux-gnu-ld... i686-pc-linux-gnu-ld
checking for i686-pc-linux-gnu-nm... i686-pc-linux-gnu-nm
checking for i686-pc-linux-gnu-ranlib... i686-pc-linux-gnu-ranlib
checking for i686-pc-linux-gnu-windres... no
checking for windres... windres
checking whether to enable maintainer-specific portions of Makefiles... no
updating cache ./config.cache
creating ./config.status
creating Makefile
gcc-3.4 -c xtreeprs.adb
gcc-3.4: Internal error: Killed (program gnat1)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
For Debian GNU/Linux specific bug reporting instructions, see
<URL:file:///usr/share/doc/gcc-3.4/README.Bugs>.

gnatmake: "xtreeprs.adb" compilation error

!!! ERROR: dev-lang/gnat-3.45 failed.
Call stack:
  ebuild.sh, line 1573:   Called dyn_compile
  ebuild.sh, line 982:   Called src_compile

!!! building helper tools
!!! If you need support, post the topmost build error, and the call stack if relevant.
...END...
This is my second attempt with FEATURES="... -confcache ..." (on first one received the same error). This is with GCC-3.4.6 on ~x86 system.
Some more info (requested in Bug-110831 and i think they are related)
# find /usr/lib -iname libgcc_s*
/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so.1
/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so
/usr/lib/openoffice/program/libgcc_s.so.1.1.1
/usr/lib/openoffice/program/libgcc_s.so.1
...
# equery belongs /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so.1
[ Searching for file(s) /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so.1 in *... ]
sys-devel/gc
# equery belongs /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so
[ Searching for file(s) /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so in *... ]
sys-devel/gcc-3.4.6 (/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so -> libgcc_s.so.1)
c-3.4.6 (/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so.1)
# equery belongs /usr/lib/openoffice/program/libgcc_s.so.1.1.1
[ Searching for file(s) /usr/lib/openoffice/program/libgcc_s.so.1.1.1 in *... ]
app-office/openoffice-bin-2.0.2 (/usr/lib/openoffice/program/libgcc_s.so.1.1.1)
# equery belongs /usr/lib/openoffice/program/libgcc_s.so.1
[ Searching for file(s) /usr/lib/openoffice/program/libgcc_s.so.1 in *... ]
app-office/openoffice-bin-2.0.2 (/usr/lib/openoffice/program/libgcc_s.so.1 -> libgcc_s.so.1.1.1)
===
# find /lib -iname libgcc_s*
/lib/libgcc_s.so.1
...# equery belongs /lib/libgcc_s.so.1
[ Searching for file(s) /lib/libgcc_s.so.1 in *... ]
...END...
#qfile /lib/libgcc_s.so.1 - returns 'nothing' (is /lib/libgcc_s.so.1 an orphan?)
# ls -l /lib/libgcc_s.so.1
-rw-r--r-- 1 root root 36072 2006-03-24 08:19 /lib/libgcc_s.so.1
The two in '/usr/lib/' belong to GCC-3.4.6 & OOo-bin-2.0.2 (plus two symlinks).
According to 'genlop' /lib/libgcc_s.so.1 must belong to GCC-3.4.6 see below:
     Fri Mar 24 07:12:41 2006 >>> sys-devel/automake-1.9.6-r2
     Fri Mar 24 08:20:59 2006 >>> sys-devel/gcc-3.4.6
     Fri Mar 24 08:37:24 2006 >>> www-client/mozilla-launcher-1.51
...END...
# qlist gcc | grep libgcc_s.so.1
/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so.1
# ls -l /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so.1
-rw-r--r-- 1 root root 36072 2006-03-24 08:19 /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so.1
# diff -u /lib/libgcc_s.so.1 /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libgcc_s.so.1
Seems they are identical (clones), exept one doesn't *belong* to GCC ;)
PS:this may not be the same/similar to Bug-110831 and i assumed so please excuse me if wrong but think this info is might be usefull.
Thanks.Rumen
emerge --info:
Gentoo Base System version 1.12.0_pre16
Portage 2.1_pre6-r7 (!/usr/portage/profiles/default-linux/x86/2006.0, gcc-3.4.6, glibc-2.4-r1, 2.6.16-gentoo i686)
=================================================================
System uname: 2.6.16-gentoo i686 AMD Athlon(tm) XP 2200+
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE=""
ALSA_CARDS="ens1371"
ARCH="x86"
AUTOCLEAN="yes"
BASH_ENV="/etc/spork/is/not/valid/profile.env"
CBUILD="i686-pc-linux-gnu"
CCACHE_DIR="/var/tmp/ccache"
CCACHE_SIZE="2G"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLORTERM=""
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/init.d /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/env.d"
CVS_RSH="ssh"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DCCC_PATH="/usr/lib/distcc/bin"
DISPLAY=":0.0"
DISTCC_LOG=""
DISTCC_VERBOSE="0"
DISTDIR="/var/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--verbose"
EMERGE_WARNING_DELAY="10"
FEATURES="autoconfig buildpkg ccache collision-protect confcache distlocks enotice gpg parallel-fetch sandbox sfperms userpriv usersandbox"
FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
FLTK_DOCDIR="/usr/share/doc/fltk-1.1.7/html"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://gentoo.ITDNet.net/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://files.gentoo.gr http://mirror.etf.bg.ac.yu/gentoo http://mirror.datapipe.net/gentoo"
GPG_AGENT_INFO="/tmp/gpg-O4dhwp/S.gpg-agent:15786:1"
GS_LIB="/home/gentoo/.fonts"
GTK2_RC_FILES="/home/gentoo/.gtkrc-2.0"
GTK_RC_FILES="/etc/gtk/gtkrc:/home/gentoo/.gtkrc:/home/gentoo/.kde/share/config/gtkrc"
G_BROKEN_FILENAMES="1"
HOME="/root"
HOSTNAME="mach"
HUSHLOGIN="FALSE"
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.16.1/info:/usr/share/gcc-data/i686-pc-linux-gnu/3.4.6/info"
INPUT_DEVICES="keyboard mouse"
KDEDIRS="/usr"
KDE_FULL_SESSION="true"
KDE_MULTIHEAD="false"
KERNEL="linux"
KONSOLE_DCOP="DCOPRef(konsole-15866,konsole)"
KONSOLE_DCOP_SESSION="DCOPRef(konsole-15866,session-1)"
LADSPA_PATH="/usr/lib/ladspa"
LANG="bg_BG.UTF8"
LC_ALL="en_US.UTF8"
LC_MESSAGES="en"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LOGNAME="root"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.qt=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.flac=01;35:*.mp3=01;35:*.mpc=00;36:*.ogg=00;36:*.wav=00;36:*.mid=00;36:*.midi=00;36:*.au=00;36:*.flac=00;36:*.aac=00;36:"
MAKEOPTS="-j2"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.16.1/man:/usr/share/gcc-data/i686-pc-linux-gnu/3.4.6/man:/usr/qt/3/doc/man"
MOZILLA_FIVE_HOME="/usr/lib/mozilla"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/sbin:/bin:/usr/sbin:/usr/bin"
PKGDIR="/var/portage/packages"
PORTAGE_ARCHLIST="ppc s390 amd64 ppc64 m68k arm sparc sh mips ia64 alpha ppc-macos hppa x86"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_CALLER="emerge"
PORTAGE_ELOG_CLASSES="info warn error log"
PORTAGE_ELOG_MAILFROM="portage@qrypto.org"
PORTAGE_ELOG_MAILURI="gentoo@mach.qrypto.org localhost"
PORTAGE_ELOG_SYSTEM="save mail"
PORTAGE_GID="250"
PORTAGE_GPG_DIR="/etc/portage/gpg"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_MASTER_PID="22021"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_TMPFS="/dev/shm"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/overlays/pkalin /usr/portage/local/layman/ecatmur /usr/portage/local/layman/kolab2 /usr/portage/local/layman/webapps-experimental"
PORT_ENOTICE_DIR="/var/enotice/"
PORT_LOGDIR="/var/log/portage"
PRELINK_PATH=""
PRELINK_PATH_MASK="/usr/lib/gstreamer-0.10:/usr/lib/gstreamer-0.8:/usr/lib/klibc"
PWD="/root"
PYTHONDOCS="/usr/share/doc/python-docs-2.4.2/html"
PYTHONPATH="/usr/lib/portage/pym"
QMAILIDHOST="connectioncable-084.headoff.net"
QMAIL_CONTROLDIR="/var/qmail/control"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
RPMDIR="/usr/portage/rpm"
RSYNC_RETRIES="3"
RSYNC_TIMEOUT="180"
RUBYOPT="-rauto_gem"
SEARCH_DIRS_MASK="/usr/lib/openoffice"
SESSION_MANAGER="local/mach:/tmp/.ICE-unix/15825"
SHELL="/bin/bash"
SHLVL="6"
SSH_AGENT_PID="15642"
SSH_AUTH_SOCK="/tmp/ssh-BWnsY15641/agent.15641"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="xterm"
TMAKEPATH="/usr/lib/tmake/linux-g++"
USE="x86 3dnow X X509 a52 aac acl acpi alsa apache2 avi bash-completion berkdb bitmap-fonts caps cdb cdr cli crypt ctype cups curl dba dri dvd dvdr eds encode esd evo exif expat fastbuild ffmpeg flac foomaticdb force-cgi-redirect freetype ftp gd gif gnutls gstreamer gtk gtk2 gtkhtml hal iconv imap imlib ipv6 ithreads javascript jpeg kdexdeltas lcms libg++ libwww mad maildir matroska memlimit mikmod mime mmx motif mp3 mpeg ncurses nls nptl nvidia ogg opengl oss pam pcre pdflib perl png posix ppds prelude python quicktime readline sdl session simplexml skey soap sockets speex spell spl sse ssl svg symlink tcpd theora threads tokenizer transcode truetype truetype-fonts type1-fonts udev unicode usb vorbis win32codecs xine xml xsl xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_vesa video_cards_fbdev video_cards_nv video_cards_nvidia"
USER="root"
USERLAND="GNU"
USE_EXPAND="DVB_CARDS ELIBC FCDSL_CARDS FRITZCAPI_CARDS INPUT_DEVICES KERNEL LINGUAS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN=""
USE_ORDER="env:pkg:conf:defaults"
VIDEO_CARDS="vesa fbdev nv nvidia"
WINDOWID="4194309"
XARGS="xargs -r"
XAUTHORITY="/root/.xauthAYnwN5"
XCURSOR_THEME="default"
XDG_CONFIG_DIRS="/usr/kde/3.5/etc/xdg"
XDG_DATA_DIRS="/usr/kde/3.5/share:/usr/share"
_="/usr/bin/emerge"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-03-25 04:59:17 UTC
Most likely out of memory/disk space.

*** This bug has been marked as a duplicate of 20600 ***