Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 127200

Summary: netscape-flash misbehaves in Opera
Product: Gentoo Linux Reporter: David Mehrmann <jammet>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: VERIFIED FIXED    
Severity: normal CC: antoni, armin76, axxo, belgix_oz, Christian.Szegedy, denilsonsa, jer, tester, vanya
Priority: High Keywords: Bug
Version: 2006.0   
Hardware: x86   
OS: Linux   
URL: http://forums.gentoo.org/viewtopic-t-443875.html
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 326841    
Attachments: netscape-flash-9.0.31.0.ebuild.patch
opera-9.20.ebuild-netscape-flash.patch
opera-9.20.ebuild-netscape-flash.patch with added elog hint

Description David Mehrmann 2006-03-22 09:28:47 UTC
There is a good chance this is Gentoo related as only Gentoo users have complained about Opera refusing to play flash stream-movies.

Personally I have no clue as to what is causing it. It could be related to file permissions or temporary file permissions or their location, group settings or something else.

I am filing this as a bug in Gentoo in the hope that whoever is testing this (links below) will find out more and be able to fix the problem.

Test sites: Google video, Gamespot,  and YouTube. Normally Opera 8 and 9 using the most recent Macromedia flash plugin will handle these. FireFox will, too.

   http://www.gamespot.com (frontpage flash video player)
   http://video.google.com/
   http://www.youtube.com/

Gentoo side discussion:
   http://forums.gentoo.org/viewtopic-t-443875.html

Opera side discussion:
   http://my.opera.com/community/forums/topic.dml?id=129106
Comment 1 David Mehrmann 2006-03-22 10:51:07 UTC
AMD64 (32 bit) users have reported on the Gentoo forums that they have encountered this problem as well.
Comment 2 Slegge 2006-03-22 12:30:41 UTC
This dosn't seem to be more gentoo related than the placement of the plugin. See http://forums.gentoo.org/viewtopic-p-3200373.html#3200373

If someone could test this to be sure this bug could be closed and we could file one with Opera or Macromedia.

Comment 3 David Mehrmann 2006-03-22 12:39:14 UTC
Confirmed! Thanks so much Slegge!

Bug can be closed.
Comment 5 David Mehrmann 2006-10-13 15:20:16 UTC
As more and more people stumble upon this problem - Opera developers included - I believe it's save to say that we need a more permanent solution to this problem.

I reopen the bug in the hope that the necessary changes can be applied to Opera ebuilds or the flash plugin ebuild (some symlinks are needed, please read the Forum thread linked below).
Comment 6 adr 2006-10-16 03:17:15 UTC
A temporary fix for the www-client/opera ebuild would be to make 2 symlinks (whether net-www/netscape-flash is/will be installed or not):
# ln -s /opt/netscape/plugins/flashplayer.xpt /opt/opera/lib/opera/plugins/flashplayer.xpt 
# ln -s /opt/netscape/plugins/libflashplayer.so /opt/opera/lib/opera/plugins/libflashplayer.so

"Assigned To: 	Heinrich Wendel (RETIRED) <lanius@gentoo.org>"
Maybe nobody will read this bug anymore. Someone with appropriate permissions should reassign the bug...
Comment 7 Jeroen Roovers gentoo-dev 2006-10-18 20:15:27 UTC
I was able to "fix" this bug by (illegally!) hacking net-www/netscape-flash like so:

sed -e 's|netscape|foobarzz|g' -i /opt/netscape/plugins/libflashplayer.so

On a system that had this issue playing video through the Flash plugin in Opera, the above fixed it completely, as a few Flash Video tests showed.

The problem is not in Opera, but in Macromedia's Flash Player. I did try the new net-www/netscape-flash-9* tonight, which works in Firefox, but not in Opera (yet)[1].

Therefore, I am closing this bug as UPSTREAM: without modifying libflashplayer.so illegally[2], this bug cannot be fixed, and it is up to Macromedia, Inc. to fix it.


[1] In Opera, the plugin window stays blank and does not load the Flash interface at all.
[2] <${PORTDIR}/licenses/Macromedia>, section 3.(e).
Comment 8 Jeroen Roovers gentoo-dev 2007-04-26 14:39:55 UTC
*** Bug 176077 has been marked as a duplicate of this bug. ***
Comment 9 Jeroen Roovers gentoo-dev 2007-04-26 15:01:35 UTC
@Vanya: On the other bug, you said a symlink should be created: /opt/opera/lib/opera/plugins/libflashplayer.so -> /opt/netscape/plugins/libflashplayer.so.

If this actually works in all cases, I don't see a reason not to set a symlink. One important requirement is that Opera keeps working even after netscape-flash is unmerged (making the symlink a dead link), in case the opera ebuild sets the symlink. The alternative would be to have netscape-flash set the symlink instead (yet there is no maintainer to CC on this bug, sadly). Recent changes are from beandog and armin76, more changes were made by tester.
Comment 10 Jeroen Roovers gentoo-dev 2007-04-26 15:09:18 UTC
Created attachment 117310 [details, diff]
netscape-flash-9.0.31.0.ebuild.patch
Comment 11 Ivan Yarych 2007-04-26 18:07:12 UTC
Opera works with nescape-flash being unmerged (symlink in place). Just no flash in this case :)
But why should you bother if this symlink comes with netscape-flash and not Opera? :)
Please don't forget about the instructions of making use of that 'modified' plugin in Opera.
Thanks.
Comment 12 Jeroen Roovers gentoo-dev 2007-04-26 21:52:56 UTC
Created attachment 117344 [details, diff]
opera-9.20.ebuild-netscape-flash.patch

We might do it in Opera instead.
Comment 13 Jeroen Roovers gentoo-dev 2007-04-26 22:24:35 UTC
Created attachment 117346 [details, diff]
opera-9.20.ebuild-netscape-flash.patch with added elog hint

(In reply to comment #11)
> Opera works with nescape-flash being unmerged (symlink in place).
> Just no flash in this case :)

Indeed.

> But why should you bother if this symlink comes with netscape-flash and not
> Opera? :)

Ultimately this problem should go upstream, either to Adobe or to Opera. It seems Opera can't really do anything about the Flash plugin behaving this way.

> Please don't forget about the instructions of making use of that 'modified'
> plugin in Opera.

Modified pluginpath.ini you mean... Here goes.
Comment 14 Ivan Yarych 2007-04-27 06:22:57 UTC
I am also trying to figure out if that is possible to set this option systemwide.
http://my.opera.com/community/forums/topic.dml?id=186198&t=1177654855&page=1#comment2020636
Comment 15 Jeroen Roovers gentoo-dev 2007-05-14 03:09:32 UTC
The "symlink workaround" is in CVS now in opera-9.20-r1.ebuild.
Comment 16 Ivan Yarych 2007-05-14 07:04:59 UTC
It will be possible to set plugin path system-wide after fixing Opera's bug with global pluginpath.ini . We should make all the strings with 'netscape' word in them and with '=2' . I think some sed command will allow to dot this? I'm not an expert in sed :)
Also take a look here:
http://my.opera.com/community/forums/topic.dml?id=186198&t=1179126097&page=1#comment2021093
Comment 17 Ivan Yarych 2007-05-14 07:06:05 UTC
(In reply to comment #16)
> We should make all the strings with 'netscape'
> word in them and with '=2' .

I meant /opt/opera/share/opera/ini/pluginpath.ini
Comment 18 Jeroen Roovers gentoo-dev 2007-07-07 20:47:17 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > We should make all the strings with 'netscape'
> > word in them and with '=2' .
> 
> I meant /opt/opera/share/opera/ini/pluginpath.ini

Fixed in opera-9.21-r1. /opt/netscape/plugins is deprecated in favour of /usr/lib/nsbrowser/plugins anyway, so pluginpath.ini is now patched to turn that 1 into a 2.
Comment 19 Denilson Sá 2007-07-26 12:05:01 UTC
(In reply to comment #18)
> (In reply to comment #17)
> > (In reply to comment #16)
> > > We should make all the strings with 'netscape'
> > > word in them and with '=2' .
> > 
> > I meant /opt/opera/share/opera/ini/pluginpath.ini
> 
> Fixed in opera-9.21-r1. /opt/netscape/plugins is deprecated in favour of
> /usr/lib/nsbrowser/plugins anyway, so pluginpath.ini is now patched to turn
> that 1 into a 2.

If this is considered "fixed" and that path is deprecated, why does opera-9.22 ebuild still install this symlink?
/opt/opera/lib/opera/plugins/libflashplayer.so -> /opt/netscape/plugins/libflashplayer.so

(I would reopen this bug if I had permission to do so)
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2007-07-26 13:23:45 UTC
(In reply to comment #19)
> If this is considered "fixed" and that path is deprecated, why does opera-9.22
> ebuild still install this symlink?
> /opt/opera/lib/opera/plugins/libflashplayer.so ->
> /opt/netscape/plugins/libflashplayer.so

Because every reasonable software should be able to deal with a simple symlink and other things still expect the plugin in /opt/netscape/plugins/ and because binary crap belongs to /opt. 

If opera can't deal with symlinks, go moan to Opera, not to Gentoo.

Comment 21 David Mehrmann 2007-07-26 14:58:54 UTC
(In reply to comment #20)

If we do everything this way we'll end up packages entirely broken really quickly. Please don't be this way, it's rude. Every package has to be dealt with independently. 

You should make sure to have Opera know what the problem is. But if there's a temp fix that you can provide to help the users - if it doesn't clash with something else, then please submit it.
Comment 22 Jeroen Roovers gentoo-dev 2007-07-26 15:31:44 UTC
(In reply to comment #19)
> If this is considered "fixed" and that path is deprecated, why does opera-9.22
> ebuild still install this symlink?
> /opt/opera/lib/opera/plugins/libflashplayer.so ->
> /opt/netscape/plugins/libflashplayer.so

Thanks for noticing. Removed that in opera-9.22-r1

> (I would reopen this bug if I had permission to do so)

Wouldn't be the same bug, would it?
Comment 23 Jeroen Roovers gentoo-dev 2007-07-26 15:46:35 UTC
(In reply to comment #22)
> (In reply to comment #19)
> > If this is considered "fixed" and that path is deprecated, why does opera-9.22
> > ebuild still install this symlink?

Because the net-www/netscape-flash plugin is installed there, and a symlink is placed in /usr/lib/nsbrowser/plugins. With our symlink in /opt/opera/lib/opera/plugins absent, it picks the one in /opt/netscape, which then causes the plugin itself to somehow limit itself. The plugin only does this when the web browser is not a Netscape derivative, it seems. The blame doesn't even lie with Opera because it's the plugin that is misbehaving.

> > /opt/opera/lib/opera/plugins/libflashplayer.so ->
> > /opt/netscape/plugins/libflashplayer.so
> 
> Thanks for noticing. Removed that in opera-9.22-r1

By the way, I cannot get videos to display on Youtube.com after (re)moving ${HOME}.opera/. I guess we really do need the symlink after all. :)
Comment 24 Jakub Moc (RETIRED) gentoo-dev 2007-07-26 15:48:48 UTC
Yeah the symlink needs to stay there, any other rants about this go to Adobe/Opera.
Comment 25 Denilson Sá 2007-07-27 04:36:54 UTC
Actually, I found why I still can't play videos in Opera. Let me explain here, so other people with same problem can find the solution:

Running "opera" does not work for me.
Deleting ~/.opera/pluginpath.ini and running "opera" still does not work.
Manually setting "/opt/netscape/plugins=2" at ~/.opera/pluginpath.ini (as described in 9.21 ebuild) works, but I don't think this is a good solution.
Running "opera -personaldir /tmp/p" (with an empty profile) also works.

So, why does a new and empty profile work, and the old one doesn't? Let's try to find out:

$ diff ~/.opera/pluginpath.ini /tmp/p/pluginpath.ini
They are exactly equal.

$ fgrep '/plugins/libflashplayer' ~/.opera/opera6.ini /tmp/p/opera6.ini
~/.opera/opera6.ini:application/x-shockwave-flash=6,,/opt/netscape/plugins/libflashplayer.so,Shockwave Flash,swf,|Shockwave Flash
~/.opera/opera6.ini:application/futuresplash=6,,/opt/netscape/plugins/libflashplayer.so,Shockwave Flash,spl,|FutureSplash Player
/tmp/p/opera6.ini:application/futuresplash=6,,/opt/opera/lib/opera/plugins/libflashplayer.so,Shockwave Flash,spl,|FutureSplash Player
/tmp/p/opera6.ini:application/x-shockwave-flash=6,,/opt/opera/lib/opera/plugins/libflashplayer.so,Shockwave Flash,swf,|Shockwave Flash

So, looks like the old opera6.ini inside my profile still points to /opt/netscape/plugins/, while the new one is created pointing to /opt/opera/lib/opera/plugins/.

Solution 1: Preferences -> Advanced -> Downloads -> application/x-shockwave-flash swf -> Edit... -> Select the correct plugin at "Use plug-in" drop-down. Repeat that for application/futuresplash spl file type. (no need to restart Opera after this)

Solution 2: Manually edit ~/.opera/opera6.ini while Opera is closed.

I hope this solution can help other people. Maybe "opera" script could be patched to warn the user whenever "/opt/netscape/plugins/libflashplayer.so" is found in ~/.opera/opera6.ini. (maybe this is not a good thing to do in a Gentoo ebuild, but I will try to ask Opera guys to take a look at this bug)
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2007-10-07 19:40:44 UTC
*** Bug 195024 has been marked as a duplicate of this bug. ***
Comment 27 Jakub Moc (RETIRED) gentoo-dev 2007-11-05 16:13:25 UTC
*** Bug 198162 has been marked as a duplicate of this bug. ***