Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 126466

Summary: Full System Lockup On Logout From Modular X with ati-drivers
Product: Gentoo Linux Reporter: Tim Redman <tim>
Component: Current packagesAssignee: X11 External Driver Maintainers <x11-drivers>
Severity: normal    
Priority: High    
Version: 2006.0   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Tim Redman 2006-03-16 15:40:01 UTC
I've been able to repeat this 100% of the time on my system.

When I do a logout from KDE, the screen clears, and KDM attempts to start up.  It gets to the same spot every time and locks up solid (cold reset only).  The machine is completely unresponsive, even via serial and SSH.  The final entry of the session appears in my kdm.log file as:

(EE) fglrx(0): CAIL: CAILResetAndInitializeGUI, error 1

I have an ATI Radeon 9200 for video.  I also have the modularized xorg-x11 installed per and, so my X configuration is all unmasked to high heaven.  The point is that this is a test machine specifically set to try out modX (and maybe later XGL), so re-merging the stable xorg-x11 to fix the problem is not a logical option.

Portage 2.1_pre6-r3 (default-linux/x86/2006.0, gcc-3.4.5, glibc-2.3.5-r2, 2.6.15-gentoo-r1 i686)
System uname: 2.6.15-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.6.14
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-Os -march=pentium4 -pipe -mno-tls-direct-seg-refs"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=pentium4 -pipe -mno-tls-direct-seg-refs"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
USE="x86 X acl alsa apache2 audiofile avi bash-completion berkdb bitmap-fonts browserplugin bzip2 chroot cli crypt ctype cups curl dba dga divx4linux dri dv dvd dvdr eds emboss encode expat faad fastbuild ffmpeg flac foomaticdb force-cgi-redirect ftp gd gdbm gif gimpprint gmp gstreamer gtk gtk2 gtkhtml icq idn imap imlib innodb java jpeg junit kde lcms ldap lesstif libg++ libwww live mad maildir memlimit mmx mng mozilla mozsvg mp3 mpeg msn musicbrainz mysql ncurses nptl nptlonly nsplugin ogg opengl oss pam pcre pdflib perl png posix ppds python qt quicktime radeon readline samba screen sdl sensord session simplexml soap sockets softmmu spell spl sse ssl svg sysfs tcltk tcpd tiff tokenizer truetype truetype-fonts type1-fonts udev usb userlocales v4l v4l2 visualization vorbis xml xmms xscreensaver xsl xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_fglrx"
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2006-03-24 15:24:59 UTC
Can you reproduce this with the "ati" driver?
Comment 2 Tim Redman 2006-03-29 06:50:28 UTC
I haven't tried this with the ati driver yet, but I did notice that it's behaving differently now.  Since I filed this bug, I've upgraded xorg-server twice.  Since upgrading to 1.0.1-r4, kdm restarts but never leaves a black screen.  However, the system doesn't hard lock up anymore, and I can ssh into the box and restart kdm by hand, which gives me a login again.  This morning, I upgraded to 1.0.2-r1, but I haven't tried restarting yet to see if there's a change.  I'll keep you posted.

As far as trying the ati driver, it seems that the error message is specific to fglrx, but I'll try swapping them out in any event and see what the difference is.  If xorg-server-1.0.2-r? works, it may be a moot point.
Comment 3 Tim Redman 2006-03-31 23:57:17 UTC
Seems it is.  xorg-server-1.0.2-r2 ends session and pops up kdm just fine.  I'm going to keep working with it until Monday or Tuesday, and if nothing else crops up, I see no reason to not change the resolution to FIXED, assuming that 1.0.2-r2 is what fixed the problem.
Comment 4 Tim Redman 2006-04-03 06:24:51 UTC
Never mind.  It's still doing it with xorg-server-1.0.2-r3.  kdm.log is still showing the same "CAIL: CAILResetAndInitializeGUI, error 1" message.  However, it's not hard locking the system any more.  I can still remote into it and restart /etc/init.d/xdm and everything pops back to normal.  I'll try switching to the ati driver and see what that does.
Comment 5 Yang Zhao 2006-04-05 01:40:44 UTC
related to bug #113685?
Comment 6 Tim Redman 2006-04-06 04:00:42 UTC

It very well may be.  Ruben provided a link on that bug to that seemed to fix the problem for me, at least for now (TerminateServer=true in kdmrc).  Bug 113685 doesn't seem to mention anything about the CAILResetAndInitializeGUI error by name, but the symptoms appear to be the same.  Although the solution doesn't work for everybody, I believe it works in this case, so it's Donnie's discretion whether to mark this bug as a duplicate of 113685, or just as RESOLVED for now.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-11-10 12:53:52 UTC

*** This bug has been marked as a duplicate of 113685 ***