Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 125164

Summary: net-misc/vnc fails to emerge with GCC 4.1.0
Product: Gentoo Linux Reporter: Nathan Blomquist <fleshy_ai>
Component: [OLD] GCC PortingAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: VERIFIED FIXED    
Severity: normal CC: ac, aliz, askwar, gentoo, jrmalaq, patrizio.bassi, rabroersma, rafael, toddmarimon, vapier
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 117482    
Attachments: Ebuild for X version bump and patches
Patch to allow GCC 4.1.0 to build this (might fix gcc 4.0 too)
Uses X11R6.9.0, compiles on ppc with gcc-4.1.0
Patch for gcc 4.1.1

Description Nathan Blomquist 2006-03-05 19:19:24 UTC
I was attempting to emerge Real VNC 4.0 with server flag.  It failed to emerge and I found a patch on the internet.  I have bumped the X version it uses to 6.8.2 and applied the patch.  It now builds and installs.  I am writing this in firefox running in the VNC session.

EBuild and patch will be applied.
Comment 1 Nathan Blomquist 2006-03-05 19:20:56 UTC
Created attachment 81483 [details]
Ebuild for X version bump and patches
Comment 2 Nathan Blomquist 2006-03-05 19:21:51 UTC
Created attachment 81484 [details, diff]
Patch to allow GCC 4.1.0 to build this (might fix gcc 4.0 too)
Comment 3 Nathan Blomquist 2006-03-05 19:29:14 UTC
Forgot to post that the patch was found here:
http://www.linuxfromscratch.org/patches/blfs/svn/X11R6.8.2-src-gcc4-1.patch

Comment 4 Patrizio Bassi 2006-03-06 03:08:34 UTC
the actual one fails due to old 6.8.1.

please follow the new ebuild :)

i686-pc-linux-gnu-gcc -c -O2 -fno-strength-reduce -ansi -pedantic -Wall -Wpointer-arith -Wundef    -fno-merge-constants -I../../../exports/include/X11 -I. -I../mfb -I../mi -I../cfb              -I../include -I../../../include -I../../../lib              -I../../../include/extensions -I../../../include/fonts -I../../../lib/X11  -I../../.. -I../../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                               -D_POSIX_SOURCE -D_XOPEN_SOURCE                    -D_BSD_SOURCE -D_SVID_SOURCE                              -D_GNU_SOURCE                           -DSHAPE -DXINPUT -DXKB -DLBX -DXAPPGROUP   -DXCSECURITY -DTOGCUP   -DXF86BIGFONT -DDPMSExtension    -DPIXPRIV -DPANORAMIX   -DRENDER -DRANDR       -DXFIXES -DDAMAGE -DCOMPOSITE -DXEVIE -DGCCUSESGAS -DAVOID_GLYPHBLT -DPIXPRIV -DSINGLEDEPTH                                 -DXFreeXDGA -DXvExtension                           -DXFree86LOADER  -DXFree86Server                                -DXF86VIDMODE                               -DXvMCExtension                                 -DSMART_SCHEDULE                           -DBUILDDEBUG -DXResExtension                             -DX_BYTE_ORDER=X_LITTLE_ENDIAN                          -DXORG_VERSION_CURRENT="(((6) * 10000000) + ((8) * 100000) + ((1) * 1000) + 0)" -DNDEBUG   -DFUNCPROTO=15 -DNARROWPROTO   -DXPRINTDIR=\"/usr/lib/X11/xserver\" -DXPRASTERDDX -DXPPCLDDX -DXPMONOPCLDDX          -DXPPSDDX -DHAS_MKSTEMP -UXFree86LOADER -D_XP_PRINT_SERVER_   attributes.c
attributes.c: In function &#8216;XpGetConfigDirBase&#8217;:
attributes.c:152: warning: assignment from incompatible pointer type
attributes.c:152: warning: comparison of distinct pointer types lacks a cast
attributes.c:153: warning: assignment from incompatible pointer type
attributes.c:155: warning: return from incompatible pointer type
attributes.c: In function &#8216;BuildPrinterAttrs&#8217;:
attributes.c:327: warning: unused variable &#8216;dirName&#8217;
attributes.c: In function &#8216;XpGetOneAttribute&#8217;:
attributes.c:627: warning: unused variable &#8216;retVal&#8217;
attributes.c: In function &#8216;AppendEntry&#8217;:
attributes.c:819: warning: &#8216;return&#8217; with no value, in function returning non-void
attributes.c: In function &#8216;XpGetAttributes&#8217;:
attributes.c:878: warning: unused variable &#8216;retVal&#8217;
attributes.c: At top level:
attributes.c:1094: error: static declaration of &#8216;ExecCommand&#8217; follows non-static declaration
attributes.h:113: error: previous declaration of &#8216;ExecCommand&#8217; was here
attributes.c: In function &#8216;SendFileToCommand&#8217;:
attributes.c:1187: warning: implicit declaration of function &#8216;initgroups&#8217;
attributes.c:1202: warning: unused variable &#8216;res&#8217;
attributes.c: In function &#8216;VectorizeCommand&#8217;:
attributes.c:1440: warning: unused variable &#8216;i&#8217;
attributes.c:1439: warning: unused variable &#8216;curTok&#8217;
attributes.c: In function &#8216;XpSubmitJob&#8217;:
attributes.c:1466: warning: unused variable &#8216;cmdOpt&#8217;
attributes.c: In function &#8216;XpGetTrayMediumFromContext&#8217;:
attributes.c:1590: warning: unused variable &#8216;pLast&#8217;
attributes.c:1590: warning: unused variable &#8216;pE&#8217;
attributes.c:1590: warning: unused variable &#8216;pS&#8217;
make[2]: *** [attributes.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/vnc-4.0-r1/work/vnc-4.0-unixsrc/xc/programs/Xserver/Xprint'
make[1]: *** [Xprint] Error 2
Comment 5 David Gurvich 2006-05-25 23:44:53 UTC
Created attachment 87534 [details]
Uses X11R6.9.0, compiles on ppc with gcc-4.1.0

The ebuild is just a copy of the earlier one that uses the 6.9.0 sources.  These seem to be compatible with gcc-4.1.0 on ppc.
Comment 6 Todd Marimon 2006-06-08 19:26:44 UTC
I'm getting an error with the X 6.8.2 ebuild (comment #1 along with patch from comment #2):

i686-pc-linux-gnu-gcc -c -O3 -march=pentium2 -mtune=pentium2 -pipe -fomit-frame-pointer -ansi -pedantic -Wall -Wpointer-arith -Wundef    -fno-merge-constants -I../../../programs/Xserver/fb -I../../../programs/Xserver/mi -I../../../programs/Xserver/include         -I../../../exports/include/X11          -I../../../include/fonts -I../../../programs/Xserver/hw/xfree86/common            -I../../../programs/Xserver/render -I../../../include/extensions -I../../../programs/Xserver/Xext  -I../../.. -I../../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                             -D_POSIX_SOURCE -D_XOPEN_SOURCE                                 -D_BSD_SOURCE -D_SVID_SOURCE                      -D_GNU_SOURCE                            -DSHAPE -DXINPUT -DXKB -DLBX -DXAPPGROUP       -DXCSECURITY -DTOGCUP   -DXF86BIGFONT -DDPMSExtension    -DPIXPRIV -DPANORAMIX   -DRENDER -DRANDR         -DXFIXES -DDAMAGE -DCOMPOSITE -DXEVIE    -DGCCUSESGAS -DAVOID_GLYPHBLT -DPIXPRIV -DSINGLEDEPTH                          -DXFreeXDGA -DXvExtension                -DXFree86LOADER  -DXFree86Server                                 -DXF86VIDMODE                           -DXvMCExtension                                 -DSMART_SCHEDULE         -DBUILDDEBUG -DXResExtension                             -DX_BYTE_ORDER=X_LITTLE_ENDIAN                          -DXORG_VERSION_CURRENT="(((6) * 10000000) + ((8) * 100000) + ((2) * 1000) + 0)" -DNDEBUG   -DFUNCPROTO=15 -DNARROWPROTO  -DIN_MODULE -DXFree86Module   -mmmx -Winline --param inline-unit-growth=10000    --param large-function-growth=10000 -DUSE_GCC34_MMX fbpict.c
rm -f fbmmx.oi686-pc-linux-gnu-gcc -c -O3 -march=pentium2 -mtune=pentium2 -pipe -fomit-frame-pointer -ansi -pedantic -Wall -Wpointer-arith -Wundef    -fno-merge-constants -I../../../programs/Xserver/fb -I../../../programs/Xserver/mi -I../../../programs/Xserver/include         -I../../../exports/include/X11          -I../../../include/fonts -I../../../programs/Xserver/hw/xfree86/common            -I../../../programs/Xserver/render -I../../../include/extensions -I../../../programs/Xserver/Xext  -I../../.. -I../../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                             -D_POSIX_SOURCE -D_XOPEN_SOURCE                                 -D_BSD_SOURCE -D_SVID_SOURCE                      -D_GNU_SOURCE                            -DSHAPE -DXINPUT -DXKB -DLBX -DXAPPGROUP       -DXCSECURITY -DTOGCUP   -DXF86BIGFONT -DDPMSExtension    -DPIXPRIV -DPANORAMIX   -DRENDER -DRANDR         -DXFIXES -DDAMAGE -DCOMPOSITE -DXEVIE    -DGCCUSESGAS -DAVOID_GLYPHBLT -DPIXPRIV -DSINGLEDEPTH                          -DXFreeXDGA -DXvExtension                -DXFree86LOADER  -DXFree86Server                                 -DXF86VIDMODE                           -DXvMCExtension                                 -DSMART_SCHEDULE         -DBUILDDEBUG -DXResExtension                             -DX_BYTE_ORDER=X_LITTLE_ENDIAN                          -DXORG_VERSION_CURRENT="(((6) * 10000000) + ((8) * 100000) + ((2) * 1000) + 0)" -DNDEBUG   -DFUNCPROTO=15 -DNARROWPROTO  -DIN_MODULE -DXFree86Module   -mmmx -Winline --param inline-unit-growth=10000    --param large-function-growth=10000 -DUSE_GCC34_MMX fbmmx.c
fbmmx.c:39: warning: specifying vector types with __attribute__ ((mode)) is deprecated
fbmmx.c:39: warning: use __attribute__ ((vector_size)) instead
fbmmx.c:40: warning: specifying vector types with __attribute__ ((mode)) is deprecated
fbmmx.c:40: warning: use __attribute__ ((vector_size)) instead
fbmmx.c:41: warning: specifying vector types with __attribute__ ((mode)) is deprecated
fbmmx.c:41: warning: use __attribute__ ((vector_size)) instead
fbmmx.c:43: warning: ISO C90 does not support 'long long'
fbmmx.c:79: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:79:20: warning: use of C99 long long integer constant
fbmmx.c:80: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:80:21: warning: use of C99 long long integer constant
fbmmx.c:81: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:81:21: warning: use of C99 long long integer constant
fbmmx.c:82: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:82:22: warning: use of C99 long long integer constant
fbmmx.c:83: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:83:20: warning: use of C99 long long integer constant
fbmmx.c:84: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:84:20: warning: use of C99 long long integer constant
fbmmx.c:85: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:85:20: warning: use of C99 long long integer constant
fbmmx.c:86: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:86:21: warning: use of C99 long long integer constant
fbmmx.c:87: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:87:21: warning: use of C99 long long integer constant
fbmmx.c:88: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:88:21: warning: use of C99 long long integer constant
fbmmx.c:89: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:89:21: warning: use of C99 long long integer constant
fbmmx.c:90: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:90:25: warning: use of C99 long long integer constant
fbmmx.c:91: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:91:34: warning: use of C99 long long integer constant
fbmmx.c:92: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:92:30: warning: use of C99 long long integer constant
fbmmx.c:93: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:93:30: warning: use of C99 long long integer constant
fbmmx.c:94: warning: ISO C90 forbids specifying subobject to initialize
fbmmx.c:94:30: warning: use of C99 long long integer constant
fbmmx.c: In function 'expand565':
fbmmx.c:306: warning: ISO C90 forbids mixed declarations and code
fbmmx.c: In function 'fbCompositeSolidMask_nx8x8888mmx':
fbmmx.c:658: warning: ISO C90 does not support 'long long'
fbmmx.c:701: warning: ISO C90 does not support 'long long'
fbmmx.c: In function 'fbCompositeSolidMask_nx8x0565mmx':
fbmmx.c:764: warning: ISO C90 does not support 'long long'
fbmmx.c:824: warning: ISO C90 does not support 'long long'
fbmmx.c:871: error: unable to find a register to spill in class 'NO_REGS'
fbmmx.c:871: error: this is the insn:
(insn:HI 334 332 337 16 (set (reg:V2SI 29 mm0 [610])
        (and:V2SI (subreg:V2SI (const_int -65536 [0xffff0000]) 0)            (mem/s/u/c:V2SI (symbol_ref:SI ("c") [flags 0x2] <var_decl 0xb7b6c688 c>) [52 c.mmx_zero+0 S8 A32]))) 850 {mmx_andv2si3} (insn_list:REG_DEP_TRUE 331 (insn_list:REG_DEP_TRUE 304 (nil)))
    (nil))
fbmmx.c:871: confused by earlier errors, bailing out
make[5]: *** [fbmmx.o] Error 1
make[5]: Leaving directory `/var/tmp/portage/vnc-4.0-r2/work/vnc-4.0-unixsrc/xc/programs/Xserver/fb'
make[4]: *** [fb] Error 2
make[4]: Leaving directory `/var/tmp/portage/vnc-4.0-r2/work/vnc-4.0-unixsrc/xc/programs/Xserver'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/vnc-4.0-r2/work/vnc-4.0-unixsrc/xc/programs'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/vnc-4.0-r2/work/vnc-4.0-unixsrc/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/var/tmp/portage/vnc-4.0-r2/work/vnc-4.0-unixsrc/xc'
make: *** [World] Error 2

!!! ERROR: net-misc/vnc-4.0-r2 failed.
!!! Function src_compile, Line 85, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
Comment 7 Todd Marimon 2006-06-08 22:48:47 UTC
The ebuild from comment #5 using X 6.9.0 works just fine.
Comment 8 Alexander Skwar 2006-06-22 02:08:54 UTC
I'm seeing this as well.

Is bug #136243 a dupe of this?
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-08-16 15:06:38 UTC
*** Bug 144158 has been marked as a duplicate of this bug. ***
Comment 10 Raúl Porcel (RETIRED) gentoo-dev 2006-08-17 08:22:31 UTC
Try using the 4.1.2 version in the tree.
Comment 11 SpanKY gentoo-dev 2006-08-28 00:55:49 UTC
the 4.1.2 version works with gcc-4
Comment 12 Christian Faulhammer (RETIRED) gentoo-dev 2006-09-13 23:36:27 UTC
*** Bug 147532 has been marked as a duplicate of this bug. ***
Comment 13 Rafael Kolless 2006-09-14 11:01:50 UTC
as gcc-4.1.1 is stable now and the main compiler for upcoming installations vnc 4.0 should not be stable for x86 anymore because it cannot compile clearly and rebuilds will fail also.

The masked version 4.1.2 which is working depends on the masked version xorg-server-1.1.

I would like to request masking version 4.0 for x86. 
Comment 14 Mike Nugent 2006-09-30 03:21:17 UTC
Created attachment 98431 [details, diff]
Patch for gcc 4.1.1

This patch modifies vnc-4.1.2 to use xorg-server 1.0.2-r7 with the "server" flag.  ./configure --enable-xvnc must be enabled (or enabled in the ebuild).  It builds under gcc 4.1.1 on 2006.1

Any information related to using this in conjunction with the composite manager would be appreciated.
Comment 15 Antonino Catinello 2006-10-15 04:54:39 UTC
Why is 4.0-r1 still marked as stable if it isn't able to be compiled with the stable marked gcc (4.1.1)? That makes no sense to me ...
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2006-10-15 04:57:18 UTC
Read Bug 145371.

Closed.