Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 125064

Summary: anjuta fails to emerge
Product: Gentoo Linux Reporter: Tomasz Wegrzanowski <Tomasz.Wegrzanowski>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Tomasz Wegrzanowski 2006-03-05 03:33:19 UTC
Last messages of emerge anjuta:

checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/anjuta-1.2.4-r1/work/anjuta-1.2.4/config.log

!!! ERROR: dev-util/anjuta-1.2.4-r1 failed.
Call stack:
  ebuild.sh, line 1933:   Called dyn_compile
  ebuild.sh, line 971:   Called src_compile
  ebuild.sh, line 1648:   Called gnome2_src_compile
  gnome2.eclass, line 47:   Called gnome2_src_configure
  gnome2.eclass, line 41:   Called econf 'compile'

Contents of /var/tmp/portage/anjuta-1.2.4-r1/work/anjuta-1.2.4/config.log:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-gtk-doc --build=i686-pc-linux-gnu

## --------- ##
## Platform. ##
## --------- ##

hostname = tavaiah
uname -m = i686
uname -r = 2.6.15-gentoo-r1
uname -s = Linux
uname -v = #1 SMP Fri Feb 3 11:27:36 CET 2006

/usr/bin/uname -p = AMD Athlon(tm) Processor
/bin/uname -X     = unknown

/bin/arch              = i686
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /sbin
PATH: /usr/sbin
PATH: /usr/lib/portage/bin
PATH: /bin
PATH: /usr/bin
PATH: /opt/bin
PATH: /usr/athena/sbin
PATH: /usr/i686-pc-linux-gnu/gcc-bin/3.3.6
PATH: /opt/ghc/bin
PATH: /opt/sun-jdk-1.5.0.06/bin
PATH: /opt/sun-jdk-1.5.0.06/jre/bin
PATH: /usr/bin
PATH: /usr/kde/3.5/sbin
PATH: /usr/kde/3.5/bin
PATH: /usr/qt/3/bin
PATH: /usr/kde/3.4/sbin
PATH: /usr/kde/3.4/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1630: checking for a BSD-compatible install
configure:1685: result: /bin/install -c
configure:1696: checking whether build environment is sane
configure:1739: result: yes
configure:1804: checking for gawk
configure:1820: found /bin/gawk
configure:1830: result: gawk
configure:1840: checking whether make sets $(MAKE)
configure:1860: result: yes
configure:2156: checking for perl
configure:2174: found /usr/bin/perl
configure:2186: result: /usr/bin/perl
configure:2204: checking for XML::Parser
configure:2210: error: XML::Parser perl module is required for intltool

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_ANJUTA_CFLAGS_set=
ac_cv_env_ANJUTA_CFLAGS_value=
ac_cv_env_ANJUTA_LIBS_set=
ac_cv_env_ANJUTA_LIBS_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-O2 -march=athlon -pipe'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=set
ac_cv_env_CXXFLAGS_value='-O2 -march=athlon -pipe'
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_F77_set=
ac_cv_env_F77_value=
ac_cv_env_FFLAGS_set=
ac_cv_env_FFLAGS_value=
ac_cv_env_GLIB_CFLAGS_set=
ac_cv_env_GLIB_CFLAGS_value=
ac_cv_env_GLIB_LIBS_set=
ac_cv_env_GLIB_LIBS_value=
ac_cv_env_GTK_CFLAGS_set=
ac_cv_env_GTK_CFLAGS_value=
ac_cv_env_GTK_LIBS_set=
ac_cv_env_GTK_LIBS_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_VTE_CFLAGS_set=
ac_cv_env_VTE_CFLAGS_value=
ac_cv_env_VTE_LIBS_set=
ac_cv_env_VTE_LIBS_value=
ac_cv_env_build_alias_set=set
ac_cv_env_build_alias_value=i686-pc-linux-gnu
ac_cv_env_host_alias_set=set
ac_cv_env_host_alias_value=i686-pc-linux-gnu
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_INTLTOOL_PERL=/usr/bin/perl
ac_cv_path_install='/bin/install -c'
ac_cv_prog_AWK=gawk
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /var/tmp/portage/anjuta-1.2.4-r1/work/anjuta-1.2.4/missing --run aclocal-1.9'
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR='${SHELL} /var/tmp/portage/anjuta-1.2.4-r1/work/anjuta-1.2.4/missing --run tar'
ANJUTA_CFLAGS=''
ANJUTA_LIBS=''
AR=''
AUTOCONF='${SHELL} /var/tmp/portage/anjuta-1.2.4-r1/work/anjuta-1.2.4/missing --run autoconf'
AUTOHEADER='${SHELL} /var/tmp/portage/anjuta-1.2.4-r1/work/anjuta-1.2.4/missing --run autoheader'
AUTOMAKE='${SHELL} /var/tmp/portage/anjuta-1.2.4-r1/work/anjuta-1.2.4/missing --run automake-1.9'
AWK='gawk'
BONOBO_REQUIRED='2.0.0'
BONOBO_UI_REQUIRED='2.0.1'
CATALOGS=''
CATOBJEXT=''
CC=''
CCDEPMODE=''
CFLAGS='-O2 -march=athlon -pipe'
CPP=''
CPPFLAGS=''
CXX=''
CXXCPP=''
CXXDEPMODE=''
CXXFLAGS='-O2 -march=athlon -pipe'
CYGPATH_W='echo'
DATADIRNAME=''
DEFS=''
DEPDIR=''
ECHO='echo'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
F77=''
FFLAGS=''
FREEBSD_BUILD=''
GDK_PIXBUF_REQUIRED='2.0.0'
GETTEXT_PACKAGE=''
GLIB_CFLAGS=''
GLIB_GENMARSHAL=''
GLIB_LIBS=''
GLIB_MKENUMS=''
GLIB_REQUIRED='2.0.6'
GMAKE=''
GMOFILES=''
GMSGFMT=''
GNOME_PRINT_REQUIRED='2.0.1'
GNOME_PRINT_UI_REQUIRED='2.0.1'
GNOME_REQUIRED='2.0.2'
GNOME_UI_REQUIRED='2.0.2'
GNOME_VFS_REQUIRED='2.0.2'
GTK_CFLAGS=''
GTK_LIBS=''
GTK_REQUIRED='2.0.8'
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
INSTOBJEXT=''
INTLLIBS=''
INTLTOOL_CAVES_RULE='%.caves:     %.caves.in     $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_DESKTOP_RULE='%.desktop:   %.desktop.in   $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_DIRECTORY_RULE='%.directory: %.directory.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_EXTRACT='$(top_builddir)/intltool-extract'
INTLTOOL_ICONV=''
INTLTOOL_KBD_RULE='%.kbd:       %.kbd.in       $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -m -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_KEYS_RULE='%.keys:      %.keys.in      $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -k -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_MERGE='$(top_builddir)/intltool-merge'
INTLTOOL_MSGFMT=''
INTLTOOL_MSGMERGE=''
INTLTOOL_OAF_RULE='%.oaf:       %.oaf.in       $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -o -p $(top_srcdir)/po $< $@'
INTLTOOL_PERL='/usr/bin/perl'
INTLTOOL_PONG_RULE='%.pong:      %.pong.in      $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_PROP_RULE='%.prop:      %.prop.in      $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_SCHEMAS_RULE='%.schemas:   %.schemas.in   $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -s -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_SERVER_RULE='%.server:    %.server.in    $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -o -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_SHEET_RULE='%.sheet:     %.sheet.in     $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_SOUNDLIST_RULE='%.soundlist: %.soundlist.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_THEME_RULE='%.theme:     %.theme.in     $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_UI_RULE='%.ui:        %.ui.in        $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_UPDATE='$(top_builddir)/intltool-update'
INTLTOOL_XAM_RULE='%.xam:       %.xml.in       $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
INTLTOOL_XGETTEXT=''
INTLTOOL_XML_NOMERGE_RULE='%.xml:       %.xml.in       $(INTLTOOL_MERGE) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u /tmp $< $@'
INTLTOOL_XML_RULE='%.xml:       %.xml.in       $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@'
LDFLAGS=''
LIBGLADE_REQUIRED='2.0.0'
LIBICONV=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LIBXML_REQUIRED='2.4.23'
LN_S=''
LTLIBICONV=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /var/tmp/portage/anjuta-1.2.4-r1/work/anjuta-1.2.4/missing --run makeinfo'
MKINSTALLDIRS=''
MSGFMT=''
NO_PREFIX_PACKAGE_DATA_DIR=''
NO_PREFIX_PACKAGE_DOC_DIR=''
NO_PREFIX_PACKAGE_HELP_DIR=''
NO_PREFIX_PACKAGE_MENU_DIR=''
NO_PREFIX_PACKAGE_PIXMAPS_DIR=''
NO_PREFIX_PACKAGE_PLUGIN_DIR=''
OBJEXT=''
OLD_VTE=''
ORBIT_REQUIRED='2.4.0'
PACKAGE='anjuta'
PACKAGE_BUGREPORT=''
PACKAGE_DATA_DIR=''
PACKAGE_DOC_DIR=''
PACKAGE_HELP_DIR=''
PACKAGE_MENU_DIR=''
PACKAGE_NAME=''
PACKAGE_PIXMAPS_DIR=''
PACKAGE_PLUGIN_DIR=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_VERSION=''
PANGO_REQUIRED='1.1.1'
PATH_SEPARATOR=':'
PCRE_CFLAGS=''
PCRE_CONFIG=''
PCRE_LIBS=''
PCRE_REQUIRED='3.9'
PKGCONFIG_CONFIG=''
PKG_CONFIG=''
POFILES=''
POSUB=''
PO_IN_DATADIR_FALSE=''
PO_IN_DATADIR_TRUE=''
PREF_SUFFIX=''
RANLIB=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
SYSTEM_DATA_DIR=''
USE_NLS=''
VERSION='1.2.4'
VTE_CFLAGS=''
VTE_LIBS=''
VTE_NEW_REQUIRED='0.9.0'
VTE_REQUIRED='0.7.0'
XGETTEXT=''
ac_ct_AR=''
ac_ct_CC=''
ac_ct_CXX=''
ac_ct_F77=''
ac_ct_RANLIB=''
ac_ct_STRIP=''
ac_pt_PKG_CONFIG=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE=''
am__fastdepCXX_TRUE=''
am__include=''
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build='i686-pc-linux-gnu'
build_alias='i686-pc-linux-gnu'
build_cpu=''
build_os=''
build_vendor=''
datadir='/usr/share'
exec_prefix='NONE'
host='i686-pc-linux-gnu'
host_alias='i686-pc-linux-gnu'
host_cpu=''
host_os=''
host_vendor=''
includedir='${prefix}/include'
infodir='/usr/share/info'
install_sh='/var/tmp/portage/anjuta-1.2.4-r1/work/anjuta-1.2.4/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='/var/lib'
mandir='/usr/share/man'
mkdir_p='mkdir -p --'
oldincludedir='/usr/include'
prefix='/usr'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE "anjuta"
#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PREF_SUFFIX ""
#define VERSION "1.2.4"

configure: exit 1
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-03-05 04:56:19 UTC
run perl-cleaner

*** This bug has been marked as a duplicate of 41124 ***